diff mbox series

[next,1/1] package/weston: enable libseat launcher if seatd is enabled

Message ID 20210527133503.412330-1-aperez@igalia.com
State Accepted
Headers show
Series [next,1/1] package/weston: enable libseat launcher if seatd is enabled | expand

Commit Message

Adrian Perez de Castro May 27, 2021, 1:35 p.m. UTC
Enable building Weston's libseat launcher, now that the seatd package
is available.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 package/weston/weston.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Yann E. MORIN June 16, 2021, 7:37 p.m. UTC | #1
Adrian, All,

On 2021-05-27 16:35 +0300, Adrian Perez de Castro spake thusly:
> Enable building Weston's libseat launcher, now that the seatd package
> is available.
> 
> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/weston/weston.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> index f59963bf2e..6afc5e269c 100644
> --- a/package/weston/weston.mk
> +++ b/package/weston/weston.mk
> @@ -25,6 +25,13 @@ else
>  WESTON_CONF_OPTS += -Dsimple-clients=
>  endif
>  
> +ifeq ($(BR2_PACKAGE_SEATD),y)
> +WESTON_CONF_OPTS += -Dlauncher-libseat=true
> +WESTON_DEPENDENCIES += seatd
> +else
> +WESTON_CONF_OPTS += -Dlauncher-libseat=false
> +endif
> +
>  ifeq ($(BR2_PACKAGE_DBUS)$(BR2_PACKAGE_SYSTEMD),yy)
>  WESTON_CONF_OPTS += -Dlauncher-logind=true
>  WESTON_DEPENDENCIES += dbus systemd
> -- 
> 2.31.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index f59963bf2e..6afc5e269c 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -25,6 +25,13 @@  else
 WESTON_CONF_OPTS += -Dsimple-clients=
 endif
 
+ifeq ($(BR2_PACKAGE_SEATD),y)
+WESTON_CONF_OPTS += -Dlauncher-libseat=true
+WESTON_DEPENDENCIES += seatd
+else
+WESTON_CONF_OPTS += -Dlauncher-libseat=false
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS)$(BR2_PACKAGE_SYSTEMD),yy)
 WESTON_CONF_OPTS += -Dlauncher-logind=true
 WESTON_DEPENDENCIES += dbus systemd