diff mbox series

[2/3] package/libglib2: add -Dxattr=true when libselinux is selected

Message ID 20210501195620.910716-2-aduskett@gmail.com
State New
Headers show
Series [1/3] package/libglib2: bump to version 2.68.1 | expand

Commit Message

Adam Duskett May 1, 2021, 7:56 p.m. UTC
Xattrs is required for SELinux. Explicitly enable the feature when the
libselinux package is selected.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/libglib2/libglib2.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index b5554d6b56..e3263ce9ce 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -77,10 +77,10 @@  LIBGLIB2_DEPENDENCIES += libiconv
 endif
 
 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
-LIBGLIB2_CONF_OPTS += -Dselinux=enabled
+LIBGLIB2_CONF_OPTS += -Dselinux=enabled -Dxattr=true
 LIBGLIB2_DEPENDENCIES += libselinux
 else
-LIBGLIB2_CONF_OPTS += -Dselinux=disabled
+LIBGLIB2_CONF_OPTS += -Dselinux=disabled -Dxattr=false
 endif
 
 # Purge gdb-related files