diff mbox series

[1/1] package/go: bump version to 1.16.3

Message ID 20210403064538.17449-1-christian@paral.in
State Accepted
Headers show
Series [1/1] package/go: bump version to 1.16.3 | expand

Commit Message

Christian Stewart April 3, 2021, 6:45 a.m. UTC
go1.16.3 (released 2021/04/01) includes fixes to the compiler, linker, runtime,
the go command, and the testing and time packages.

https://golang.org/doc/go1.16

Signed-off-by: Christian Stewart <christian@paral.in>
---
 package/go/go.hash | 4 ++--
 package/go/go.mk   | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN April 3, 2021, 7:03 a.m. UTC | #1
Christian, All,

On 2021-04-02 23:45 -0700, Christian Stewart spake thusly:
> go1.16.3 (released 2021/04/01) includes fixes to the compiler, linker, runtime,
> the go command, and the testing and time packages.
> 
> https://golang.org/doc/go1.16
> 
> Signed-off-by: Christian Stewart <christian@paral.in>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/go/go.hash | 4 ++--
>  package/go/go.mk   | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/go/go.hash b/package/go/go.hash
> index 524b6131dc..6d8759f97f 100644
> --- a/package/go/go.hash
> +++ b/package/go/go.hash
> @@ -1,3 +1,3 @@
>  # From https://golang.org/dl/
> -sha256  37ca14287a23cb8ba2ac3f5c3dd8adbc1f7a54b9701a57824bf19a0b271f83ea  go1.16.2.src.tar.gz
> -sha256	2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
> +sha256  b298d29de9236ca47a023e382313bcc2d2eed31dfa706b60a04103ce83a71a25  go1.16.3.src.tar.gz
> +sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
> diff --git a/package/go/go.mk b/package/go/go.mk
> index ff12fb0c62..138b1cbd34 100644
> --- a/package/go/go.mk
> +++ b/package/go/go.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -GO_VERSION = 1.16.2
> +GO_VERSION = 1.16.3
>  GO_SITE = https://storage.googleapis.com/golang
>  GO_SOURCE = go$(GO_VERSION).src.tar.gz
>  
> -- 
> 2.31.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard April 4, 2021, 9:36 a.m. UTC | #2
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > go1.16.3 (released 2021/04/01) includes fixes to the compiler, linker, runtime,
 > the go command, and the testing and time packages.

 > https://golang.org/doc/go1.16

 > Signed-off-by: Christian Stewart <christian@paral.in>

For 2020.11.x / 2021.02.x I have instead bumped to 1.15.11, which
contains the same set of fixes.
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 524b6131dc..6d8759f97f 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://golang.org/dl/
-sha256  37ca14287a23cb8ba2ac3f5c3dd8adbc1f7a54b9701a57824bf19a0b271f83ea  go1.16.2.src.tar.gz
-sha256	2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
+sha256  b298d29de9236ca47a023e382313bcc2d2eed31dfa706b60a04103ce83a71a25  go1.16.3.src.tar.gz
+sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index ff12fb0c62..138b1cbd34 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.16.2
+GO_VERSION = 1.16.3
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz