diff mbox series

package/mender: add nodbus to tags if dbus is not selected

Message ID 20210401154453.144605-3-aduskett@gmail.com
State Accepted
Headers show
Series package/mender: add nodbus to tags if dbus is not selected | expand

Commit Message

Adam Duskett April 1, 2021, 3:44 p.m. UTC
The README.md file suggests passing "nodbus" as a tag if dbus is not selected.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/mender/mender.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni April 1, 2021, 3:59 p.m. UTC | #1
On Thu,  1 Apr 2021 08:44:53 -0700
Adam Duskett <aduskett@gmail.com> wrote:

> The README.md file suggests passing "nodbus" as a tag if dbus is not selected.
> 
> Signed-off-by: Adam Duskett <aduskett@gmail.com>

Interesting. What does it do, if D-Bus is not a build dependency, what
there is to enable/disable within the Mender code base?

Thanks!

Thomas
Adam Duskett April 1, 2021, 4:38 p.m. UTC | #2
Hey Thomas;

It looks like passing nodbus disables building the following files:
./dbus/dbus_libgio_helpers.go
./dbus/error.go
./dbus/dbus_libgio_test.go
./dbus/dbus_libgio.go
./dbus/dbus_test.go
./dbus/error_test.go

It also looks like if dbus isn't found, config.DBus.Enabled is set
to false in config.go. Although it's probably better to err on the
side of caution and follow the README.md's instructions yeah?

Adam

On Thu, Apr 1, 2021 at 8:59 AM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> On Thu,  1 Apr 2021 08:44:53 -0700
> Adam Duskett <aduskett@gmail.com> wrote:
>
> > The README.md file suggests passing "nodbus" as a tag if dbus is not selected.
> >
> > Signed-off-by: Adam Duskett <aduskett@gmail.com>
>
> Interesting. What does it do, if D-Bus is not a build dependency, what
> there is to enable/disable within the Mender code base?
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
diff mbox series

Patch

diff --git a/package/mender/mender.mk b/package/mender/mender.mk
index 1ebd5a2e83..c2bee71d93 100644
--- a/package/mender/mender.mk
+++ b/package/mender/mender.mk
@@ -93,6 +93,8 @@  define MENDER_INSTALL_DBUS_AUTHENTICATION_MANAGER_CONF
 		      $(TARGET_DIR)/etc/dbus-1/system.d/io.mender.AuthenticationManager.conf
 endef
 MENDER_POST_INSTALL_TARGET_HOOKS += MENDER_INSTALL_DBUS_AUTHENTICATION_MANAGER_CONF
+else
+MENDER_TAGS += nodbus
 endif
 
 define MENDER_INSTALL_INIT_SYSTEMD