diff mbox series

[1/1] package/go: bump version to 1.16

Message ID 20210217222154.2144796-1-christian@paral.in
State Superseded
Headers show
Series [1/1] package/go: bump version to 1.16 | expand

Commit Message

Christian Stewart Feb. 17, 2021, 10:21 p.m. UTC
Release notes: https://golang.org/doc/go1.16

The latest Go release, version 1.16, arrives six months after Go 1.15. Most of
its changes are in the implementation of the toolchain, runtime, and libraries.

The linker changes in 1.16 extend the 1.15 improvements to all supported
architecture/OS combinations (the 1.15 performance improvements were primarily
focused on ELF-based OSes and amd64 architectures). For a representative set of
large Go programs, linking is 20-25% faster than 1.15 and requires 5-15% less
memory on average for linux/amd64, with larger improvements for other
architectures and OSes. Most binaries are also smaller as a result of more
aggressive symbol pruning.

Signed-off-by: Christian Stewart <christian@paral.in>
---
 package/go/go.hash | 2 +-
 package/go/go.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Feb. 18, 2021, 10:37 a.m. UTC | #1
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > Release notes: https://golang.org/doc/go1.16

The release notes mention changes for i386 machines without SSE support,
but you don't seem to be handling that?
Christian Stewart Feb. 19, 2021, 11:52 a.m. UTC | #2
On Thu, Feb 18, 2021 at 2:37 AM Peter Korsgaard <peter@korsgaard.com> wrote:
>
> >>>>> "Christian" == Christian Stewart <christian@paral.in> writes:
>
>  > Release notes: https://golang.org/doc/go1.16
>
> The release notes mention changes for i386 machines without SSE support,
> but you don't seem to be handling that?

I guess you're talking about this section:

 As announced in the Go 1.15 release notes, Go 1.16 drops support for
x87 mode compilation (GO386=387). Support for non-SSE2 processors is
now available using soft float mode (GO386=softfloat). Users running
on non-SSE2 processors should replace GO386=387 with GO386=softfloat.

We don't set GO386 so it doesn't apply.

Best,
Christian
Peter Korsgaard Feb. 19, 2021, 12:22 p.m. UTC | #3
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > On Thu, Feb 18, 2021 at 2:37 AM Peter Korsgaard <peter@korsgaard.com> wrote:
 >> 
 >> >>>>> "Christian" == Christian Stewart <christian@paral.in> writes:
 >> 
 >> > Release notes: https://golang.org/doc/go1.16
 >> 
 >> The release notes mention changes for i386 machines without SSE support,
 >> but you don't seem to be handling that?

 > I guess you're talking about this section:

 >  As announced in the Go 1.15 release notes, Go 1.16 drops support for
 > x87 mode compilation (GO386=387). Support for non-SSE2 processors is
 > now available using soft float mode (GO386=softfloat). Users running
 > on non-SSE2 processors should replace GO386=387 with GO386=softfloat.

 > We don't set GO386 so it doesn't apply.

But using SSE2 presumably means that go applications built for i386 will
only run on machines with SSE2 support, so as a minimum we need to
adjust BR2_PACKAGE_HOST_GO_TARGET_ARCH_SUPPORTS to ensure go is not
available on older i386 variants?
Christian Stewart Feb. 19, 2021, 12:27 p.m. UTC | #4
Hi Peter,

On Fri, Feb 19, 2021 at 4:22 AM Peter Korsgaard <peter@korsgaard.com> wrote:
>  >  As announced in the Go 1.15 release notes, Go 1.16 drops support for
>  > x87 mode compilation (GO386=387). Support for non-SSE2 processors is
>  > now available using soft float mode (GO386=softfloat). Users running
>  > on non-SSE2 processors should replace GO386=387 with GO386=softfloat.
>
>  > We don't set GO386 so it doesn't apply.
>
> But using SSE2 presumably means that go applications built for i386 will
> only run on machines with SSE2 support, so as a minimum we need to
> adjust BR2_PACKAGE_HOST_GO_TARGET_ARCH_SUPPORTS to ensure go is not
> available on older i386 variants?

Better to just set GO386=softfloat for older i386 variants without SSE2.

IMO, this seems like a separate issue from the version bump.

Best regards,
Christian
Peter Korsgaard Feb. 19, 2021, 12:42 p.m. UTC | #5
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > Hi Peter,
 > On Fri, Feb 19, 2021 at 4:22 AM Peter Korsgaard <peter@korsgaard.com> wrote:
 >> >  As announced in the Go 1.15 release notes, Go 1.16 drops support for
 >> > x87 mode compilation (GO386=387). Support for non-SSE2 processors is
 >> > now available using soft float mode (GO386=softfloat). Users running
 >> > on non-SSE2 processors should replace GO386=387 with GO386=softfloat.
 >> 
 >> > We don't set GO386 so it doesn't apply.
 >> 
 >> But using SSE2 presumably means that go applications built for i386 will
 >> only run on machines with SSE2 support, so as a minimum we need to
 >> adjust BR2_PACKAGE_HOST_GO_TARGET_ARCH_SUPPORTS to ensure go is not
 >> available on older i386 variants?

 > Better to just set GO386=softfloat for older i386 variants without SSE2.

 > IMO, this seems like a separate issue from the version bump.

Why? Isn't that new behaviour? If so, this should be fixed as part of
the version bump.
Christian Stewart Feb. 19, 2021, 11:50 p.m. UTC | #6
Hi Peter,

On Fri, Feb 19, 2021 at 4:42 AM Peter Korsgaard <peter@korsgaard.com> wrote:
>  >> > We don't set GO386 so it doesn't apply.
>  >>
>  >> But using SSE2 presumably means that go applications built for i386 will
>  >> only run on machines with SSE2 support, so as a minimum we need to
>  >> adjust BR2_PACKAGE_HOST_GO_TARGET_ARCH_SUPPORTS to ensure go is not
>  >> available on older i386 variants?
>
>  > Better to just set GO386=softfloat for older i386 variants without SSE2.
>
>  > IMO, this seems like a separate issue from the version bump.
>
> Why? Isn't that new behaviour? If so, this should be fixed as part of
> the version bump.

OK, I will submit a v2 which sets it if SSE2 is unavailable.

Defconfig:

BR2_x86_i486=y
BR2_TOOLCHAIN_BUILDROOT_GLIBC=y
BR2_PACKAGE_RUNC=y

In v2 it should set

$(if $(GO_GO386),GO386=$(GO_GO386))

# i386: use softfloat if no SSE2: https://golang.org/doc/go1.16#386
ifneq ($(BR2_X86_CPU_HAS_SSE2),y)
GO_GO386 = softfloat
endif

Best,
Christian
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index cbc82a9b64..4181fb52c5 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,3 +1,3 @@ 
 # From https://golang.org/dl/
-sha256  540c0ab7781084d124991321ed1458e479982de94454a98afab6acadf38497c2  go1.15.8.src.tar.gz
+sha256  7688063d55656105898f323d90a79a39c378d86fe89ae192eb3b7fc46347c95a  go1.16.src.tar.gz
 sha256	2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
diff --git a/package/go/go.mk b/package/go/go.mk
index 7b7f173706..9946682730 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.15.8
+GO_VERSION = 1.16
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz