diff mbox series

package/tcpdump: remove duplicated binary

Message ID 20210216125031.2244-1-patrickdepinguin@gmail.com
State Accepted
Headers show
Series package/tcpdump: remove duplicated binary | expand

Commit Message

Thomas De Schampheleire Feb. 16, 2021, 12:50 p.m. UTC
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Since tcpdump 4.99.0, the 'tcpdump' binary is no longer installed in
/usr/sbin but in /usr/bin. This change invalidates the Buildroot hook
'TCPDUMP_REMOVE_DUPLICATED_BINARY', causing a fairly large rootfs size
increase as a result.

Update the path inside this hook.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
 package/tcpdump/tcpdump.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Feb. 16, 2021, 7:46 p.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 > Since tcpdump 4.99.0, the 'tcpdump' binary is no longer installed in
 > /usr/sbin but in /usr/bin. This change invalidates the Buildroot hook
 > 'TCPDUMP_REMOVE_DUPLICATED_BINARY', causing a fairly large rootfs size
 > increase as a result.

 > Update the path inside this hook.

 > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Committed, thanks.
Baruch Siach Feb. 16, 2021, 7:46 p.m. UTC | #2
Hi Thomas,

On Tue, Feb 16 2021, Thomas De Schampheleire wrote:

> From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
>
> Since tcpdump 4.99.0, the 'tcpdump' binary is no longer installed in
> /usr/sbin but in /usr/bin. This change invalidates the Buildroot hook
> 'TCPDUMP_REMOVE_DUPLICATED_BINARY', causing a fairly large rootfs size
> increase as a result.
>
> Update the path inside this hook.
>
> Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Acked-by: Baruch Siach <baruch@tkos.co.il>

Thanks,
baruch

> ---
>  package/tcpdump/tcpdump.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
> index f8ea6576ee..c562034a4e 100644
> --- a/package/tcpdump/tcpdump.mk
> +++ b/package/tcpdump/tcpdump.mk
> @@ -22,7 +22,7 @@ TCPDUMP_SELINUX_MODULES = netutils
>  
>  # make install installs an unneeded extra copy of the tcpdump binary
>  define TCPDUMP_REMOVE_DUPLICATED_BINARY
> -	rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
> +	rm -f $(TARGET_DIR)/usr/bin/tcpdump.$(TCPDUMP_VERSION)
>  endef
>  
>  TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY
diff mbox series

Patch

diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
index f8ea6576ee..c562034a4e 100644
--- a/package/tcpdump/tcpdump.mk
+++ b/package/tcpdump/tcpdump.mk
@@ -22,7 +22,7 @@  TCPDUMP_SELINUX_MODULES = netutils
 
 # make install installs an unneeded extra copy of the tcpdump binary
 define TCPDUMP_REMOVE_DUPLICATED_BINARY
-	rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
+	rm -f $(TARGET_DIR)/usr/bin/tcpdump.$(TCPDUMP_VERSION)
 endef
 
 TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY