diff mbox series

package/opkg-utils: needs Python3 on the host

Message ID 20201209151551.21986-1-patrickdepinguin@gmail.com
State Accepted
Headers show
Series package/opkg-utils: needs Python3 on the host | expand

Commit Message

Thomas De Schampheleire Dec. 9, 2020, 3:15 p.m. UTC
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

The 'opkg.py' script installed by host-opkg-utils has as shebang:
    #!/usr/bin/env python3

which may not be available on all host machines.
Add a potential dependency on host-python3 via BR2_PYTHON3_HOST_DEPENDENCY,
which will only add the host-python3 dependency if no python3 is already
available on the host.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
 package/opkg-utils/opkg-utils.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Korsgaard Dec. 21, 2020, 9:26 a.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 > The 'opkg.py' script installed by host-opkg-utils has as shebang:
 >     #!/usr/bin/env python3

 > which may not be available on all host machines.
 > Add a potential dependency on host-python3 via BR2_PYTHON3_HOST_DEPENDENCY,
 > which will only add the host-python3 dependency if no python3 is already
 > available on the host.

 > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Committed, thanks.
Peter Korsgaard Dec. 22, 2020, 10:51 a.m. UTC | #2
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 > The 'opkg.py' script installed by host-opkg-utils has as shebang:
 >     #!/usr/bin/env python3

 > which may not be available on all host machines.
 > Add a potential dependency on host-python3 via BR2_PYTHON3_HOST_DEPENDENCY,
 > which will only add the host-python3 dependency if no python3 is already
 > available on the host.

 > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Committed to 2020.02.x, 2020.08.x and 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
index fa14053f65..a94a4cd5cd 100644
--- a/package/opkg-utils/opkg-utils.mk
+++ b/package/opkg-utils/opkg-utils.mk
@@ -10,6 +10,8 @@  OPKG_UTILS_SITE_METHOD = git
 OPKG_UTILS_LICENSE = GPL-2.0+
 OPKG_UTILS_LICENSE_FILES = COPYING
 
+HOST_OPKG_UTILS_DEPENDENCIES += $(BR2_PYTHON3_HOST_DEPENDENCY)
+
 define HOST_OPKG_UTILS_BUILD_CMDS
 	$(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS)
 endef