diff mbox series

package/nginx: use /run instead of /var/run

Message ID 20201015101137.32333-1-buildroot@heine.tech
State Accepted
Headers show
Series package/nginx: use /run instead of /var/run | expand

Commit Message

Michael Nosthoff Oct. 15, 2020, 10:11 a.m. UTC
This is a follow-up to 4027ba29f448 ("package/nginx: use /run for
PIDFile").

I missed that nginx is still built with /var/run paths.

This commit changes the compile options to use /run instead of /var/run
for pid and lock file to make it consistent.

Further dropping the passing of the pid option in the service file as
this isn't neccessary. Neither debian nor nginx default .service does
it.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---
 package/nginx/nginx.mk      | 4 ++--
 package/nginx/nginx.service | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni Oct. 25, 2020, 9:30 a.m. UTC | #1
On Thu, 15 Oct 2020 12:11:36 +0200
Michael Nosthoff via buildroot <buildroot@busybox.net> wrote:

> This is a follow-up to 4027ba29f448 ("package/nginx: use /run for
> PIDFile").
> 
> I missed that nginx is still built with /var/run paths.
> 
> This commit changes the compile options to use /run instead of /var/run
> for pid and lock file to make it consistent.
> 
> Further dropping the passing of the pid option in the service file as
> this isn't neccessary. Neither debian nor nginx default .service does
> it.
> 
> Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
> ---
>  package/nginx/nginx.mk      | 4 ++--
>  package/nginx/nginx.service | 8 ++++----
>  2 files changed, 6 insertions(+), 6 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Oct. 29, 2020, 10:22 p.m. UTC | #2
>>>>> "Michael" == Michael Nosthoff via buildroot <buildroot@busybox.net> writes:

 > This is a follow-up to 4027ba29f448 ("package/nginx: use /run for
 > PIDFile").

 > I missed that nginx is still built with /var/run paths.

 > This commit changes the compile options to use /run instead of /var/run
 > for pid and lock file to make it consistent.

 > Further dropping the passing of the pid option in the service file as
 > this isn't neccessary. Neither debian nor nginx default .service does
 > it.

 > Signed-off-by: Michael Nosthoff <buildroot@heine.tech>

Committed to 2020.02.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/nginx/nginx.mk b/package/nginx/nginx.mk
index 1f896bc377..00fb147682 100644
--- a/package/nginx/nginx.mk
+++ b/package/nginx/nginx.mk
@@ -49,8 +49,8 @@  NGINX_CONF_OPTS += \
 	--prefix=/usr \
 	--conf-path=/etc/nginx/nginx.conf \
 	--sbin-path=/usr/sbin/nginx \
-	--pid-path=/var/run/nginx.pid \
-	--lock-path=/var/run/lock/nginx.lock \
+	--pid-path=/run/nginx.pid \
+	--lock-path=/run/lock/nginx.lock \
 	--user=www-data \
 	--group=www-data \
 	--error-log-path=/var/log/nginx/error.log \
diff --git a/package/nginx/nginx.service b/package/nginx/nginx.service
index 9fd215fd3e..f203cecdc0 100644
--- a/package/nginx/nginx.service
+++ b/package/nginx/nginx.service
@@ -6,10 +6,10 @@  After=syslog.target network.target
 Type=forking
 PIDFile=/run/nginx.pid
 ExecStartPre=/usr/bin/mkdir -p /var/log/nginx /var/tmp/nginx
-ExecStartPre=/usr/sbin/nginx -t -q -g 'pid /var/run/nginx.pid; daemon on; master_process on;'
-ExecStart=/usr/sbin/nginx -g 'pid /var/run/nginx.pid; daemon on; master_process on;'
-ExecReload=/usr/sbin/nginx -g 'pid /var/run/nginx.pid; daemon on; master_process on;' -s reload
-ExecStop=/usr/sbin/nginx -g 'pid /var/run/nginx.pid;' -s quit
+ExecStartPre=/usr/sbin/nginx -t -q -g 'daemon on; master_process on;'
+ExecStart=/usr/sbin/nginx -g 'daemon on; master_process on;'
+ExecReload=/usr/sbin/nginx -g 'daemon on; master_process on;' -s reload
+ExecStop=/usr/sbin/nginx -s quit
 PrivateDevices=yes
 
 [Install]