diff mbox series

[1/2] package/systemd: link libqrencode independent of remote

Message ID 20201014151249.18330-2-buildroot@heine.tech
State Accepted
Headers show
Series package/systemd: unify journal remote options | expand

Commit Message

Michael Nosthoff Oct. 14, 2020, 3:12 p.m. UTC
systemds libqrencode support is independent from journal-gatewayd.
In v247 it will additionally be used in homectl for recovery key
generation.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---
 package/systemd/systemd.mk | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Thomas Petazzoni Oct. 14, 2020, 6:43 p.m. UTC | #1
On Wed, 14 Oct 2020 17:12:49 +0200
Michael Nosthoff via buildroot <buildroot@busybox.net> wrote:

> systemds libqrencode support is independent from journal-gatewayd.
> In v247 it will additionally be used in homectl for recovery key
> generation.
> 
> Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
> ---
>  package/systemd/systemd.mk | 15 ++++++++-------
>  1 file changed, 8 insertions(+), 7 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 30e28adf95..b684f538a8 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -243,14 +243,8 @@  endif
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)
 SYSTEMD_DEPENDENCIES += libmicrohttpd
 SYSTEMD_CONF_OPTS += -Dmicrohttpd=true
-ifeq ($(BR2_PACKAGE_LIBQRENCODE),y)
-SYSTEMD_CONF_OPTS += -Dqrencode=true
-SYSTEMD_DEPENDENCIES += libqrencode
 else
-SYSTEMD_CONF_OPTS += -Dqrencode=false
-endif
-else
-SYSTEMD_CONF_OPTS += -Dmicrohttpd=false -Dqrencode=false
+SYSTEMD_CONF_OPTS += -Dmicrohttpd=false
 endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_REMOTE),y)
@@ -260,6 +254,13 @@  else
 SYSTEMD_CONF_OPTS += -Dremote=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIBQRENCODE),y)
+SYSTEMD_DEPENDENCIES += libqrencode
+SYSTEMD_CONF_OPTS += -Dqrencode=true
+else
+SYSTEMD_CONF_OPTS += -Dqrencode=false
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
 SYSTEMD_DEPENDENCIES += libselinux
 SYSTEMD_CONF_OPTS += -Dselinux=true