diff mbox series

[v1,2/3] package/qt5webengine: needs libxkbcommon

Message ID 20200915180004.2335-2-ps.report@gmx.net
State Changes Requested
Headers show
Series [v1,1/3] package/qt5: bump version to 5.15.1 | expand

Commit Message

Peter Seiderer Sept. 15, 2020, 6 p.m. UTC
Fixes:
  subprocess.CalledProcessError: Command '['/home/seiderer/Work/Buildroot/build_rpi4_qt5_update_001/build/qt5webengine-5.15.1/src/core/pkg-config_wrapper.sh', '--variable=prefix', 'xkbcommon']' returned non-zero exit status 1

  See //ui/events/keycodes/BUILD.gn:12:3: whence it was called.
    pkg_config("xkbcommon") {
    ^------------------------
  See //ui/events/ozone/layout/BUILD.gn:42:15: which caused the file to be included.
      deps += [ "//ui/events/keycodes:xkb" ]
                ^-------------------------
  Project ERROR: GN run error!

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Notes:
 - send as extra patch as I am not sure if the failure is caused by
   the version bump and/or by a combination from my buildroot config
---
 package/qt5/qt5webengine/Config.in       | 1 +
 package/qt5/qt5webengine/qt5webengine.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Sept. 17, 2020, 9:05 p.m. UTC | #1
On Tue, 15 Sep 2020 20:00:03 +0200
Peter Seiderer <ps.report@gmx.net> wrote:

> Fixes:
>   subprocess.CalledProcessError: Command '['/home/seiderer/Work/Buildroot/build_rpi4_qt5_update_001/build/qt5webengine-5.15.1/src/core/pkg-config_wrapper.sh', '--variable=prefix', 'xkbcommon']' returned non-zero exit status 1
> 
>   See //ui/events/keycodes/BUILD.gn:12:3: whence it was called.
>     pkg_config("xkbcommon") {
>     ^------------------------
>   See //ui/events/ozone/layout/BUILD.gn:42:15: which caused the file to be included.
>       deps += [ "//ui/events/keycodes:xkb" ]
>                 ^-------------------------
>   Project ERROR: GN run error!
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
> Notes:
>  - send as extra patch as I am not sure if the failure is caused by
>    the version bump and/or by a combination from my buildroot config

Unfortunately, I think we really need to understand if this is a change
needed in relation to the bump or not, so that we know if it needs to
go in a stable branch.

At least in a simple build of qt5webengine in v5.15.0 I have not
encountered this particular build failure. But perhaps it occurs only
when you have a bunch of other dependencies enabled.

The BUILD.gn file contains:

if (use_xkbcommon) {
  pkg_config("xkbcommon") {
    packages = [ "xkbcommon" ]
  }
}

And src/buildtools/config/linux.pri seems to be defining the value of
use_xkbcommon:

    qtConfig(build-qtwebengine-core):qtConfig(webengine-system-xkbcommon) {
        gn_args += use_xkbcommon=true
    } else {
        gn_args += use_xkbcommon=false
    }

I've never been familiar enough with the .pri syntax though to
understand what this is doing.

Could you try to see if the problem really comes from the 5.15.1 bump ?

Thanks!

Thomas
Peter Seiderer Sept. 18, 2020, 8:01 p.m. UTC | #2
Hello Thomas,

On Thu, 17 Sep 2020 23:05:46 +0200, Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> On Tue, 15 Sep 2020 20:00:03 +0200
> Peter Seiderer <ps.report@gmx.net> wrote:
>
> > Fixes:
> >   subprocess.CalledProcessError: Command '['/home/seiderer/Work/Buildroot/build_rpi4_qt5_update_001/build/qt5webengine-5.15.1/src/core/pkg-config_wrapper.sh', '--variable=prefix', 'xkbcommon']' returned non-zero exit status 1
> >
> >   See //ui/events/keycodes/BUILD.gn:12:3: whence it was called.
> >     pkg_config("xkbcommon") {
> >     ^------------------------
> >   See //ui/events/ozone/layout/BUILD.gn:42:15: which caused the file to be included.
> >       deps += [ "//ui/events/keycodes:xkb" ]
> >                 ^-------------------------
> >   Project ERROR: GN run error!
> >
> > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> > ---
> > Notes:
> >  - send as extra patch as I am not sure if the failure is caused by
> >    the version bump and/or by a combination from my buildroot config
>
> Unfortunately, I think we really need to understand if this is a change
> needed in relation to the bump or not, so that we know if it needs to
> go in a stable branch.
>
> At least in a simple build of qt5webengine in v5.15.0 I have not
> encountered this particular build failure. But perhaps it occurs only
> when you have a bunch of other dependencies enabled.
>
> The BUILD.gn file contains:
>
> if (use_xkbcommon) {
>   pkg_config("xkbcommon") {
>     packages = [ "xkbcommon" ]
>   }
> }
>
> And src/buildtools/config/linux.pri seems to be defining the value of
> use_xkbcommon:
>
>     qtConfig(build-qtwebengine-core):qtConfig(webengine-system-xkbcommon) {
>         gn_args += use_xkbcommon=true
>     } else {
>         gn_args += use_xkbcommon=false
>     }
>
> I've never been familiar enough with the .pri syntax though to
> understand what this is doing.
>
> Could you try to see if the problem really comes from the 5.15.1 bump ?

qt5webengine-5.15.0 with the same buildroot config
compiles fine without libxkbcommon, will try qt5webengine-5.15.1
with a striped down buildroot config to evaluate if some of
my buildroot config options enable the need for libxkbcommon...

Regards,
Peter

>
> Thanks!
>
> Thomas
diff mbox series

Patch

diff --git a/package/qt5/qt5webengine/Config.in b/package/qt5/qt5webengine/Config.in
index 9879345e1e..4e923c7f31 100644
--- a/package/qt5/qt5webengine/Config.in
+++ b/package/qt5/qt5webengine/Config.in
@@ -41,6 +41,7 @@  config BR2_PACKAGE_QT5WEBENGINE
 	select BR2_PACKAGE_LIBGLIB2
 	select BR2_PACKAGE_LIBNSS
 	select BR2_PACKAGE_LIBVPX
+	select BR2_PACKAGE_LIBXKBCOMMON
 	select BR2_PACKAGE_OPUS
 	select BR2_PACKAGE_WEBP
 	select BR2_PACKAGE_WEBP_DEMUX
diff --git a/package/qt5/qt5webengine/qt5webengine.mk b/package/qt5/qt5webengine/qt5webengine.mk
index 9101f35937..64c9c96cc2 100644
--- a/package/qt5/qt5webengine/qt5webengine.mk
+++ b/package/qt5/qt5webengine/qt5webengine.mk
@@ -7,7 +7,7 @@ 
 QT5WEBENGINE_VERSION = $(QT5_VERSION)
 QT5WEBENGINE_SITE = $(QT5_SITE)
 QT5WEBENGINE_SOURCE = qtwebengine-$(QT5_SOURCE_TARBALL_PREFIX)-$(QT5WEBENGINE_VERSION).tar.xz
-QT5WEBENGINE_DEPENDENCIES = ffmpeg libglib2 libvpx opus webp \
+QT5WEBENGINE_DEPENDENCIES = ffmpeg libglib2 libvpx libxkbcommon opus webp \
 	qt5declarative qt5webchannel host-bison host-flex host-gperf \
 	host-pkgconf host-python
 QT5WEBENGINE_INSTALL_STAGING = YES