diff mbox series

[v2,2/3] package/meson: use specific BR variables for cross-compilation.conf

Message ID 20200915100546.806157-2-nolange79@gmail.com
State Superseded
Headers show
Series [v2,1/3] package/pkg-meson.mk: fix generation of pkg_config_static prop | expand

Commit Message

Norbert Lange Sept. 15, 2020, 10:05 a.m. UTC
dont depend on specific names of compiler tools, but use existing
Buildroot variables.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/meson/cross-compilation.conf.in | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Nicolas Cavallari Sept. 15, 2020, 2:05 p.m. UTC | #1
On 15/09/2020 12:05, Norbert Lange wrote:
> dont depend on specific names of compiler tools, but use existing
> Buildroot variables.
> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/meson/cross-compilation.conf.in | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/package/meson/cross-compilation.conf.in b/package/meson/cross-compilation.conf.in
> index e9344e2b2f..67c5da8156 100644
> --- a/package/meson/cross-compilation.conf.in
> +++ b/package/meson/cross-compilation.conf.in
> @@ -4,11 +4,11 @@
>  # - Buildroot's 'target' is Meson's 'host'
>  
>  [binaries]
> -c = '@TARGET_CROSS@gcc'
> -cpp = '@TARGET_CROSS@g++'
> -ar = '@TARGET_CROSS@ar'
> -strip = '@TARGET_CROSS@strip'
> -pkgconfig = '@HOST_DIR@/bin/pkgconf'
> +c = '@TARGET_CC@'
> +cpp = '@TARGET_CXX@'
> +ar = '@TARGET_AR@'
> +strip = '@TARGET_STRIP@'
> +pkgconfig = '@PKG_CONFIG_HOST_BINARY@'
>  g-ir-compiler = '@STAGING_DIR@/usr/bin/g-ir-compiler'
>  g-ir-scanner = '@STAGING_DIR@/usr/bin/g-ir-scanner'

This changes host/bin/pkgconf to host/bin/pkg-config, but that shouldn't
be a problem, given meson only uses this pkgconfig to find target
packages and not host packages (for that meson would look it up in a
native-file instead of a cross-file).

Also @PKG_CONFIG_HOST_BINARY@ won't be replaced if patch 3 isn't
applied, so this isn't bisectable. Maybe it must be merged with patch 3 ?
Norbert Lange Sept. 15, 2020, 3:46 p.m. UTC | #2
Am Di., 15. Sept. 2020 um 16:05 Uhr schrieb Nicolas Cavallari
<nicolas.cavallari@green-communications.fr>:
>
> On 15/09/2020 12:05, Norbert Lange wrote:
> > dont depend on specific names of compiler tools, but use existing
> > Buildroot variables.
> >
> > Signed-off-by: Norbert Lange <nolange79@gmail.com>
> > ---
> >  package/meson/cross-compilation.conf.in | 10 +++++-----
> >  1 file changed, 5 insertions(+), 5 deletions(-)
> >
> > diff --git a/package/meson/cross-compilation.conf.in b/package/meson/cross-compilation.conf.in
> > index e9344e2b2f..67c5da8156 100644
> > --- a/package/meson/cross-compilation.conf.in
> > +++ b/package/meson/cross-compilation.conf.in
> > @@ -4,11 +4,11 @@
> >  # - Buildroot's 'target' is Meson's 'host'
> >
> >  [binaries]
> > -c = '@TARGET_CROSS@gcc'
> > -cpp = '@TARGET_CROSS@g++'
> > -ar = '@TARGET_CROSS@ar'
> > -strip = '@TARGET_CROSS@strip'
> > -pkgconfig = '@HOST_DIR@/bin/pkgconf'
> > +c = '@TARGET_CC@'
> > +cpp = '@TARGET_CXX@'
> > +ar = '@TARGET_AR@'
> > +strip = '@TARGET_STRIP@'
> > +pkgconfig = '@PKG_CONFIG_HOST_BINARY@'
> >  g-ir-compiler = '@STAGING_DIR@/usr/bin/g-ir-compiler'
> >  g-ir-scanner = '@STAGING_DIR@/usr/bin/g-ir-scanner'
>
> This changes host/bin/pkgconf to host/bin/pkg-config, but that shouldn't
> be a problem, given meson only uses this pkgconfig to find target
> packages and not host packages (for that meson would look it up in a
> native-file instead of a cross-file).

Well, its used by all other build systems, so this makes more sense to me,
otherwise, shouldn't PKG_CONFIG_HOST_BINARY be changed to pkgconfig?

>
> Also @PKG_CONFIG_HOST_BINARY@ won't be replaced if patch 3 isn't
> applied, so this isn't bisectable. Maybe it must be merged with patch 3 ?

Yeah, I did actually split this off as doing too much in a single
patch was often critized.
can fix PATCH #2 or merge it again. Gonnna wait for more feedback

Norbert
Thomas Petazzoni Sept. 15, 2020, 8:50 p.m. UTC | #3
On Tue, 15 Sep 2020 17:46:18 +0200
Norbert Lange <nolange79@gmail.com> wrote:

> > This changes host/bin/pkgconf to host/bin/pkg-config, but that shouldn't
> > be a problem, given meson only uses this pkgconfig to find target
> > packages and not host packages (for that meson would look it up in a
> > native-file instead of a cross-file).  
> 
> Well, its used by all other build systems, so this makes more sense to me,
> otherwise, shouldn't PKG_CONFIG_HOST_BINARY be changed to pkgconfig?

No, for Meson things are special, and it should really point to pkgconf
directly, and not to Buildroot's pkg-config wrapper around pkgconf.

Otherwise, what you're doing essentially reverts
4e0bc29993376613d200e892d491e31ea5a49622.

Thomas
Nicolas Cavallari Sept. 16, 2020, 7:42 a.m. UTC | #4
On 15/09/2020 22:50, Thomas Petazzoni wrote:
> On Tue, 15 Sep 2020 17:46:18 +0200
> Norbert Lange <nolange79@gmail.com> wrote:
> 
>>> This changes host/bin/pkgconf to host/bin/pkg-config, but that shouldn't
>>> be a problem, given meson only uses this pkgconfig to find target
>>> packages and not host packages (for that meson would look it up in a
>>> native-file instead of a cross-file).  
>>
>> Well, its used by all other build systems, so this makes more sense to me,
>> otherwise, shouldn't PKG_CONFIG_HOST_BINARY be changed to pkgconfig?
> 
> No, for Meson things are special, and it should really point to pkgconf
> directly, and not to Buildroot's pkg-config wrapper around pkgconf.
> 
> Otherwise, what you're doing essentially reverts
> 4e0bc29993376613d200e892d491e31ea5a49622.

We have already established that 4e0bc299 doesn't work:

https://marc.info/?l=buildroot&m=158853516017526&w=2

And i can confirm that the situation hasn't changed in 2020.08, the logs from my
first message in this thread are unchanged in 2020.08
https://marc.info/?l=buildroot&m=158849499805939&w=2

but this is probably another topic.
diff mbox series

Patch

diff --git a/package/meson/cross-compilation.conf.in b/package/meson/cross-compilation.conf.in
index e9344e2b2f..67c5da8156 100644
--- a/package/meson/cross-compilation.conf.in
+++ b/package/meson/cross-compilation.conf.in
@@ -4,11 +4,11 @@ 
 # - Buildroot's 'target' is Meson's 'host'
 
 [binaries]
-c = '@TARGET_CROSS@gcc'
-cpp = '@TARGET_CROSS@g++'
-ar = '@TARGET_CROSS@ar'
-strip = '@TARGET_CROSS@strip'
-pkgconfig = '@HOST_DIR@/bin/pkgconf'
+c = '@TARGET_CC@'
+cpp = '@TARGET_CXX@'
+ar = '@TARGET_AR@'
+strip = '@TARGET_STRIP@'
+pkgconfig = '@PKG_CONFIG_HOST_BINARY@'
 g-ir-compiler = '@STAGING_DIR@/usr/bin/g-ir-compiler'
 g-ir-scanner = '@STAGING_DIR@/usr/bin/g-ir-scanner'