diff mbox series

[1/2] package/mtd: add host-acl dependency for host

Message ID 20200908085106.3197433-1-antoine.tenart@bootlin.com
State Superseded
Headers show
Series [1/2] package/mtd: add host-acl dependency for host | expand

Commit Message

Antoine Tenart Sept. 8, 2020, 8:51 a.m. UTC
When compiling the host version of mtd, --with-jffs and --with-ubifs are
always set, meaning --with-xattr is set by default. The xattr support
only work if 'sys/acl.h' is available, otherwise the feature is silently
dropped (a warning is shown during the configuration step).

This patch adds a dependency on host-acl for host-mtd, so that the xattr
feature is correctly supported. Logic to have xattr support is already
there and working for the non-host flavour.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
---
 package/mtd/mtd.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index 1186fa52d552..9f259b35d906 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -53,7 +53,7 @@  else
 MTD_CONF_OPTS += --without-xattr
 endif
 
-HOST_MTD_DEPENDENCIES = host-zlib host-lzo host-util-linux host-zstd
+HOST_MTD_DEPENDENCIES = host-acl host-zlib host-lzo host-util-linux host-zstd
 HOST_MTD_CONF_OPTS = \
 	--with-jffs \
 	--with-ubifs \