diff mbox series

package/live555: update licenses

Message ID 20200813082235.890148-1-buildroot@heine.tech
State Accepted
Headers show
Series package/live555: update licenses | expand

Commit Message

Michael Nosthoff Aug. 13, 2020, 8:22 a.m. UTC
The included license files indicate that the project is licensed
under GPL3.0 and LGPL3.0.

Even though the project site [1] only mentions LGPL.

- Add GPL-3.0+
- Bump LGPL License to 3.0+
- add the LGPL license file included in download

[1] http://live555.com/liveMedia/faq.html#copyright-and-license

Fixes:
 - https://bugs.busybox.net/show_bug.cgi?id=13156

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
---
 package/live555/live555.hash | 1 +
 package/live555/live555.mk   | 4 ++--
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Aug. 13, 2020, 8:36 p.m. UTC | #1
Hello Michael,

Thanks for your contribution!

On Thu, 13 Aug 2020 10:22:35 +0200
Michael Nosthoff <buildroot@heine.tech> wrote:

> The included license files indicate that the project is licensed
> under GPL3.0 and LGPL3.0.
> 
> Even though the project site [1] only mentions LGPL.
> 
> - Add GPL-3.0+
> - Bump LGPL License to 3.0+
> - add the LGPL license file included in download
> 
> [1] http://live555.com/liveMedia/faq.html#copyright-and-license

In fact, there are no sources files under GPL-3.0: all the source files
indicate LGPL-3.0. So the presence of this COPYING file with the
GPL-3.0 license text seems to be a mistake.

So I've adjusted your commit to only mention the LGPL-3.0 license, 
added a comment in live555.mk about why we don't think anything is
under GPL-3.0 and applied to master.

Also, it's worth mentioning that the live555 developers themselves
don't seem to understand the LGPL very well. In the second bullet point
at http://live555.com/liveMedia/faq.html#copyright-and-license, they
claim:

  If you distribute a product (whether software or hardware; whether
  free or for pay) that uses the LIVE555 library code, then you must -
  when requested by either a customer, or Live Networks, Inc. - upgrade
  it as soon as possible to use the latest version of the LIVE555
  library code

This is clearly _NOT_ a requirement of the LGPL, and a license that
would have this requirement would not be a free software / open source
license.

Best regards,

Thomas
Peter Korsgaard Aug. 28, 2020, 4:09 p.m. UTC | #2
>>>>> "Michael" == Michael Nosthoff <buildroot@heine.tech> writes:

 > The included license files indicate that the project is licensed
 > under GPL3.0 and LGPL3.0.

 > Even though the project site [1] only mentions LGPL.

 > - Add GPL-3.0+
 > - Bump LGPL License to 3.0+
 > - add the LGPL license file included in download

 > [1] http://live555.com/liveMedia/faq.html#copyright-and-license

 > Fixes:
 >  - https://bugs.busybox.net/show_bug.cgi?id=13156

 > Signed-off-by: Michael Nosthoff <buildroot@heine.tech>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/live555/live555.hash b/package/live555/live555.hash
index 867e0befd0..cbe41802a1 100644
--- a/package/live555/live555.hash
+++ b/package/live555/live555.hash
@@ -3,3 +3,4 @@  md5  327bc53f60361c6d703d52e86f476f11  live.2020.06.25.tar.gz
 # Locally generated
 sha256  f206309f10d281990889b7a0c92c26a7fa55ac0e8568bf594b9b27433b4db585  live.2020.06.25.tar.gz
 sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  COPYING
+sha256  da7eabb7bafdf7d3ae5e9f223aa5bdc1eece45ac569dc21b3b037520b4464768  COPYING.LESSER
diff --git a/package/live555/live555.mk b/package/live555/live555.mk
index b2313886b1..bc48c5f8b3 100644
--- a/package/live555/live555.mk
+++ b/package/live555/live555.mk
@@ -7,8 +7,8 @@ 
 LIVE555_VERSION = 2020.06.25
 LIVE555_SOURCE = live.$(LIVE555_VERSION).tar.gz
 LIVE555_SITE = http://www.live555.com/liveMedia/public
-LIVE555_LICENSE = LGPL-2.1+
-LIVE555_LICENSE_FILES = COPYING
+LIVE555_LICENSE = LGPL-3.0+ or GPL-3.0+
+LIVE555_LICENSE_FILES = COPYING.LESSER COPYING
 LIVE555_INSTALL_STAGING = YES
 
 LIVE555_CFLAGS = $(TARGET_CFLAGS)