diff mbox series

[2/2] package/python-numpy: use fortran compiler when available

Message ID 20200627130805.8615-2-guillaume.bressaix@gmail.com
State Accepted
Headers show
Series [1/2] package/python-numpy: remove non needed --fcompiler flag | expand

Commit Message

Guillaume Bres June 27, 2020, 1:08 p.m. UTC
From: "Guillaume W. Bres" <guillaume.bressaix@gmail.com>

python-numpy can be built using fortran compiler if
available, this is the correct configure flag to do it

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
---
 package/python-numpy/python-numpy.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Arnout Vandecappelle Jan. 8, 2022, 3:41 p.m. UTC | #1
On 27/06/2020 15:08, guillaume.bressaix@gmail.com wrote:
> From: "Guillaume W. Bres" <guillaume.bressaix@gmail.com>
> 
> python-numpy can be built using fortran compiler if
> available, this is the correct configure flag to do it
> 
> Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
> ---
>   package/python-numpy/python-numpy.mk | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/package/python-numpy/python-numpy.mk b/package/python-numpy/python-numpy.mk
> index f9c55c9f3c..9e08fd5f2e 100644
> --- a/package/python-numpy/python-numpy.mk
> +++ b/package/python-numpy/python-numpy.mk
> @@ -23,6 +23,10 @@ else
>   PYTHON_NUMPY_ENV += BLAS=None LAPACK=None
>   endif
>   
> +ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),y)
> +PYTHON_NUMPY_ENV += F90=$(TARGET_FC)

  It's better to still explicitly pass --fcompiler=gnu95; same when fortran is 
not available, pass --fcompiler=None. That way, we get an error if it 
accidentally picks up the wrong compiler (e.g. from the host).

  Therefore, I squashed the two patches, and applied to master, thanks.

  Regards,
  Arnout

> +endif
> +
>   define PYTHON_NUMPY_CONFIGURE_CMDS
>   	-rm -f $(@D)/site.cfg
>   	echo "[DEFAULT]" >> $(@D)/site.cfg
>
diff mbox series

Patch

diff --git a/package/python-numpy/python-numpy.mk b/package/python-numpy/python-numpy.mk
index f9c55c9f3c..9e08fd5f2e 100644
--- a/package/python-numpy/python-numpy.mk
+++ b/package/python-numpy/python-numpy.mk
@@ -23,6 +23,10 @@  else
 PYTHON_NUMPY_ENV += BLAS=None LAPACK=None
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_FORTRAN),y)
+PYTHON_NUMPY_ENV += F90=$(TARGET_FC)
+endif
+
 define PYTHON_NUMPY_CONFIGURE_CMDS
 	-rm -f $(@D)/site.cfg
 	echo "[DEFAULT]" >> $(@D)/site.cfg