diff mbox series

[v2,4/7] package/cups: Add lp user as default cups user

Message ID 20200619145719.2352019-5-angelo@amarulasolutions.com
State Changes Requested
Headers show
Series Cups revamp | expand

Commit Message

Angelo Compagnucci June 19, 2020, 2:57 p.m. UTC
This patch is a backport from the rockchip tree.

Author: Jeffy Chen <jeffy.chen@rock-chips.com>
Date:   Tue Nov 13 18:25:34 2018 +0800

    package: cups: Add lp user as default cups user

    Change-Id: Ic7434fe0a7b41b86b5b8b097fa29dd9718e29aa5
    Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>

but fixes the CUPS_USERS table.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/cups/cups.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni June 20, 2020, 8:37 p.m. UTC | #1
Hello,

On Fri, 19 Jun 2020 16:57:16 +0200
Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> This patch is a backport from the rockchip tree.

Good idea to try to bring back into Buildroot changes made in other
forks! However, it would be nice to have a better commit log that
explains why these changes are needed, i.e what is the visible issue
without this fix.

> diff --git a/package/cups/cups.mk b/package/cups/cups.mk
> index 461e0d9143..40fe210c94 100644
> --- a/package/cups/cups.mk
> +++ b/package/cups/cups.mk
> @@ -22,6 +22,9 @@ CUPS_CONF_OPTS = \
>  	--disable-gssapi \
>  	--disable-pam \
>  	--libdir=/usr/lib \
> +	--with-cups-user=lp \
> +	--with-cups-group=lp \
> +	--with-system-groups="lpadmin sys root" \

What is this --with-system-groups option doing?

>  	--with-rcdir=no
>  CUPS_CONFIG_SCRIPTS = cups-config
>  CUPS_DEPENDENCIES = \
> @@ -78,4 +81,9 @@ define CUPS_INSTALL_INIT_SYSV
>  		$(TARGET_DIR)/etc/init.d/S81cupsd
>  endef
>  
> +define CUPS_USERS
> +	lp -1 lp -1 * /var/spool/lpd /bin/false - lp
> +	- - lpadmin -1 * - - - Printers admin group.

So we need both a "lp" group and a "lpadmin" group ?

Thomas
diff mbox series

Patch

diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 461e0d9143..40fe210c94 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -22,6 +22,9 @@  CUPS_CONF_OPTS = \
 	--disable-gssapi \
 	--disable-pam \
 	--libdir=/usr/lib \
+	--with-cups-user=lp \
+	--with-cups-group=lp \
+	--with-system-groups="lpadmin sys root" \
 	--with-rcdir=no
 CUPS_CONFIG_SCRIPTS = cups-config
 CUPS_DEPENDENCIES = \
@@ -78,4 +81,9 @@  define CUPS_INSTALL_INIT_SYSV
 		$(TARGET_DIR)/etc/init.d/S81cupsd
 endef
 
+define CUPS_USERS
+	lp -1 lp -1 * /var/spool/lpd /bin/false - lp
+	- - lpadmin -1 * - - - Printers admin group.
+endef
+
 $(eval $(autotools-package))