diff mbox series

[1/1] boot/uboot: Change from FTP to HTTP for official releases

Message ID 20200604182420.37049-1-troglobit@gmail.com
State Superseded
Headers show
Series [1/1] boot/uboot: Change from FTP to HTTP for official releases | expand

Commit Message

Joachim Wiberg June 4, 2020, 6:24 p.m. UTC
The HTTP URL seems to be more reliable and quicker for download than FTP.
FTP may also be a blocked protocol on some sites and in CI/CD setups.

Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
---
 boot/uboot/uboot.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Baruch Siach June 4, 2020, 6:41 p.m. UTC | #1
Hi Joachim,

On Thu, Jun 04 2020, Joachim Nilsson wrote:
> The HTTP URL seems to be more reliable and quicker for download than FTP.
> FTP may also be a blocked protocol on some sites and in CI/CD setups.
>
> Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
> ---
>  boot/uboot/uboot.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index 1d50e72846..ede14fe234 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -33,7 +33,7 @@ UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_REPO_URL))
>  UBOOT_SITE_METHOD = svn
>  else
>  # Handle stable official U-Boot versions
> -UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
> +UBOOT_SITE = http://ftp.denx.de/pub/u-boot

This URL redirects to https. Better use https directly.

baruch

>  UBOOT_SOURCE = u-boot-$(UBOOT_VERSION).tar.bz2
>  endif
Joachim Wiberg June 4, 2020, 6:51 p.m. UTC | #2
On Thu Jun 4, 2020 at 11:41 PM CEST, Baruch Siach wrote:
> On Thu, Jun 04 2020, Joachim Nilsson wrote:
> > -UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
> > +UBOOT_SITE = http://ftp.denx.de/pub/u-boot
> This URL redirects to https. Better use https directly.

Argh!  Thanks for taking the time to audit this, Baruch! :)
I'll send a v2 patch shortly.

Regards
 /Joachim
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 1d50e72846..ede14fe234 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -33,7 +33,7 @@  UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_REPO_URL))
 UBOOT_SITE_METHOD = svn
 else
 # Handle stable official U-Boot versions
-UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot
+UBOOT_SITE = http://ftp.denx.de/pub/u-boot
 UBOOT_SOURCE = u-boot-$(UBOOT_VERSION).tar.bz2
 endif