diff mbox series

[2/2] package/fluidsynth: add systemd optional dependency

Message ID 20200424113928.213441-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/fluidsynth: add sdl2 optional dependency | expand

Commit Message

Fabrice Fontaine April 24, 2020, 11:39 a.m. UTC
systemd is an optional dependency (enabled by default) since version
2.0.5 and
https://github.com/FluidSynth/fluidsynth/commit/099369f8b7f39afe08b6a518195948b05a937af3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/fluidsynth/fluidsynth.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Jan. 7, 2021, 10:25 p.m. UTC | #1
On Fri, 24 Apr 2020 13:39:28 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> systemd is an optional dependency (enabled by default) since version
> 2.0.5 and
> https://github.com/FluidSynth/fluidsynth/commit/099369f8b7f39afe08b6a518195948b05a937af3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/fluidsynth/fluidsynth.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/fluidsynth/fluidsynth.mk b/package/fluidsynth/fluidsynth.mk
index 98eb1ad30c..22ba59669c 100644
--- a/package/fluidsynth/fluidsynth.mk
+++ b/package/fluidsynth/fluidsynth.mk
@@ -73,4 +73,11 @@  else
 FLUIDSYNTH_CONF_OPTS += -Denable-sdl2=0
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+FLUIDSYNTH_CONF_OPTS += -Denable-systemd=1
+FLUIDSYNTH_DEPENDENCIES += systemd
+else
+FLUIDSYNTH_CONF_OPTS += -Denable-systemd=0
+endif
+
 $(eval $(cmake-package))