diff mbox series

[v2] package/matio: new package

Message ID 20200424085624.23908-1-gwenj@trabucayre.com
State Changes Requested
Headers show
Series [v2] package/matio: new package | expand

Commit Message

Gwenhael Goavec-Merou April 24, 2020, 8:56 a.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

matio is an C library for reading and writing MATLAB MAT files.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
Changes v1 -> v2:
 * add one blank line befor URL (Heiko)
 * drop blank lines around MATIO_DEPENDENCIES and MATIO_INSTALL_STAGING (Heiko)
 * drop comment about STAGING (Heiko)
 * += -> + for MATIO_CONF_ENV (Heiko)
---
 DEVELOPERS               |  1 +
 package/Config.in        |  1 +
 package/matio/Config.in  | 15 +++++++++++++++
 package/matio/matio.hash |  5 +++++
 package/matio/matio.mk   | 25 +++++++++++++++++++++++++
 5 files changed, 47 insertions(+)
 create mode 100644 package/matio/Config.in
 create mode 100644 package/matio/matio.hash
 create mode 100644 package/matio/matio.mk

Comments

Yann E. MORIN April 24, 2020, 12:05 p.m. UTC | #1
Gwenhael, All,

On 2020-04-24 10:56 +0200, Gwenhael Goavec-Merou spake thusly:
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> matio is an C library for reading and writing MATLAB MAT files.
> 
> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
[--SNIP--]
> diff --git a/package/matio/Config.in b/package/matio/Config.in
> new file mode 100644
> index 0000000000..b6c4223e44
> --- /dev/null
> +++ b/package/matio/Config.in
> @@ -0,0 +1,15 @@
> +config BR2_PACKAGE_MATIO
> +	bool "matio"
> +	select BR2_PACKAGE_ZLIB
> +	help
> +	  matio is an C library for reading and writing MATLAB MAT
> +	  files.
> +
> +	  https://sourceforge.net/projects/matio
> +
> +if BR2_PACKAGE_MATIO
> +
> +config BR2_PACKAGE_MATIO_SPARSE
> +	bool "sparse support"

Why do we need this top be optional? Does it increase the size
considerably?

Im intrigued, because...

[--SNIP--]
> diff --git a/package/matio/matio.mk b/package/matio/matio.mk
> new file mode 100644
> index 0000000000..2ac46f10ad
> --- /dev/null
> +++ b/package/matio/matio.mk
> @@ -0,0 +1,25 @@
> +################################################################################
> +#
> +# matio
> +#
> +################################################################################
> +
> +MATIO_VERSION = 1.5.17
> +MATIO_SITE = http://downloads.sourceforge.net/project/matio/matio/$(MATIO_VERSION)
> +MATIO_LICENSE = BSD-2-Clause
> +MATIO_LICENSE_FILES = COPYING
> +MATIO_DEPENDENCIES = zlib
> +MATIO_INSTALL_STAGING = YES
> +
> +# va_copy()
> +MATIO_CONF_ENV = ac_cv_va_copy=yes
> +
> +MATIO_CONF_OPTS = --enable-mat73=no

... here you explicitly disable a feature.

> +ifeq ($(BR2_PACKAGE_MATIO_SPARSE),y)
> +MATIO_CONF_OPTS += --enable-extended-sparse=yes
> +else
> +MATIO_CONF_OPTS += --enable-extended-sparse=no

Usually, we use: --enable-extended-sparse and --disable-extended-sparse=yes

Regards,
Yann E. MORIN.

> +endif
> +
> +$(eval $(autotools-package))
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Gwenhael Goavec-Merou April 24, 2020, 12:47 p.m. UTC | #2
Yann, all
On Fri, 24 Apr 2020 14:05:45 +0200
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Gwenhael, All,
> 
> On 2020-04-24 10:56 +0200, Gwenhael Goavec-Merou spake thusly:
> > From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > 
> > matio is an C library for reading and writing MATLAB MAT files.
> > 
> > Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> > ---  
> [--SNIP--]
> > diff --git a/package/matio/Config.in b/package/matio/Config.in
> > new file mode 100644
> > index 0000000000..b6c4223e44
> > --- /dev/null
> > +++ b/package/matio/Config.in
> > @@ -0,0 +1,15 @@
> > +config BR2_PACKAGE_MATIO
> > +	bool "matio"
> > +	select BR2_PACKAGE_ZLIB
> > +	help
> > +	  matio is an C library for reading and writing MATLAB MAT
> > +	  files.
> > +
> > +	  https://sourceforge.net/projects/matio
> > +
> > +if BR2_PACKAGE_MATIO
> > +
> > +config BR2_PACKAGE_MATIO_SPARSE
> > +	bool "sparse support"  
> 
> Why do we need this top be optional? Does it increase the size
> considerably?
>
I need to check 
>
> Im intrigued, because...
> 
> [--SNIP--]
> > diff --git a/package/matio/matio.mk b/package/matio/matio.mk
> > new file mode 100644
> > index 0000000000..2ac46f10ad
> > --- /dev/null
> > +++ b/package/matio/matio.mk
> > @@ -0,0 +1,25 @@
> > +################################################################################
> > +#
> > +# matio
> > +#
> > +################################################################################
> > +
> > +MATIO_VERSION = 1.5.17
> > +MATIO_SITE =
> > http://downloads.sourceforge.net/project/matio/matio/$(MATIO_VERSION)
> > +MATIO_LICENSE = BSD-2-Clause +MATIO_LICENSE_FILES = COPYING
> > +MATIO_DEPENDENCIES = zlib
> > +MATIO_INSTALL_STAGING = YES
> > +
> > +# va_copy()
> > +MATIO_CONF_ENV = ac_cv_va_copy=yes
> > +
> > +MATIO_CONF_OPTS = --enable-mat73=no  
> 
> ... here you explicitly disable a feature.
>
This feature requires hdf5, not available. I must add a message to explain why

> 
> > +ifeq ($(BR2_PACKAGE_MATIO_SPARSE),y)
> > +MATIO_CONF_OPTS += --enable-extended-sparse=yes
> > +else
> > +MATIO_CONF_OPTS += --enable-extended-sparse=no  
> 
> Usually, we use: --enable-extended-sparse and --disable-extended-sparse=yes
> 
> Regards,
> Yann E. MORIN.
> 
> > +endif
> > +
> > +$(eval $(autotools-package))
> > -- 
> > 2.25.1
> > 
Regards,
Gwen
Thomas Petazzoni April 25, 2020, 9:50 a.m. UTC | #3
On Fri, 24 Apr 2020 10:56:24 +0200
Gwenhael Goavec-Merou <gwenj@trabucayre.com> wrote:

> diff --git a/package/matio/matio.hash b/package/matio/matio.hash
> new file mode 100644
> index 0000000000..d84f50e0b2
> --- /dev/null
> +++ b/package/matio/matio.hash
> @@ -0,0 +1,5 @@
> +# From https://sourceforge.net/projects/matio/files/matio/1.5.17/
> +sha512  af8ff11c7c44fea9ea6886e381f49ef9186946f3def98ad9695f2d5d1df045c35e8f4ceac12a44be397f7bbd708b4803762b5ce54c45b60a9f446d551c04f5d2  matio-1.5.17.tar.gz
> +# Locally computed
> +sha256  5e455527d370ab297c4abe5a2ab4d599c93ac7c1a0c85d841cc5c22f8221c400  matio-1.5.17.tar.gz

If there's an upstream provided sha512 hash, I'm not sure it's really
useful to add a locally calculated sha256 hash.

> +MATIO_VERSION = 1.5.17
> +MATIO_SITE = http://downloads.sourceforge.net/project/matio/matio/$(MATIO_VERSION)
> +MATIO_LICENSE = BSD-2-Clause
> +MATIO_LICENSE_FILES = COPYING
> +MATIO_DEPENDENCIES = zlib
> +MATIO_INSTALL_STAGING = YES
> +
> +# va_copy()
> +MATIO_CONF_ENV = ac_cv_va_copy=yes
> +
> +MATIO_CONF_OPTS = --enable-mat73=no

Please use:

	--disable-mat73

> +
> +ifeq ($(BR2_PACKAGE_MATIO_SPARSE),y)
> +MATIO_CONF_OPTS += --enable-extended-sparse=yes

Just:

	--enable-extended-sparse

> +else
> +MATIO_CONF_OPTS += --enable-extended-sparse=no

Use:

	--disable-extended-sparse

Thanks,

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index c57bc1c5c9..6cd115be38 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1101,6 +1101,7 @@  F:	package/gnuradio/
 F:	package/gqrx/
 F:	package/gr-osmosdr/
 F:	package/libusbgx/
+F:	package/matio/
 F:	package/python-cheetah/
 F:	package/python-markdown/
 F:	package/python-remi/
diff --git a/package/Config.in b/package/Config.in
index a9c6f6fcbc..f7c48d2d9e 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1868,6 +1868,7 @@  endif
 	source "package/liquid-dsp/Config.in"
 	source "package/llvm/Config.in"
 	source "package/lttng-libust/Config.in"
+	source "package/matio/Config.in"
 	source "package/mpc/Config.in"
 	source "package/mpdecimal/Config.in"
 	source "package/mpfr/Config.in"
diff --git a/package/matio/Config.in b/package/matio/Config.in
new file mode 100644
index 0000000000..b6c4223e44
--- /dev/null
+++ b/package/matio/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_MATIO
+	bool "matio"
+	select BR2_PACKAGE_ZLIB
+	help
+	  matio is an C library for reading and writing MATLAB MAT
+	  files.
+
+	  https://sourceforge.net/projects/matio
+
+if BR2_PACKAGE_MATIO
+
+config BR2_PACKAGE_MATIO_SPARSE
+	bool "sparse support"
+
+endif
diff --git a/package/matio/matio.hash b/package/matio/matio.hash
new file mode 100644
index 0000000000..d84f50e0b2
--- /dev/null
+++ b/package/matio/matio.hash
@@ -0,0 +1,5 @@ 
+# From https://sourceforge.net/projects/matio/files/matio/1.5.17/
+sha512  af8ff11c7c44fea9ea6886e381f49ef9186946f3def98ad9695f2d5d1df045c35e8f4ceac12a44be397f7bbd708b4803762b5ce54c45b60a9f446d551c04f5d2  matio-1.5.17.tar.gz
+# Locally computed
+sha256  5e455527d370ab297c4abe5a2ab4d599c93ac7c1a0c85d841cc5c22f8221c400  matio-1.5.17.tar.gz
+sha256  62a0cab69eeadb3697a2249d5a869915b89e62b59b794dd70802c2b8624ed374  COPYING
diff --git a/package/matio/matio.mk b/package/matio/matio.mk
new file mode 100644
index 0000000000..2ac46f10ad
--- /dev/null
+++ b/package/matio/matio.mk
@@ -0,0 +1,25 @@ 
+################################################################################
+#
+# matio
+#
+################################################################################
+
+MATIO_VERSION = 1.5.17
+MATIO_SITE = http://downloads.sourceforge.net/project/matio/matio/$(MATIO_VERSION)
+MATIO_LICENSE = BSD-2-Clause
+MATIO_LICENSE_FILES = COPYING
+MATIO_DEPENDENCIES = zlib
+MATIO_INSTALL_STAGING = YES
+
+# va_copy()
+MATIO_CONF_ENV = ac_cv_va_copy=yes
+
+MATIO_CONF_OPTS = --enable-mat73=no
+
+ifeq ($(BR2_PACKAGE_MATIO_SPARSE),y)
+MATIO_CONF_OPTS += --enable-extended-sparse=yes
+else
+MATIO_CONF_OPTS += --enable-extended-sparse=no
+endif
+
+$(eval $(autotools-package))