diff mbox series

package/cegui: force c++11 when xerces is used

Message ID 20200403195305.33887-1-b.bilas@grinn-global.com
State Rejected
Headers show
Series package/cegui: force c++11 when xerces is used | expand

Commit Message

Bartosz Bilas April 3, 2020, 7:53 p.m. UTC
Fixes:
 - http://autobuild.buildroot.net/results/ea04be78b31b3409801597fc0ebe04627742c0c8
 - http://autobuild.buildroot.net/results/7de3a07c304e3939ec9fd164328d004a5a9bba6d
 - http://autobuild.buildroot.net/results/472b4e8438c9100e06e401296f0417a463e5fcf1

and couple of others

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/cegui/cegui.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Bartosz Bilas April 3, 2020, 8:13 p.m. UTC | #1
Please ignore this patch.

Best
Bartek
On 03.04.2020 21:53, Bartosz Bilas wrote:
> Fixes:
>   - http://autobuild.buildroot.net/results/ea04be78b31b3409801597fc0ebe04627742c0c8
>   - http://autobuild.buildroot.net/results/7de3a07c304e3939ec9fd164328d004a5a9bba6d
>   - http://autobuild.buildroot.net/results/472b4e8438c9100e06e401296f0417a463e5fcf1
>
> and couple of others
>
> Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
> ---
>   package/cegui/cegui.mk | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/package/cegui/cegui.mk b/package/cegui/cegui.mk
> index 657492a7f7..fe5ecc2e16 100644
> --- a/package/cegui/cegui.mk
> +++ b/package/cegui/cegui.mk
> @@ -74,7 +74,8 @@ endif
>   
>   ifeq ($(BR2_PACKAGE_XERCES),y)
>   CEGUI_DEPENDENCIES += xerces
> -CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=ON
> +CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=ON \
> +		    -DCMAKE_CXX_STANDARD=11 # char16_t
>   else
>   CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF
>   endif
diff mbox series

Patch

diff --git a/package/cegui/cegui.mk b/package/cegui/cegui.mk
index 657492a7f7..fe5ecc2e16 100644
--- a/package/cegui/cegui.mk
+++ b/package/cegui/cegui.mk
@@ -74,7 +74,8 @@  endif
 
 ifeq ($(BR2_PACKAGE_XERCES),y)
 CEGUI_DEPENDENCIES += xerces
-CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=ON
+CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=ON \
+		    -DCMAKE_CXX_STANDARD=11 # char16_t
 else
 CEGUI_CONF_OTPS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF
 endif