diff mbox series

[v2,1/2] package/libyang: enable LYD_PRIV option for frr package

Message ID 20200225025850.17209-2-vadim4j@gmail.com
State Superseded
Headers show
Series add frr package | expand

Commit Message

Vadym Kochan Feb. 25, 2020, 2:58 a.m. UTC
This option is required by frr package, so enable it only if frr is
selected.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
---
 package/libyang/libyang.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Feb. 25, 2020, 8:06 a.m. UTC | #1
On Tue, 25 Feb 2020 04:58:49 +0200
Vadim Kochan <vadim4j@gmail.com> wrote:

> This option is required by frr package, so enable it only if frr is
> selected.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> ---
>  package/libyang/libyang.mk | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/libyang/libyang.mk b/package/libyang/libyang.mk
> index 648ffeb6a3..9d7f5df696 100644
> --- a/package/libyang/libyang.mk
> +++ b/package/libyang/libyang.mk
> @@ -17,6 +17,10 @@ LIBYANG_CONF_OPTS = \
>  	-DENABLE_VALGRIND_TESTS=OFF \
>  	-DGEN_PYTHON_BINDINGS=OFF
>  
> +ifeq ($(BR2_PACKAGE_FRR),y)

We normally don't look at which reverse dependencies are enabled to
enable features in a dependent package. We do the opposite: look at
which of our dependencies are available to enable features.

What is the size increase of enabling this option? If it is
significant, we want to introduce a BR2_PACKAGE_LIBYANG_LYD_PRIV
sub-option, and select it from the frr package.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/libyang/libyang.mk b/package/libyang/libyang.mk
index 648ffeb6a3..9d7f5df696 100644
--- a/package/libyang/libyang.mk
+++ b/package/libyang/libyang.mk
@@ -17,6 +17,10 @@  LIBYANG_CONF_OPTS = \
 	-DENABLE_VALGRIND_TESTS=OFF \
 	-DGEN_PYTHON_BINDINGS=OFF
 
+ifeq ($(BR2_PACKAGE_FRR),y)
+LIBYANG_CONF_OPTS += -DENABLE_LYD_PRIV=ON
+endif
+
 HOST_LIBYANG_CONF_OPTS = \
 	-DENABLE_VALGRIND_TESTS=OFF \
 	-DGEN_PYTHON_BINDINGS=OFF