diff mbox series

package/skeleton-init-openrc: fix root filesystem ro/rw remount

Message ID 20200224114134.25887-1-unixmania@gmail.com
State Accepted
Headers show
Series package/skeleton-init-openrc: fix root filesystem ro/rw remount | expand

Commit Message

Carlos Santos Feb. 24, 2020, 11:41 a.m. UTC
From: Carlos Santos <unixmania@gmail.com>

The regular expressions used in the sed commands assumes that there is a
space after '/dev/root' but the skeleton file contains a tab. Use a more
flexible '[[:blank:]]', instead.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
 package/skeleton-init-openrc/skeleton-init-openrc.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Feb. 24, 2020, 6:34 p.m. UTC | #1
Carlos, All,

On 2020-02-24 08:41 -0300, unixmania@gmail.com spake thusly:
> From: Carlos Santos <unixmania@gmail.com>
> 
> The regular expressions used in the sed commands assumes that there is a
> space after '/dev/root' but the skeleton file contains a tab. Use a more
> flexible '[[:blank:]]', instead.
> 
> Signed-off-by: Carlos Santos <unixmania@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/skeleton-init-openrc/skeleton-init-openrc.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/skeleton-init-openrc/skeleton-init-openrc.mk b/package/skeleton-init-openrc/skeleton-init-openrc.mk
> index 656fc531d7..b0538ad03f 100644
> --- a/package/skeleton-init-openrc/skeleton-init-openrc.mk
> +++ b/package/skeleton-init-openrc/skeleton-init-openrc.mk
> @@ -19,13 +19,13 @@ ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
>  # Comment /dev/root entry in fstab. When openrc does not find fstab entry for
>  # "/", it will try to remount "/" as "rw".
>  define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
> -	$(SED) '\:^/dev/root :s/^/# /' $(TARGET_DIR)/etc/fstab
> +	$(SED) '\:^/dev/root[[:blank:]]:s/^/# /' $(TARGET_DIR)/etc/fstab
>  endef
>  else
>  # Uncomment /dev/root entry in fstab which has "ro" option so openrc notices
>  # it and doesn't remount root to rw.
>  define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
> -	$(SED) '\:^# /dev/root:s/^# //' $(TARGET_DIR)/etc/fstab
> +	$(SED) '\:^#[[:blank:]]*/dev/root[[:blank:]]:s/^# //' $(TARGET_DIR)/etc/fstab
>  endef
>  endif # BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
>  
> -- 
> 2.18.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard March 14, 2020, 4:28 p.m. UTC | #2
>>>>> "unixmania" == unixmania  <unixmania@gmail.com> writes:

 > From: Carlos Santos <unixmania@gmail.com>
 > The regular expressions used in the sed commands assumes that there is a
 > space after '/dev/root' but the skeleton file contains a tab. Use a more
 > flexible '[[:blank:]]', instead.

 > Signed-off-by: Carlos Santos <unixmania@gmail.com>

Committed to 2019.11.x (not in 2019.02.x), thanks.
diff mbox series

Patch

diff --git a/package/skeleton-init-openrc/skeleton-init-openrc.mk b/package/skeleton-init-openrc/skeleton-init-openrc.mk
index 656fc531d7..b0538ad03f 100644
--- a/package/skeleton-init-openrc/skeleton-init-openrc.mk
+++ b/package/skeleton-init-openrc/skeleton-init-openrc.mk
@@ -19,13 +19,13 @@  ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
 # Comment /dev/root entry in fstab. When openrc does not find fstab entry for
 # "/", it will try to remount "/" as "rw".
 define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
-	$(SED) '\:^/dev/root :s/^/# /' $(TARGET_DIR)/etc/fstab
+	$(SED) '\:^/dev/root[[:blank:]]:s/^/# /' $(TARGET_DIR)/etc/fstab
 endef
 else
 # Uncomment /dev/root entry in fstab which has "ro" option so openrc notices
 # it and doesn't remount root to rw.
 define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
-	$(SED) '\:^# /dev/root:s/^# //' $(TARGET_DIR)/etc/fstab
+	$(SED) '\:^#[[:blank:]]*/dev/root[[:blank:]]:s/^# //' $(TARGET_DIR)/etc/fstab
 endef
 endif # BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW