diff mbox series

[1/1] package/python: re-enable hashlib

Message ID 20200203111837.13376-1-titouan.christophe@railnova.eu
State Accepted
Headers show
Series [1/1] package/python: re-enable hashlib | expand

Commit Message

Titouan Christophe Feb. 3, 2020, 11:18 a.m. UTC
From: Titouan Christophe <titouan.christophe@railnova.eu>

In commit e5cfb319f9493d677f059ca72b80f7fa22fc9f0f,
the committer did add the flag `--disable-hashlib` to python,
even though this was not part of the original patch
(https://patchwork.ozlabs.org/patch/1231905/).

This unexpected modification break the builds of waf-based
packages, such as jack2, mpv or aubio. This commit therefore

Fixes: http://autobuild.buildroot.net/results/2b3/2b377bcfda6e7ae4d6bb894664e3a4cb13a70b6d/
Fixes: http://autobuild.buildroot.net/results/cd5/cd5da8cb3da8479ebee60d011ce0c5dc0e59aab7/

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
---
 package/python/python.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 3, 2020, 11:31 a.m. UTC | #1
On Mon,  3 Feb 2020 12:18:37 +0100
titouan.christophe@railnova.eu wrote:

> From: Titouan Christophe <titouan.christophe@railnova.eu>
> 
> In commit e5cfb319f9493d677f059ca72b80f7fa22fc9f0f,
> the committer did add the flag `--disable-hashlib` to python,
> even though this was not part of the original patch
> (https://patchwork.ozlabs.org/patch/1231905/).
> 
> This unexpected modification break the builds of waf-based
> packages, such as jack2, mpv or aubio. This commit therefore
> 
> Fixes: http://autobuild.buildroot.net/results/2b3/2b377bcfda6e7ae4d6bb894664e3a4cb13a70b6d/
> Fixes: http://autobuild.buildroot.net/results/cd5/cd5da8cb3da8479ebee60d011ce0c5dc0e59aab7/
> 
> Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>

Note to self: "git commit -a --amend" can be dangerous. Sorry for the mess.

However, this particular change is related to a discussion I had on the
mailing list about this hashlib module which was causing build issues
on some machines in host Python. This module needs OpenSSL on the host,
which we don't have installed on some autobuilders. So how come we
hadn't seen these failures before ?

Thomas
diff mbox series

Patch

diff --git a/package/python/python.mk b/package/python/python.mk
index 9e3c32687c..41a981e3d3 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -60,7 +60,7 @@  HOST_PYTHON_DEPENDENCIES = host-expat host-zlib
 ifeq ($(BR2_PACKAGE_HOST_PYTHON_SSL),y)
 HOST_PYTHON_DEPENDENCIES += host-openssl
 else
-HOST_PYTHON_CONF_OPTS += --disable-ssl --disable-hashlib
+HOST_PYTHON_CONF_OPTS += --disable-ssl
 endif
 
 PYTHON_INSTALL_STAGING = YES