diff mbox series

[2/2] package/docker-proxy: bump to feeff4

Message ID 20200110045033.1920685-2-christian@paral.in
State Changes Requested, archived
Headers show
Series [1/2] package/docker-containerd: bump to 1.3.2 | expand

Commit Message

Christian Stewart Jan. 10, 2020, 4:50 a.m. UTC
docker-proxy (libnetwork) has not added a release tag for a long time. Use the
latest master commit hash from 09 Jan 2020 instead.

Signed-off-by: Christian Stewart <christian@paral.in>
---
 package/docker-proxy/docker-proxy.hash | 2 +-
 package/docker-proxy/docker-proxy.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Jan. 10, 2020, 8:40 a.m. UTC | #1
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > docker-proxy (libnetwork) has not added a release tag for a long time. Use the
 > latest master commit hash from 09 Jan 2020 instead.

 > Signed-off-by: Christian Stewart <christian@paral.in>

Same comment as for docker-containerd.

I was of the understanding that docker-proxy isn't really needed any
more. Can you clarify?


 > ---
 >  package/docker-proxy/docker-proxy.hash | 2 +-
 >  package/docker-proxy/docker-proxy.mk   | 2 +-
 >  2 files changed, 2 insertions(+), 2 deletions(-)

 > diff --git a/package/docker-proxy/docker-proxy.hash b/package/docker-proxy/docker-proxy.hash
 > index 58de697929..4fa9541bed 100644
 > --- a/package/docker-proxy/docker-proxy.hash
 > +++ b/package/docker-proxy/docker-proxy.hash
 > @@ -1,3 +1,3 @@
 >  # Locally calculated
 > -sha256	866c8d196b9396a383b437b0d775476459ed7c11f527c4f6bbf1fd08524b461d	docker-proxy-55685ba49593e67f5e1c8180539379b16736c25e.tar.gz
 > +sha256  0fffcd438b9a87a7ff8315364ff4631d2241ac0cf9f9f83871aeafcb2a383fd1  docker-proxy-feeff4f0a3fd2a2bb19cf67c826082c66ffaaed9.tar.gz
 >  sha256  cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14	LICENSE
 > diff --git a/package/docker-proxy/docker-proxy.mk b/package/docker-proxy/docker-proxy.mk
 > index 8843266c30..67f1ae2a90 100644
 > --- a/package/docker-proxy/docker-proxy.mk
 > +++ b/package/docker-proxy/docker-proxy.mk
 > @@ -4,7 +4,7 @@
 >  #
 >  ################################################################################
 
 > -DOCKER_PROXY_VERSION = 55685ba49593e67f5e1c8180539379b16736c25e
 > +DOCKER_PROXY_VERSION = feeff4f0a3fd2a2bb19cf67c826082c66ffaaed9
 >  DOCKER_PROXY_SITE = $(call github,docker,libnetwork,$(DOCKER_PROXY_VERSION))
 
 >  DOCKER_PROXY_LICENSE = Apache-2.0
 > -- 
 > 2.24.1

 > _______________________________________________
 > buildroot mailing list
 > buildroot@busybox.net
 > http://lists.busybox.net/mailman/listinfo/buildroot
Christian Stewart Jan. 11, 2020, 4:20 a.m. UTC | #2
Hi Peter,

On Fri, Jan 10, 2020 at 12:40 AM Peter Korsgaard <peter@korsgaard.com> wrote:
> I was of the understanding that docker-proxy isn't really needed any
> more. Can you clarify?

I have build + run tested it with the latest version as built by this
patch. Docker-proxy is still used in the Gentoo build files.

There's not much information online about docker-proxy, one article
even claims that it should be a symlink to the docker binary itself.

The docker-proxy binary is executed when port-forwarding.

$ docker run -d -p 80:8080 nginx

Results in the following being run:

/usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 80
-container-ip 172.17.0.2 -container-port 8080

The binary does need to be in place, and it works fine after this
version bump. I'm not sure if it could be replaced with a symlink to
the docker binary itself.

Best regards,
Christian
Peter Korsgaard Jan. 11, 2020, 8:31 a.m. UTC | #3
>>>>> "Christian" == Christian Stewart <christian@paral.in> writes:

 > Hi Peter,
 > On Fri, Jan 10, 2020 at 12:40 AM Peter Korsgaard <peter@korsgaard.com> wrote:
 >> I was of the understanding that docker-proxy isn't really needed any
 >> more. Can you clarify?

 > I have build + run tested it with the latest version as built by this
 > patch. Docker-proxy is still used in the Gentoo build files.

 > There's not much information online about docker-proxy, one article
 > even claims that it should be a symlink to the docker binary itself.

 > The docker-proxy binary is executed when port-forwarding.

 > $ docker run -d -p 80:8080 nginx

 > Results in the following being run:

 > /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 80
 > -container-ip 172.17.0.2 -container-port 8080

 > The binary does need to be in place, and it works fine after this
 > version bump. I'm not sure if it could be replaced with a symlink to
 > the docker binary itself.

Ok. I am referring to references like this:

https://github.com/moby/moby/issues/14856

https://serverfault.com/questions/633604/what-is-the-point-of-the-docker-proxy-process-why-is-a-userspace-tcp-proxy-need

Which makes me think that docker-proxy should be optional rather than
unconditionally selected by docker-engine.

What do you think?
Christian Stewart Feb. 4, 2020, 11:06 p.m. UTC | #4
Hi Peter,

Peter Korsgaard <peter@korsgaard.com> writes:
> Ok. I am referring to references like this:
>
> https://github.com/moby/moby/issues/14856
>
> https://serverfault.com/questions/633604/what-is-the-point-of-the-docker-proxy-process-why-is-a-userspace-tcp-proxy-need
>
> Which makes me think that docker-proxy should be optional rather than
> unconditionally selected by docker-engine.
>
> What do you think?

We could set --userland-proxy=false on the daemon, perhaps, and remove
the docker-proxy requirement? I will do some tests on this.

I think it makes sense to first bump docker-proxy (it still is started
and used with the current configuration) and then remove it later.

Best regards,
Christian
diff mbox series

Patch

diff --git a/package/docker-proxy/docker-proxy.hash b/package/docker-proxy/docker-proxy.hash
index 58de697929..4fa9541bed 100644
--- a/package/docker-proxy/docker-proxy.hash
+++ b/package/docker-proxy/docker-proxy.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256	866c8d196b9396a383b437b0d775476459ed7c11f527c4f6bbf1fd08524b461d	docker-proxy-55685ba49593e67f5e1c8180539379b16736c25e.tar.gz
+sha256  0fffcd438b9a87a7ff8315364ff4631d2241ac0cf9f9f83871aeafcb2a383fd1  docker-proxy-feeff4f0a3fd2a2bb19cf67c826082c66ffaaed9.tar.gz
 sha256  cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14	LICENSE
diff --git a/package/docker-proxy/docker-proxy.mk b/package/docker-proxy/docker-proxy.mk
index 8843266c30..67f1ae2a90 100644
--- a/package/docker-proxy/docker-proxy.mk
+++ b/package/docker-proxy/docker-proxy.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-DOCKER_PROXY_VERSION = 55685ba49593e67f5e1c8180539379b16736c25e
+DOCKER_PROXY_VERSION = feeff4f0a3fd2a2bb19cf67c826082c66ffaaed9
 DOCKER_PROXY_SITE = $(call github,docker,libnetwork,$(DOCKER_PROXY_VERSION))
 
 DOCKER_PROXY_LICENSE = Apache-2.0