diff mbox series

[1/1] package/tinyssh: new package

Message ID 20190819234413.18292-1-vadim4j@gmail.com
State Accepted
Headers show
Series [1/1] package/tinyssh: new package | expand

Commit Message

Vadym Kochan Aug. 19, 2019, 11:44 p.m. UTC
TinySSH is a minimalistic SSH server which implements only a subset of
SSHv2 features.

Might be useful for small systems.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
---
 DEVELOPERS                   |  1 +
 package/Config.in            |  1 +
 package/tinyssh/Config.in    |  8 ++++++++
 package/tinyssh/tinyssh.hash |  2 ++
 package/tinyssh/tinyssh.mk   | 19 +++++++++++++++++++
 5 files changed, 31 insertions(+)
 create mode 100644 package/tinyssh/Config.in
 create mode 100644 package/tinyssh/tinyssh.hash
 create mode 100644 package/tinyssh/tinyssh.mk

Comments

Giulio Benetti Dec. 20, 2019, 3:56 p.m. UTC | #1
Hi Vadim,

On 8/20/19 1:44 AM, Vadim Kochan wrote:
> TinySSH is a minimalistic SSH server which implements only a subset of
> SSHv2 features.
> 
> Might be useful for small systems.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> ---
>   DEVELOPERS                   |  1 +
>   package/Config.in            |  1 +
>   package/tinyssh/Config.in    |  8 ++++++++
>   package/tinyssh/tinyssh.hash |  2 ++
>   package/tinyssh/tinyssh.mk   | 19 +++++++++++++++++++
>   5 files changed, 31 insertions(+)
>   create mode 100644 package/tinyssh/Config.in
>   create mode 100644 package/tinyssh/tinyssh.hash
>   create mode 100644 package/tinyssh/tinyssh.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index e50ac78ae7..5884cea0a0 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -2307,6 +2307,7 @@ F:	package/tstools/
>   N:	Vadim Kochan <vadim4j@gmail.com>
>   F:	package/brcm-patchram-plus/
>   F:	package/gettext-tiny/
> +F:	package/tinyssh/
>   
>   N:	Valentin Korenblit <valentinkorenblit@gmail.com>
>   F:	package/clang/
> diff --git a/package/Config.in b/package/Config.in
> index 710ed12be0..d6793c891b 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -2073,6 +2073,7 @@ endif
>   	source "package/thttpd/Config.in"
>   	source "package/tinc/Config.in"
>   	source "package/tinyhttpd/Config.in"
> +	source "package/tinyssh/Config.in"
>   	source "package/tor/Config.in"
>   	source "package/traceroute/Config.in"
>   	source "package/transmission/Config.in"
> diff --git a/package/tinyssh/Config.in b/package/tinyssh/Config.in
> new file mode 100644
> index 0000000000..da19d2d454
> --- /dev/null
> +++ b/package/tinyssh/Config.in
> @@ -0,0 +1,8 @@
> +config BR2_PACKAGE_TINYSSH
> +	bool "tinyssh"
> +	depends on BR2_USE_MMU # fork()
> +	help
> +	  TinySSH is a minimalistic SSH server which implements only
> +	  a subset of SSHv2 features.
> +
> +	  https://tinyssh.org
> diff --git a/package/tinyssh/tinyssh.hash b/package/tinyssh/tinyssh.hash
> new file mode 100644
> index 0000000000..0ca7c5b741
> --- /dev/null
> +++ b/package/tinyssh/tinyssh.hash
> @@ -0,0 +1,2 @@
> +# locally computed
> +sha256  7e5e080c594db9110869ecea7c9a258507a0de10a09613a584347b3d707fb609  tinyssh-acd059bcac384fcd4af35d1babc87142eca610af.tar.gz
> diff --git a/package/tinyssh/tinyssh.mk b/package/tinyssh/tinyssh.mk
> new file mode 100644
> index 0000000000..69341e13e8
> --- /dev/null
> +++ b/package/tinyssh/tinyssh.mk
> @@ -0,0 +1,19 @@
> +################################################################################
> +#
> +# tinyssh
> +#
> +################################################################################
> +
> +TINYSSH_VERSION = acd059bcac384fcd4af35d1babc87142eca610af
> +TINYSSH_SITE = $(call github,janmojzis,tinyssh,$(TINYSSH_VERSION))
> +TINYSSH_LICENSE = CC0-1.0

Here you are missing TINYSSH_LICENSE_FILES(from what I can see there is 
only LICENCE as file).

Can you please submit a v2 version with license files? And can you also 
check if there are other license files inside the package?

Best regards
Yann E. MORIN Jan. 1, 2020, 11:01 a.m. UTC | #2
Vadim, All,

On 2019-08-20 02:44 +0300, Vadim Kochan spake thusly:
> TinySSH is a minimalistic SSH server which implements only a subset of
> SSHv2 features.
> 
> Might be useful for small systems.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>

Applied to master with the following changes:
  - add missing licence file, as noticed by Giulio
  - update the version to bring two fixes
  - update hash file accordingly (version and licence file)

Regards,
Yann E. MORIN.

> ---
>  DEVELOPERS                   |  1 +
>  package/Config.in            |  1 +
>  package/tinyssh/Config.in    |  8 ++++++++
>  package/tinyssh/tinyssh.hash |  2 ++
>  package/tinyssh/tinyssh.mk   | 19 +++++++++++++++++++
>  5 files changed, 31 insertions(+)
>  create mode 100644 package/tinyssh/Config.in
>  create mode 100644 package/tinyssh/tinyssh.hash
>  create mode 100644 package/tinyssh/tinyssh.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index e50ac78ae7..5884cea0a0 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -2307,6 +2307,7 @@ F:	package/tstools/
>  N:	Vadim Kochan <vadim4j@gmail.com>
>  F:	package/brcm-patchram-plus/
>  F:	package/gettext-tiny/
> +F:	package/tinyssh/
>  
>  N:	Valentin Korenblit <valentinkorenblit@gmail.com>
>  F:	package/clang/
> diff --git a/package/Config.in b/package/Config.in
> index 710ed12be0..d6793c891b 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -2073,6 +2073,7 @@ endif
>  	source "package/thttpd/Config.in"
>  	source "package/tinc/Config.in"
>  	source "package/tinyhttpd/Config.in"
> +	source "package/tinyssh/Config.in"
>  	source "package/tor/Config.in"
>  	source "package/traceroute/Config.in"
>  	source "package/transmission/Config.in"
> diff --git a/package/tinyssh/Config.in b/package/tinyssh/Config.in
> new file mode 100644
> index 0000000000..da19d2d454
> --- /dev/null
> +++ b/package/tinyssh/Config.in
> @@ -0,0 +1,8 @@
> +config BR2_PACKAGE_TINYSSH
> +	bool "tinyssh"
> +	depends on BR2_USE_MMU # fork()
> +	help
> +	  TinySSH is a minimalistic SSH server which implements only
> +	  a subset of SSHv2 features.
> +
> +	  https://tinyssh.org
> diff --git a/package/tinyssh/tinyssh.hash b/package/tinyssh/tinyssh.hash
> new file mode 100644
> index 0000000000..0ca7c5b741
> --- /dev/null
> +++ b/package/tinyssh/tinyssh.hash
> @@ -0,0 +1,2 @@
> +# locally computed
> +sha256  7e5e080c594db9110869ecea7c9a258507a0de10a09613a584347b3d707fb609  tinyssh-acd059bcac384fcd4af35d1babc87142eca610af.tar.gz
> diff --git a/package/tinyssh/tinyssh.mk b/package/tinyssh/tinyssh.mk
> new file mode 100644
> index 0000000000..69341e13e8
> --- /dev/null
> +++ b/package/tinyssh/tinyssh.mk
> @@ -0,0 +1,19 @@
> +################################################################################
> +#
> +# tinyssh
> +#
> +################################################################################
> +
> +TINYSSH_VERSION = acd059bcac384fcd4af35d1babc87142eca610af
> +TINYSSH_SITE = $(call github,janmojzis,tinyssh,$(TINYSSH_VERSION))
> +TINYSSH_LICENSE = CC0-1.0
> +
> +define TINYSSH_BUILD_CMDS
> +	$(TARGET_MAKE_ENV) CC="$(TARGET_CC)" $(MAKE) -C $(@D) cross-compile
> +endef
> +
> +define TINYSSH_INSTALL_TARGET_CMDS
> +	$(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
> +endef
> +
> +$(eval $(generic-package))
> -- 
> 2.22.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index e50ac78ae7..5884cea0a0 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -2307,6 +2307,7 @@  F:	package/tstools/
 N:	Vadim Kochan <vadim4j@gmail.com>
 F:	package/brcm-patchram-plus/
 F:	package/gettext-tiny/
+F:	package/tinyssh/
 
 N:	Valentin Korenblit <valentinkorenblit@gmail.com>
 F:	package/clang/
diff --git a/package/Config.in b/package/Config.in
index 710ed12be0..d6793c891b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2073,6 +2073,7 @@  endif
 	source "package/thttpd/Config.in"
 	source "package/tinc/Config.in"
 	source "package/tinyhttpd/Config.in"
+	source "package/tinyssh/Config.in"
 	source "package/tor/Config.in"
 	source "package/traceroute/Config.in"
 	source "package/transmission/Config.in"
diff --git a/package/tinyssh/Config.in b/package/tinyssh/Config.in
new file mode 100644
index 0000000000..da19d2d454
--- /dev/null
+++ b/package/tinyssh/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_TINYSSH
+	bool "tinyssh"
+	depends on BR2_USE_MMU # fork()
+	help
+	  TinySSH is a minimalistic SSH server which implements only
+	  a subset of SSHv2 features.
+
+	  https://tinyssh.org
diff --git a/package/tinyssh/tinyssh.hash b/package/tinyssh/tinyssh.hash
new file mode 100644
index 0000000000..0ca7c5b741
--- /dev/null
+++ b/package/tinyssh/tinyssh.hash
@@ -0,0 +1,2 @@ 
+# locally computed
+sha256  7e5e080c594db9110869ecea7c9a258507a0de10a09613a584347b3d707fb609  tinyssh-acd059bcac384fcd4af35d1babc87142eca610af.tar.gz
diff --git a/package/tinyssh/tinyssh.mk b/package/tinyssh/tinyssh.mk
new file mode 100644
index 0000000000..69341e13e8
--- /dev/null
+++ b/package/tinyssh/tinyssh.mk
@@ -0,0 +1,19 @@ 
+################################################################################
+#
+# tinyssh
+#
+################################################################################
+
+TINYSSH_VERSION = acd059bcac384fcd4af35d1babc87142eca610af
+TINYSSH_SITE = $(call github,janmojzis,tinyssh,$(TINYSSH_VERSION))
+TINYSSH_LICENSE = CC0-1.0
+
+define TINYSSH_BUILD_CMDS
+	$(TARGET_MAKE_ENV) CC="$(TARGET_CC)" $(MAKE) -C $(@D) cross-compile
+endef
+
+define TINYSSH_INSTALL_TARGET_CMDS
+	$(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
+endef
+
+$(eval $(generic-package))