diff mbox series

[1/1] pkg-infra/show-info: dump install_{staging, target} info

Message ID 20190723123355.22313-1-vadim4j@gmail.com
State Changes Requested
Headers show
Series [1/1] pkg-infra/show-info: dump install_{staging, target} info | expand

Commit Message

Vadym Kochan July 23, 2019, 12:33 p.m. UTC
provide info if the package will be installed to staging/target
destinations. Might be useful for analyzing the packages which
installed only for target/staging.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
---
 package/pkg-utils.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni July 23, 2019, 12:44 p.m. UTC | #1
On Tue, 23 Jul 2019 15:33:55 +0300
Vadim Kochan <vadim4j@gmail.com> wrote:

> provide info if the package will be installed to staging/target
> destinations. Might be useful for analyzing the packages which
> installed only for target/staging.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> ---
>  package/pkg-utils.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
> index b7280e930f..81222565bf 100644
> --- a/package/pkg-utils.mk
> +++ b/package/pkg-utils.mk
> @@ -94,6 +94,14 @@ endef
>  define _json-info-pkg-details
>  	"version": "$($(1)_DL_VERSION)",
>  	"licenses": "$($(1)_LICENSE)",
> +	$(if $($(1)_INSTALL_TARGET), \
> +		"install_target": true$(comma),
> +		"install_target": false$(comma)
> +	)
> +	$(if $($(1)_INSTALL_STAGING), \
> +		"install_staging": true$(comma),
> +		"install_staging": false$(comma)
> +	)

I would prefer install-target and install-staging for the JSON property
names, I prefer - over _.

Also, maybe you can write it like this:

	"install-target": $(if $($(1)_INSTALL_TARGET),true,false),
	"install-staging": $(if $($(1)_INSTALL_STAGING),true,false),

Note: I haven't thought about whether those properties are actually
useful or not to have in the JSON output. I mainly react to the
implementation details.

Thomas
Yann E. MORIN July 28, 2019, 9:56 a.m. UTC | #2
On 2019-07-23 14:44 +0200, Thomas Petazzoni spake thusly:
> On Tue, 23 Jul 2019 15:33:55 +0300
> Vadim Kochan <vadim4j@gmail.com> wrote:
> 
> > provide info if the package will be installed to staging/target
> > destinations. Might be useful for analyzing the packages which
> > installed only for target/staging.
> > 
> > Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> > ---
> >  package/pkg-utils.mk | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> > 
> > diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
> > index b7280e930f..81222565bf 100644
> > --- a/package/pkg-utils.mk
> > +++ b/package/pkg-utils.mk
> > @@ -94,6 +94,14 @@ endef
> >  define _json-info-pkg-details
> >  	"version": "$($(1)_DL_VERSION)",
> >  	"licenses": "$($(1)_LICENSE)",
> > +	$(if $($(1)_INSTALL_TARGET), \
> > +		"install_target": true$(comma),
> > +		"install_target": false$(comma)
> > +	)
> > +	$(if $($(1)_INSTALL_STAGING), \
> > +		"install_staging": true$(comma),
> > +		"install_staging": false$(comma)
> > +	)
> 
> I would prefer install-target and install-staging for the JSON property
> names, I prefer - over _.

I do too, but Thomas DS. suggested we use _ and that's what we have in
"reverse_depenencies".

> Also, maybe you can write it like this:
> 
> 	"install-target": $(if $($(1)_INSTALL_TARGET),true,false),
> 	"install-staging": $(if $($(1)_INSTALL_STAGING),true,false),

+1

> Note: I haven't thought about whether those properties are actually
> useful or not to have in the JSON output. I mainly react to the
> implementation details.

I think it is interesting to have.

Regards,
Yann E. MORIN.
Yann E. MORIN July 28, 2019, 10:01 a.m. UTC | #3
Vadim, Thomas, All,

On 2019-07-28 11:56 +0200, Yann E. MORIN spake thusly:
> On 2019-07-23 14:44 +0200, Thomas Petazzoni spake thusly:
> > On Tue, 23 Jul 2019 15:33:55 +0300
> > Vadim Kochan <vadim4j@gmail.com> wrote:
> > > provide info if the package will be installed to staging/target
> > > destinations. Might be useful for analyzing the packages which
> > > installed only for target/staging.
[--SNIP--]
> > Also, maybe you can write it like this:
> > 	"install-target": $(if $($(1)_INSTALL_TARGET),true,false),
> > 	"install-staging": $(if $($(1)_INSTALL_STAGING),true,false),
> +1

And I missed Carlos' reply that this does not work, in fact.
So maybe something like:

    $(if $(subst NO,,$($(1)_INSTALL_TARGET)),true,false)

Regards,
Yann E. MORIN.
Peter Korsgaard Aug. 7, 2019, 7:18 a.m. UTC | #4
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > On Tue, 23 Jul 2019 15:33:55 +0300
 > Vadim Kochan <vadim4j@gmail.com> wrote:

 >> provide info if the package will be installed to staging/target
 >> destinations. Might be useful for analyzing the packages which
 >> installed only for target/staging.
 >> 
 >> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
 >> ---
 >> package/pkg-utils.mk | 8 ++++++++
 >> 1 file changed, 8 insertions(+)
 >> 
 >> diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
 >> index b7280e930f..81222565bf 100644
 >> --- a/package/pkg-utils.mk
 >> +++ b/package/pkg-utils.mk
 >> @@ -94,6 +94,14 @@ endef
 >> define _json-info-pkg-details
 >> "version": "$($(1)_DL_VERSION)",
 >> "licenses": "$($(1)_LICENSE)",
 >> +	$(if $($(1)_INSTALL_TARGET), \
 >> +		"install_target": true$(comma),
 >> +		"install_target": false$(comma)
 >> +	)
 >> +	$(if $($(1)_INSTALL_STAGING), \
 >> +		"install_staging": true$(comma),
 >> +		"install_staging": false$(comma)
 >> +	)

 > I would prefer install-target and install-staging for the JSON property
 > names, I prefer - over _.

Notice that some programming languages handle json like variables
(object.property.subproperty), and '-' is typically not allowed in
variable names.
diff mbox series

Patch

diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index b7280e930f..81222565bf 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -94,6 +94,14 @@  endef
 define _json-info-pkg-details
 	"version": "$($(1)_DL_VERSION)",
 	"licenses": "$($(1)_LICENSE)",
+	$(if $($(1)_INSTALL_TARGET), \
+		"install_target": true$(comma),
+		"install_target": false$(comma)
+	)
+	$(if $($(1)_INSTALL_STAGING), \
+		"install_staging": true$(comma),
+		"install_staging": false$(comma)
+	)
 	"downloads": [
 	$(foreach dl,$(sort $($(1)_ALL_DOWNLOADS)),
 		{