diff mbox series

package/openmpi: fix build failure due to Gcc Bug 68485

Message ID 20190530132341.62716-1-giulio.benetti@micronovasrl.com
State Accepted
Headers show
Series package/openmpi: fix build failure due to Gcc Bug 68485 | expand

Commit Message

Giulio Benetti May 30, 2019, 1:23 p.m. UTC
Package openmpi manifests Microblaze Gcc Bug 68485 resulting in a build
failure due to an Internal Compiler Error.

As done for other packages in Buildroot work around this Gcc Bug by
setting optimization to -O0 if BR2_TOOLCHAIN_HAS_GCC_BUG_68485=y.

Fixes:
http://autobuild.buildroot.net/results/8f3/8f334427e7475154d69469f8ee4efab6df80e403/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/openmpi/openmpi.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Thomas Petazzoni May 31, 2019, 8:53 p.m. UTC | #1
On Thu, 30 May 2019 15:23:41 +0200
Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:

> Package openmpi manifests Microblaze Gcc Bug 68485 resulting in a build
> failure due to an Internal Compiler Error.
> 
> As done for other packages in Buildroot work around this Gcc Bug by
> setting optimization to -O0 if BR2_TOOLCHAIN_HAS_GCC_BUG_68485=y.
> 
> Fixes:
> http://autobuild.buildroot.net/results/8f3/8f334427e7475154d69469f8ee4efab6df80e403/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---
>  package/openmpi/openmpi.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/openmpi/openmpi.mk b/package/openmpi/openmpi.mk
index 8d9eafd631..b682e6e74e 100644
--- a/package/openmpi/openmpi.mk
+++ b/package/openmpi/openmpi.mk
@@ -38,4 +38,12 @@  else
 OPENMPI_CONF_OPTS += --enable-mpi-fortran=no
 endif
 
+OPENMPI_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+OPENMPI_CFLAGS += -O0
+endif
+
+OPENMPI_CONF_ENV = CFLAGS="$(OPENMPI_CFLAGS)"
+
 $(eval $(autotools-package))