diff mbox series

package/qt5base: fix qmake parallel build

Message ID 20190422095842.61772-1-giulio.benetti@micronovasrl.com
State Accepted
Headers show
Series package/qt5base: fix qmake parallel build | expand

Commit Message

Giulio Benetti April 22, 2019, 9:58 a.m. UTC
When configuring qt5base, qmake is built, but it's not built in parallel
mode. This is due to MAKEFLAGS having 2 dashes on its tail, so this:
MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)"
expands in this(i.e. 5 njobs):
MAKEFLAGS="--no-print-directory -- -j5"
and -j5 gets ignored due to "--" preceeding -j5.
Double dashes are part of $(MAKEFLAGS) only when evaluated by shell.

Swap $(MAKEFLAGS) and -j$(PARALLEL_JOBS) to avoid having "--" before
-j$(PARALLEL_JOBS), this way -j$(PARALLEL_JOBS) won't be ignored by
./configure.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/qt5/qt5base/qt5base.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Michael Nazzareno Trimarchi April 22, 2019, 5:14 p.m. UTC | #1
Hi

On Mon, Apr 22, 2019 at 11:59 AM Giulio Benetti
<giulio.benetti@micronovasrl.com> wrote:
>
> When configuring qt5base, qmake is built, but it's not built in parallel
> mode. This is due to MAKEFLAGS having 2 dashes on its tail, so this:
> MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)"
> expands in this(i.e. 5 njobs):
> MAKEFLAGS="--no-print-directory -- -j5"
> and -j5 gets ignored due to "--" preceeding -j5.
> Double dashes are part of $(MAKEFLAGS) only when evaluated by shell.
>
> Swap $(MAKEFLAGS) and -j$(PARALLEL_JOBS) to avoid having "--" before
> -j$(PARALLEL_JOBS), this way -j$(PARALLEL_JOBS) won't be ignored by
> ./configure.
>
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---

Tested-by: Michael Trimarchi <michael@amarulasolutions.com>

Thank you

Michael
>  package/qt5/qt5base/qt5base.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
> index 0b45c50a66..e73b8931aa 100644
> --- a/package/qt5/qt5base/qt5base.mk
> +++ b/package/qt5/qt5base/qt5base.mk
> @@ -324,7 +324,7 @@ define QT5BASE_CONFIGURE_CMDS
>         (cd $(@D); \
>                 $(TARGET_MAKE_ENV) \
>                 PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
> -               MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)" \
> +               MAKEFLAGS="-j$(PARALLEL_JOBS) $(MAKEFLAGS)" \
>                 ./configure \
>                 -v \
>                 -prefix /usr \
> --
> 2.17.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni April 22, 2019, 8:25 p.m. UTC | #2
On Mon, 22 Apr 2019 11:58:42 +0200
Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:

> When configuring qt5base, qmake is built, but it's not built in parallel
> mode. This is due to MAKEFLAGS having 2 dashes on its tail, so this:
> MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)"
> expands in this(i.e. 5 njobs):
> MAKEFLAGS="--no-print-directory -- -j5"
> and -j5 gets ignored due to "--" preceeding -j5.
> Double dashes are part of $(MAKEFLAGS) only when evaluated by shell.
> 
> Swap $(MAKEFLAGS) and -j$(PARALLEL_JOBS) to avoid having "--" before
> -j$(PARALLEL_JOBS), this way -j$(PARALLEL_JOBS) won't be ignored by
> ./configure.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---
>  package/qt5/qt5base/qt5base.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 0b45c50a66..e73b8931aa 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -324,7 +324,7 @@  define QT5BASE_CONFIGURE_CMDS
 	(cd $(@D); \
 		$(TARGET_MAKE_ENV) \
 		PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
-		MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)" \
+		MAKEFLAGS="-j$(PARALLEL_JOBS) $(MAKEFLAGS)" \
 		./configure \
 		-v \
 		-prefix /usr \