diff mbox series

package/civetweb: fix link failure due to missing OpenSSL dependency

Message ID 20190409211032.66320-1-giulio.benetti@micronovasrl.com
State Accepted
Headers show
Series package/civetweb: fix link failure due to missing OpenSSL dependency | expand

Commit Message

Giulio Benetti April 9, 2019, 9:10 p.m. UTC
During linking one OpenSSL dependecy is missing(-latomic) on linking
library list.

- Substitute explicit library list with `pkg-config libssl` when
BR2_PACKAGE_OPENSSL is enabled. In such way all needed libraries will be
included in linking list.
- Add also `host-pkgconf` to CIVETWEB_DEPENDENCIES if
BR2_PACKAGE_OPENSSL is enabled to make it available for previous point.

Fixes:
http://autobuild.buildroot.net/results/b2e/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/civetweb/civetweb.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 9, 2019, 9:28 p.m. UTC | #1
On Tue,  9 Apr 2019 23:10:32 +0200
Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:

> During linking one OpenSSL dependecy is missing(-latomic) on linking
> library list.
> 
> - Substitute explicit library list with `pkg-config libssl` when
> BR2_PACKAGE_OPENSSL is enabled. In such way all needed libraries will be
> included in linking list.
> - Add also `host-pkgconf` to CIVETWEB_DEPENDENCIES if
> BR2_PACKAGE_OPENSSL is enabled to make it available for previous point.
> 
> Fixes:
> http://autobuild.buildroot.net/results/b2e/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>

Applied to master, with one small change, see below.

> +CIVETWEB_LIBS += `$(HOST_DIR)/usr/bin/pkg-config --libs libssl`

$(HOST_DIR)/usr no longer really exists, it's a symlink to $(HOST_DIR),
so this path should have been just $(HOST_DIR)/bin/pkg-config.

However, pkgconf.mk precisely provides the PKG_CONFIG_HOST_BINARY
variable, which contains exactly the path to pkg-config. So I've used
that instead.

Thanks!

Thomas
Giulio Benetti April 10, 2019, 10:06 a.m. UTC | #2
Il 09/04/2019 23:28, Thomas Petazzoni ha scritto:> $(HOST_DIR)/usr no 
longer really exists, it's a symlink to $(HOST_DIR),
> so this path should have been just $(HOST_DIR)/bin/pkg-config.
> 
> However, pkgconf.mk precisely provides the PKG_CONFIG_HOST_BINARY
> variable, which contains exactly the path to pkg-config. So I've used
> that instead.

Ah I've missed that variable good to know.

Thank you
Peter Korsgaard April 14, 2019, 9:26 p.m. UTC | #3
>>>>> "Giulio" == Giulio Benetti <giulio.benetti@micronovasrl.com> writes:

 > During linking one OpenSSL dependecy is missing(-latomic) on linking
 > library list.

 > - Substitute explicit library list with `pkg-config libssl` when
 > BR2_PACKAGE_OPENSSL is enabled. In such way all needed libraries will be
 > included in linking list.
 > - Add also `host-pkgconf` to CIVETWEB_DEPENDENCIES if
 > BR2_PACKAGE_OPENSSL is enabled to make it available for previous point.

 > Fixes:
 > http://autobuild.buildroot.net/results/b2e/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c/

 > Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>

Committed to 2019.02.x, thanks.
diff mbox series

Patch

diff --git a/package/civetweb/civetweb.mk b/package/civetweb/civetweb.mk
index fe1cdd5675..c999ec89be 100644
--- a/package/civetweb/civetweb.mk
+++ b/package/civetweb/civetweb.mk
@@ -32,8 +32,8 @@  endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 CIVETWEB_COPT += -DNO_SSL_DL
-CIVETWEB_LIBS += -lssl -lcrypto -lz
-CIVETWEB_DEPENDENCIES += openssl
+CIVETWEB_LIBS += `$(HOST_DIR)/usr/bin/pkg-config --libs libssl`
+CIVETWEB_DEPENDENCIES += openssl host-pkgconf
 else
 CIVETWEB_COPT += -DNO_SSL
 endif