diff mbox series

package/gettext-tiny: bump version to add --template option

Message ID 20190404143132.7416-1-giulio.benetti@micronovasrl.com
State Accepted
Headers show
Series package/gettext-tiny: bump version to add --template option | expand

Commit Message

Giulio Benetti April 4, 2019, 2:31 p.m. UTC
Some package(i.e. rygel) uses gettext-tiny msgfmt with --template option
to build, but current version(0.3.1) doesn't support --template flag and
exits giving:
"fopen: No such file or directory"
On master branch they've added support for --template after lot of
modifications, so it's hard to produce a patch to be applied against
0.3.1.

Then bump version to latest master branch commit.

Fixes:
http://autobuild.buildroot.net/results/77b/77b1854c914915d3205d915a0f01001f6f3555df/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/gettext-tiny/gettext-tiny.hash | 2 +-
 package/gettext-tiny/gettext-tiny.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 4, 2019, 8:18 p.m. UTC | #1
On Thu,  4 Apr 2019 16:31:32 +0200
Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:

> Some package(i.e. rygel) uses gettext-tiny msgfmt with --template option
> to build, but current version(0.3.1) doesn't support --template flag and
> exits giving:
> "fopen: No such file or directory"
> On master branch they've added support for --template after lot of
> modifications, so it's hard to produce a patch to be applied against
> 0.3.1.
> 
> Then bump version to latest master branch commit.
> 
> Fixes:
> http://autobuild.buildroot.net/results/77b/77b1854c914915d3205d915a0f01001f6f3555df/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---
>  package/gettext-tiny/gettext-tiny.hash | 2 +-
>  package/gettext-tiny/gettext-tiny.mk   | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Vadym Kochan April 4, 2019, 9:36 p.m. UTC | #2
Hi Thomas, Giulio, All

On Thu, Apr 04, 2019 at 10:18:06PM +0200, Thomas Petazzoni wrote:
> On Thu,  4 Apr 2019 16:31:32 +0200
> Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:
> 
> > Some package(i.e. rygel) uses gettext-tiny msgfmt with --template option
> > to build, but current version(0.3.1) doesn't support --template flag and
> > exits giving:
> > "fopen: No such file or directory"
> > On master branch they've added support for --template after lot of
> > modifications, so it's hard to produce a patch to be applied against
> > 0.3.1.
> > 
> > Then bump version to latest master branch commit.
> > 
> > Fixes:
> > http://autobuild.buildroot.net/results/77b/77b1854c914915d3205d915a0f01001f6f3555df/
> > 
> > Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> > ---
> >  package/gettext-tiny/gettext-tiny.hash | 2 +-
> >  package/gettext-tiny/gettext-tiny.mk   | 2 +-
> >  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> Applied to master, thanks.
> 

It causes to fail libglib2 with formatting errors :(,
just checked with ./utils/test-pkg ...

Regards,
Vadim Kochan
Vadym Kochan April 4, 2019, 10:08 p.m. UTC | #3
Hi Again,

On Fri, Apr 05, 2019 at 12:36:28AM +0300, Vadim Kochan wrote:
> Hi Thomas, Giulio, All
> 
> On Thu, Apr 04, 2019 at 10:18:06PM +0200, Thomas Petazzoni wrote:
> > On Thu,  4 Apr 2019 16:31:32 +0200
> > Giulio Benetti <giulio.benetti@micronovasrl.com> wrote:
> > 
> > > Some package(i.e. rygel) uses gettext-tiny msgfmt with --template option
> > > to build, but current version(0.3.1) doesn't support --template flag and
> > > exits giving:
> > > "fopen: No such file or directory"
> > > On master branch they've added support for --template after lot of
> > > modifications, so it's hard to produce a patch to be applied against
> > > 0.3.1.
> > > 
> > > Then bump version to latest master branch commit.
> > > 
> > > Fixes:
> > > http://autobuild.buildroot.net/results/77b/77b1854c914915d3205d915a0f01001f6f3555df/
> > > 
> > > Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> > > ---
> > >  package/gettext-tiny/gettext-tiny.hash | 2 +-
> > >  package/gettext-tiny/gettext-tiny.mk   | 2 +-
> > >  2 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > Applied to master, thanks.
> > 
> 
> It causes to fail libglib2 with formatting errors :(,
> just checked with ./utils/test-pkg ...
> 
> Regards,
> Vadim Kochan

The following diff helps .....

----------------------8<------------------------------
diff --git a/package/Makefile.in b/package/Makefile.in
index dc818a2c18..c719d39235 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -159,6 +159,9 @@ TARGET_HARDENED += -D_FORTIFY_SOURCE=2
 endif
 
 TARGET_CPPFLAGS += -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
+TARGET_CPPFLAGS += -DLIBINTL_NO_MACROS=1
+endif
 TARGET_CFLAGS = $(TARGET_CPPFLAGS) $(TARGET_ABI) $(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) $(TARGET_HARDENED)
 TARGET_CXXFLAGS = $(TARGET_CFLAGS)
 TARGET_FCFLAGS = $(TARGET_ABI) $(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
@@ -220,6 +223,9 @@ UNZIP := $(shell which unzip || type -p unzip) -q
 APPLY_PATCHES = PATH=$(HOST_DIR)/bin:$$PATH support/scripts/apply-patches.sh $(if $(QUIET),-s)
 
 HOST_CPPFLAGS  = -I$(HOST_DIR)/include
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
+HOST_CPPFLAGS += -DLIBINTL_NO_MACROS=1
+endif
 HOST_CFLAGS   ?= -O2
 HOST_CFLAGS   += $(HOST_CPPFLAGS)
 HOST_CXXFLAGS += $(HOST_CFLAGS)
---------------------->8------------------------------

Regards,
Vadim Kochan
diff mbox series

Patch

diff --git a/package/gettext-tiny/gettext-tiny.hash b/package/gettext-tiny/gettext-tiny.hash
index 672e964186..7d13054144 100644
--- a/package/gettext-tiny/gettext-tiny.hash
+++ b/package/gettext-tiny/gettext-tiny.hash
@@ -1,5 +1,5 @@ 
 # Locally Computed:
-sha256 654dcd52f2650476c8822b60bee89c20a0aa7f6a1bf6001701eeacd71a9e388b  gettext-tiny-v0.3.1.tar.gz
+sha256 00b03b08d909021aa5580fb45b6cf0ec45e9084ef94c26f034f03a64a69942bc  gettext-tiny-c6dcdcdef801127549d3906d153c061880d25a73.tar.gz
 sha256 b57aa4fdc1c614c28d41c1e2d5c4090935964c5f86291ba7d1c99ffd1d698b34  LICENSE
 sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  extra/COPYING
 # From http://lists.gnu.org/archive/html/bug-gettext/2016-06/msg00008.html
diff --git a/package/gettext-tiny/gettext-tiny.mk b/package/gettext-tiny/gettext-tiny.mk
index 881edc6f35..e3a6d11399 100644
--- a/package/gettext-tiny/gettext-tiny.mk
+++ b/package/gettext-tiny/gettext-tiny.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GETTEXT_TINY_VERSION = v0.3.1
+GETTEXT_TINY_VERSION = c6dcdcdef801127549d3906d153c061880d25a73
 GETTEXT_TINY_SITE = $(call github,sabotage-linux,gettext-tiny,$(GETTEXT_TINY_VERSION))
 GETTEXT_TINY_LICENSE = MIT, GPL-3.0+ (extra gettext)
 GETTEXT_TINY_INSTALL_STAGING = YES