diff mbox series

package/pugixml: force-enable 'long long' support to support gcc<4.8

Message ID 20190205142826.18285-1-patrickdepinguin@gmail.com
State Accepted
Commit 189c63f276fa98ef3a59b6762d87cbe0cd9974ea
Headers show
Series package/pugixml: force-enable 'long long' support to support gcc<4.8 | expand

Commit Message

Thomas De Schampheleire Feb. 5, 2019, 2:28 p.m. UTC
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

Although pugixml will enable 'long long' support automatically if it detects
C++11 (gcc 4.8+), we would like to support older gcc compilers too.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
 package/pugixml/pugixml.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard Feb. 5, 2019, 7:55 p.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 > Although pugixml will enable 'long long' support automatically if it detects
 > C++11 (gcc 4.8+), we would like to support older gcc compilers too.

 > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>

4.8 is really old, but OK.

Committed, thanks.
Thomas De Schampheleire Feb. 5, 2019, 8:03 p.m. UTC | #2
El mar., 5 feb. 2019 a las 20:55, Peter Korsgaard
(<peter@korsgaard.com>) escribió:
>
> >>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:
>
>  > From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
>  > Although pugixml will enable 'long long' support automatically if it detects
>  > C++11 (gcc 4.8+), we would like to support older gcc compilers too.
>
>  > Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
>
> 4.8 is really old, but OK.

Yes. The Marvell Octeon toolchain still has 4.7.0...

Thanks for applying...

/Thomas
diff mbox series

Patch

diff --git a/package/pugixml/pugixml.mk b/package/pugixml/pugixml.mk
index acf22604c4..8edaddd827 100644
--- a/package/pugixml/pugixml.mk
+++ b/package/pugixml/pugixml.mk
@@ -10,6 +10,12 @@  PUGIXML_LICENSE = MIT
 PUGIXML_LICENSE_FILES = readme.txt
 PUGIXML_INSTALL_STAGING = YES
 
+# Pugixml will automatically enable 'long long' support on C++11 compilers,
+# which means gcc 4.8+. As gcc always supports the 'long long' type,
+# force-enable this option to support older gcc versions. See also:
+# https://gcc.gnu.org/onlinedocs/gcc/Long-Long.html
+PUGIXML_BUILD_DEFINES += PUGIXML_HAS_LONG_LONG
+
 ifeq ($(BR2_PACKAGE_PUGIXML_XPATH_SUPPORT),)
 PUGIXML_BUILD_DEFINES += PUGIXML_NO_XPATH
 endif