diff mbox series

[v2,1/3] package/wine: Add gettext dependency for host-wine only with NLS enabled

Message ID 20190105200046.31512-2-vadim4j@gmail.com
State Accepted
Headers show
Series Add gettext-tiny package | expand

Commit Message

Vadym Kochan Jan. 5, 2019, 8 p.m. UTC
Checked that host-wine compiles ok without host-gettext, so no
needs to specify this dependency.

libgettextpo is required by tools/wrc (https://linux.die.net/man/1/wrc)
which allows to convert windows resources also to *.po format, which is
not needed if NLS is disabled.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
---
 package/wine/wine.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Feb. 6, 2019, 1:12 p.m. UTC | #1
On Sat,  5 Jan 2019 22:00:44 +0200
Vadim Kochan <vadim4j@gmail.com> wrote:

> Checked that host-wine compiles ok without host-gettext, so no
> needs to specify this dependency.
> 
> libgettextpo is required by tools/wrc (https://linux.die.net/man/1/wrc)
> which allows to convert windows resources also to *.po format, which is
> not needed if NLS is disabled.
> 
> Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
> ---
>  package/wine/wine.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/wine/wine.mk b/package/wine/wine.mk
index 78c8e6ab63..7e44e3c81d 100644
--- a/package/wine/wine.mk
+++ b/package/wine/wine.mk
@@ -307,8 +307,12 @@  WINE_CONF_OPTS += --without-zlib
 endif
 
 # host-gettext is essential for .po file support in host-wine wrc
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
 HOST_WINE_DEPENDENCIES += host-gettext
 HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
+else
+HOST_WINE_CONF_OPTS += --without-gettext --without-gettextpo
+endif
 
 # Wine needs to enable 64-bit build tools on 64-bit host
 ifeq ($(HOSTARCH),x86_64)