diff mbox series

[v2,1/4] system cfg: introduce option BR2_SYSTEM_DEFAULT_PATH

Message ID 20181219210455.14754-2-mmayer@broadcom.com
State Superseded
Headers show
Series Allow customization of system default PATH | expand

Commit Message

Markus Mayer Dec. 19, 2018, 9:04 p.m. UTC
The configuration option BR2_SYSTEM_DEFAULT_PATH allows the user to
override the default path, which can be used by /etc/profile and some
system daemons.

It defaults to the value previously hard-coded in /etc/profile. This
default should be suitable for most users.

Signed-off-by: Markus Mayer <mmayer@broadcom.com>
---
 system/Config.in | 9 +++++++++
 system/system.mk | 4 ++++
 2 files changed, 13 insertions(+)

Comments

Yann E. MORIN Dec. 19, 2018, 9:32 p.m. UTC | #1
Markus, All,

On 2018-12-19 13:04 -0800, Markus Mayer spake thusly:
> The configuration option BR2_SYSTEM_DEFAULT_PATH allows the user to
> override the default path, which can be used by /etc/profile and some
> system daemons.
> 
> It defaults to the value previously hard-coded in /etc/profile. This
> default should be suitable for most users.
> 
> Signed-off-by: Markus Mayer <mmayer@broadcom.com>
> ---
>  system/Config.in | 9 +++++++++
>  system/system.mk | 4 ++++
>  2 files changed, 13 insertions(+)
> 
> diff --git a/system/Config.in b/system/Config.in
> index 0f77b9b6721a..afae487a4bd5 100644
> --- a/system/Config.in
> +++ b/system/Config.in
> @@ -386,6 +386,15 @@ comment "automatic network configuration via DHCP needs ifupdown or busybox or n
>  
>  endif # BR2_ROOTFS_SKELETON_DEFAULT
>  
> +config BR2_SYSTEM_DEFAULT_PATH
> +	string "Set the system's default PATH"
> +	default "/bin:/sbin:/usr/bin:/usr/sbin"
> +	help
> +	  Sets the system's default PATH. It is being used in /etc/profile

Slight formatting issue here, check-package conplains:

    system/Config.in:393: help text: <tab><2 spaces><62 chars> (http://nightly.buildroot.org/#writing-rules-config-in)

Otherwise (no need to respin, that can be fixed when applying I hope):

Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> +	  in the skeleton-init-common package and by some daemons.
> +
> +	  The default should work in most cases.
> +
>  config BR2_ENABLE_LOCALE_PURGE
>  	bool "Purge unwanted locales"
>  	default y
> diff --git a/system/system.mk b/system/system.mk
> index ca6bf1388f39..8db87cb12930 100644
> --- a/system/system.mk
> +++ b/system/system.mk
> @@ -86,3 +86,7 @@ define SYSTEM_REMOUNT_ROOT_INITTAB
>  	$(SED) '/^[^#].*-o remount,rw \/$$/s~^~#~' $(TARGET_DIR)/etc/inittab
>  endef
>  endif
> +
> +ifeq ($(BR_BUILDING)$(BR2_SYSTEM_DEFAULT_PATH),y"")
> +$(error BR2_SYSTEM_DEFAULT_PATH can't be empty)
> +endif
> -- 
> 2.17.1
>
diff mbox series

Patch

diff --git a/system/Config.in b/system/Config.in
index 0f77b9b6721a..afae487a4bd5 100644
--- a/system/Config.in
+++ b/system/Config.in
@@ -386,6 +386,15 @@  comment "automatic network configuration via DHCP needs ifupdown or busybox or n
 
 endif # BR2_ROOTFS_SKELETON_DEFAULT
 
+config BR2_SYSTEM_DEFAULT_PATH
+	string "Set the system's default PATH"
+	default "/bin:/sbin:/usr/bin:/usr/sbin"
+	help
+	  Sets the system's default PATH. It is being used in /etc/profile
+	  in the skeleton-init-common package and by some daemons.
+
+	  The default should work in most cases.
+
 config BR2_ENABLE_LOCALE_PURGE
 	bool "Purge unwanted locales"
 	default y
diff --git a/system/system.mk b/system/system.mk
index ca6bf1388f39..8db87cb12930 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -86,3 +86,7 @@  define SYSTEM_REMOUNT_ROOT_INITTAB
 	$(SED) '/^[^#].*-o remount,rw \/$$/s~^~#~' $(TARGET_DIR)/etc/inittab
 endef
 endif
+
+ifeq ($(BR_BUILDING)$(BR2_SYSTEM_DEFAULT_PATH),y"")
+$(error BR2_SYSTEM_DEFAULT_PATH can't be empty)
+endif