diff mbox series

package/liquid-dsp: add missing dependency on fftw

Message ID 20181212090458.15747-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/liquid-dsp: add missing dependency on fftw | expand

Commit Message

Thomas Petazzoni Dec. 12, 2018, 9:04 a.m. UTC
When one of BR2_PACKAGE_FFTW_PRECISION_* is enabled, liquid-dsp links
against fftw3f, fftw3 or fftw3l, but forgets to add the fftw package
in its dependencies. It works fine in practice because "fftw" is
before "liquid-dsp" in the alphabetic ordering, but building with
"make liquid-dsp" or with per-package directory causes a build
failure.

Fix that by adding the missing dependencies.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/liquid-dsp/liquid-dsp.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Gwenhael Goavec-Merou Dec. 12, 2018, 9:21 a.m. UTC | #1
Thomas,
This issue is also fixed by http://patchwork.ozlabs.org/patch/1011657/

Regards,
Gwen

On Wed, 12 Dec 2018 10:04:58 +0100
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> When one of BR2_PACKAGE_FFTW_PRECISION_* is enabled, liquid-dsp links
> against fftw3f, fftw3 or fftw3l, but forgets to add the fftw package
> in its dependencies. It works fine in practice because "fftw" is
> before "liquid-dsp" in the alphabetic ordering, but building with
> "make liquid-dsp" or with per-package directory causes a build
> failure.
> 
> Fix that by adding the missing dependencies.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/liquid-dsp/liquid-dsp.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/liquid-dsp/liquid-dsp.mk
> b/package/liquid-dsp/liquid-dsp.mk index e3114a2d15..db67893844 100644
> --- a/package/liquid-dsp/liquid-dsp.mk
> +++ b/package/liquid-dsp/liquid-dsp.mk
> @@ -32,6 +32,7 @@ endif
>  # use FFTW instead of built-in FFT
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_SINGLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3f
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  # disable altivec, it has build issues
> @@ -41,10 +42,12 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_DOUBLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3l
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  LIQUID_DSP_CONF_OPTS += \
> -- 
> 2.19.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Dec. 12, 2018, 9:25 a.m. UTC | #2
Hello,

On Wed, 12 Dec 2018 10:21:14 +0100, Gwenhael Goavec-Merou wrote:

> This issue is also fixed by http://patchwork.ozlabs.org/patch/1011657/

Yes, but I think we want to apply my patch first, because it is the
minimal fix that doesn't depend on the FFTW rework. My patch can then
be easily backported to the stable branches, because it doesn't depend
on the heavier FFTW rework.

And then on top of that, we can of course apply your FFTW rework.

Best regards,

Thomas
Gwenhael Goavec-Merou Dec. 12, 2018, 9:34 a.m. UTC | #3
On Wed, 12 Dec 2018 10:25:22 +0100
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> Hello,
> 
> On Wed, 12 Dec 2018 10:21:14 +0100, Gwenhael Goavec-Merou wrote:
> 
> > This issue is also fixed by http://patchwork.ozlabs.org/patch/1011657/  
> 
> Yes, but I think we want to apply my patch first, because it is the
> minimal fix that doesn't depend on the FFTW rework. My patch can then
> be easily backported to the stable branches, because it doesn't depend
> on the heavier FFTW rework.
>
Yes, it's true. And finally  with the rework of FFTW and the fact that fftw
depends on fftw-xx the only thing that is needed is to change the name of the
variables
> 
> And then on top of that, we can of course apply your FFTW rework.
> 
Regards,

Gwen
Gwenhael Goavec-Merou Dec. 12, 2018, 11:37 a.m. UTC | #4
On Wed, 12 Dec 2018 10:04:58 +0100
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> When one of BR2_PACKAGE_FFTW_PRECISION_* is enabled, liquid-dsp links
> against fftw3f, fftw3 or fftw3l, but forgets to add the fftw package
> in its dependencies. It works fine in practice because "fftw" is
> before "liquid-dsp" in the alphabetic ordering, but building with
> "make liquid-dsp" or with per-package directory causes a build
> failure.
> 
> Fix that by adding the missing dependencies.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Tested-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Reviewed-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/liquid-dsp/liquid-dsp.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/liquid-dsp/liquid-dsp.mk
> b/package/liquid-dsp/liquid-dsp.mk index e3114a2d15..db67893844 100644
> --- a/package/liquid-dsp/liquid-dsp.mk
> +++ b/package/liquid-dsp/liquid-dsp.mk
> @@ -32,6 +32,7 @@ endif
>  # use FFTW instead of built-in FFT
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_SINGLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3f
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  # disable altivec, it has build issues
> @@ -41,10 +42,12 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_DOUBLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  ifeq ($(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),y)
>  LIQUID_DSP_LDFLAGS += -lfftw3l
> +LIQUID_DSP_DEPENDENCIES += fftw
>  endif
>  
>  LIQUID_DSP_CONF_OPTS += \
> -- 
> 2.19.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni Dec. 13, 2018, 8:18 p.m. UTC | #5
Hello,

On Wed, 12 Dec 2018 10:04:58 +0100, Thomas Petazzoni wrote:
> When one of BR2_PACKAGE_FFTW_PRECISION_* is enabled, liquid-dsp links
> against fftw3f, fftw3 or fftw3l, but forgets to add the fftw package
> in its dependencies. It works fine in practice because "fftw" is
> before "liquid-dsp" in the alphabetic ordering, but building with
> "make liquid-dsp" or with per-package directory causes a build
> failure.
> 
> Fix that by adding the missing dependencies.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/liquid-dsp/liquid-dsp.mk | 3 +++
>  1 file changed, 3 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Dec. 16, 2018, 9:18 p.m. UTC | #6
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > When one of BR2_PACKAGE_FFTW_PRECISION_* is enabled, liquid-dsp links
 > against fftw3f, fftw3 or fftw3l, but forgets to add the fftw package
 > in its dependencies. It works fine in practice because "fftw" is
 > before "liquid-dsp" in the alphabetic ordering, but building with
 > "make liquid-dsp" or with per-package directory causes a build
 > failure.

 > Fix that by adding the missing dependencies.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2018.02.x, 2018.08.x and 2018.11.x, thanks.
diff mbox series

Patch

diff --git a/package/liquid-dsp/liquid-dsp.mk b/package/liquid-dsp/liquid-dsp.mk
index e3114a2d15..db67893844 100644
--- a/package/liquid-dsp/liquid-dsp.mk
+++ b/package/liquid-dsp/liquid-dsp.mk
@@ -32,6 +32,7 @@  endif
 # use FFTW instead of built-in FFT
 ifeq ($(BR2_PACKAGE_FFTW_PRECISION_SINGLE),y)
 LIQUID_DSP_LDFLAGS += -lfftw3f
+LIQUID_DSP_DEPENDENCIES += fftw
 endif
 
 # disable altivec, it has build issues
@@ -41,10 +42,12 @@  endif
 
 ifeq ($(BR2_PACKAGE_FFTW_PRECISION_DOUBLE),y)
 LIQUID_DSP_LDFLAGS += -lfftw3
+LIQUID_DSP_DEPENDENCIES += fftw
 endif
 
 ifeq ($(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),y)
 LIQUID_DSP_LDFLAGS += -lfftw3l
+LIQUID_DSP_DEPENDENCIES += fftw
 endif
 
 LIQUID_DSP_CONF_OPTS += \