diff mbox series

[v2,1/2] at: change upstream site, bump version

Message ID 20180918213949.36376-2-giulio.benetti@micronovasrl.com
State Superseded, archived
Headers show
Series at: bump version | expand

Commit Message

Giulio Benetti Sept. 18, 2018, 9:39 p.m. UTC
At is now available on a git repository at:
https://salsa.debian.org/debian/at
Main changes 3.1.16 -> 3.1.23:
- add support for SELinux, multiple files
- improve atd.service, see bug report 892819
- fix various bugs and warnings
- finalized script to release software

So:
- change AT_SITE_METHOD to git pointing to release/3.1.23
- update tarball sha256 in hash file
- improved S99at script:
  if /var/spool is linked to /tmp, .SEQ file will be lost and atd won't
  work neither for a live session. Create .SEQ file if not found, warning
  during start that after reboot atjobs could be lost.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/at/S99at   |  9 +++++++++
 package/at/at.hash |  4 ++--
 package/at/at.mk   | 10 ++++++----
 3 files changed, 17 insertions(+), 6 deletions(-)

Comments

Giulio Benetti Sept. 18, 2018, 9:43 p.m. UTC | #1
Forgot to mention V1->V2 Changes:
- removed patch for parallel build since it doesn't work in every case
- improved s99at script to have atd working in live session warning
   about that after reboot atjobs will be lost.

Sorry.
Kind regards
Baruch Siach Sept. 20, 2018, 4:38 a.m. UTC | #2
Hi Giulio,

On Tue, Sep 18, 2018 at 11:39:48PM +0200, Giulio Benetti wrote:
> At is now available on a git repository at:
> https://salsa.debian.org/debian/at
> Main changes 3.1.16 -> 3.1.23:
> - add support for SELinux, multiple files
> - improve atd.service, see bug report 892819
> - fix various bugs and warnings
> - finalized script to release software
> 
> So:
> - change AT_SITE_METHOD to git pointing to release/3.1.23
> - update tarball sha256 in hash file
> - improved S99at script:
>   if /var/spool is linked to /tmp, .SEQ file will be lost and atd won't
>   work neither for a live session. Create .SEQ file if not found, warning
>   during start that after reboot atjobs could be lost.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> ---
>  package/at/S99at   |  9 +++++++++
>  package/at/at.hash |  4 ++--
>  package/at/at.mk   | 10 ++++++----
>  3 files changed, 17 insertions(+), 6 deletions(-)
> 
> diff --git a/package/at/S99at b/package/at/S99at
> index 666d39b546..fb81736ae2 100755
> --- a/package/at/S99at
> +++ b/package/at/S99at
> @@ -6,6 +6,15 @@
>  umask 077
>  
>  start() {
> +	# Since /va/spool can be linked to /tmp (tmpfs) 

va -> var

> +	# /var/spool/cron/atjobs/.SEQ created could be not available
> +	# Check if not exists otherwise create it
> +	if [ ! -f /var/spool/cron/atjobs/.SEQ ]; then
> +	    mkdir -p /var/spool/cron/atjobs/
> +	    touch /var/spool/cron/atjobs/.SEQ
> +	    printf "atd: Created missing .SEQ file. Probably it's in tmpfs and on reboot atjobs will be lost!\n"
> +	fi
> +
>  	printf "Starting atd: "
>  	start-stop-daemon --start --quiet --make-pidfile --pidfile /var/run/atd.pid --background --exec /usr/sbin/atd -- -f
>  	echo "OK"
> diff --git a/package/at/at.hash b/package/at/at.hash
> index 22c732cc7e..e6eb26d818 100644
> --- a/package/at/at.hash
> +++ b/package/at/at.hash
> @@ -1,2 +1,2 @@
> -# From: http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at/at_3.1.16-1.dsc
> -sha256 cb9af59c6a54edce9536ba629841055409d1f89d8ae26494727a97141fb4d5c1  at_3.1.16.orig.tar.gz
> +# Locally calculated
> +sha256 f5c7c8226fab0bc4e2d16a55e04d4026f3452db51fc5cbcc4bb5a3c79a79f7ef  at-release_3.1.23.tar.gz
> diff --git a/package/at/at.mk b/package/at/at.mk
> index 058ebac5c8..083fbbc74b 100644
> --- a/package/at/at.mk
> +++ b/package/at/at.mk
> @@ -4,10 +4,11 @@
>  #
>  ################################################################################
>  
> -AT_VERSION = 3.1.16
> -AT_SOURCE = at_$(AT_VERSION).orig.tar.gz
> -AT_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at
> -# missing deps for parsetime.l
> +AT_VERSION = release/3.1.23
> +AT_SITE = https://salsa.debian.org/debian/at.git
> +AT_SITE_METHOD = git
> +# Tried to add missing deps for parsetime.l but still parallel build fails
> +# in some case, so at the moment let's keep MAKE1
>  AT_MAKE = $(MAKE1)
>  AT_AUTORECONF = YES
>  AT_DEPENDENCIES = $(if $(BR2_PACKAGE_FLEX),flex) host-bison host-flex
> @@ -23,6 +24,7 @@ AT_CONF_OPTS = \
>  
>  define AT_INSTALL_INIT_SYSV
>  	$(INSTALL) -m 0755 -D package/at/S99at $(TARGET_DIR)/etc/init.d/S99at
> +	

Redundant newline.

>  endef
>  
>  $(eval $(autotools-package))

baruch
Matt Weber Sept. 20, 2018, 12:43 p.m. UTC | #3
Giulio,


On Tue, Sep 18, 2018 at 4:40 PM Giulio Benetti
<giulio.benetti@micronovasrl.com> wrote:
>
> At is now available on a git repository at:
> https://salsa.debian.org/debian/at
> Main changes 3.1.16 -> 3.1.23:
> - add support for SELinux, multiple files
> - improve atd.service, see bug report 892819
> - fix various bugs and warnings
> - finalized script to release software

Please update the Config.in to list a valid url for this package.

Maybe https://salsa.debian.org/debian/at  or https://tracker.debian.org/pkg/at ?

Matt
Giulio Benetti Sept. 20, 2018, 4:43 p.m. UTC | #4
Hi Baruch,

Il 20/09/2018 06:38, Baruch Siach ha scritto:
> Hi Giulio,
> 
> On Tue, Sep 18, 2018 at 11:39:48PM +0200, Giulio Benetti wrote:
>> At is now available on a git repository at:
>> https://salsa.debian.org/debian/at
>> Main changes 3.1.16 -> 3.1.23:
>> - add support for SELinux, multiple files
>> - improve atd.service, see bug report 892819
>> - fix various bugs and warnings
>> - finalized script to release software
>>
>> So:
>> - change AT_SITE_METHOD to git pointing to release/3.1.23
>> - update tarball sha256 in hash file
>> - improved S99at script:
>>    if /var/spool is linked to /tmp, .SEQ file will be lost and atd won't
>>    work neither for a live session. Create .SEQ file if not found, warning
>>    during start that after reboot atjobs could be lost.
>>
>> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
>> ---
>>   package/at/S99at   |  9 +++++++++
>>   package/at/at.hash |  4 ++--
>>   package/at/at.mk   | 10 ++++++----
>>   3 files changed, 17 insertions(+), 6 deletions(-)
>>
>> diff --git a/package/at/S99at b/package/at/S99at
>> index 666d39b546..fb81736ae2 100755
>> --- a/package/at/S99at
>> +++ b/package/at/S99at
>> @@ -6,6 +6,15 @@
>>   umask 077
>>   
>>   start() {
>> +	# Since /va/spool can be linked to /tmp (tmpfs)
> 
> va -> var

Oops, yes.

> 
>> +	# /var/spool/cron/atjobs/.SEQ created could be not available
>> +	# Check if not exists otherwise create it
>> +	if [ ! -f /var/spool/cron/atjobs/.SEQ ]; then
>> +	    mkdir -p /var/spool/cron/atjobs/
>> +	    touch /var/spool/cron/atjobs/.SEQ
>> +	    printf "atd: Created missing .SEQ file. Probably it's in tmpfs and on reboot atjobs will be lost!\n"
>> +	fi
>> +
>>   	printf "Starting atd: "
>>   	start-stop-daemon --start --quiet --make-pidfile --pidfile /var/run/atd.pid --background --exec /usr/sbin/atd -- -f
>>   	echo "OK"
>> diff --git a/package/at/at.hash b/package/at/at.hash
>> index 22c732cc7e..e6eb26d818 100644
>> --- a/package/at/at.hash
>> +++ b/package/at/at.hash
>> @@ -1,2 +1,2 @@
>> -# From: http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at/at_3.1.16-1.dsc
>> -sha256 cb9af59c6a54edce9536ba629841055409d1f89d8ae26494727a97141fb4d5c1  at_3.1.16.orig.tar.gz
>> +# Locally calculated
>> +sha256 f5c7c8226fab0bc4e2d16a55e04d4026f3452db51fc5cbcc4bb5a3c79a79f7ef  at-release_3.1.23.tar.gz
>> diff --git a/package/at/at.mk b/package/at/at.mk
>> index 058ebac5c8..083fbbc74b 100644
>> --- a/package/at/at.mk
>> +++ b/package/at/at.mk
>> @@ -4,10 +4,11 @@
>>   #
>>   ################################################################################
>>   
>> -AT_VERSION = 3.1.16
>> -AT_SOURCE = at_$(AT_VERSION).orig.tar.gz
>> -AT_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at
>> -# missing deps for parsetime.l
>> +AT_VERSION = release/3.1.23
>> +AT_SITE = https://salsa.debian.org/debian/at.git
>> +AT_SITE_METHOD = git
>> +# Tried to add missing deps for parsetime.l but still parallel build fails
>> +# in some case, so at the moment let's keep MAKE1
>>   AT_MAKE = $(MAKE1)
>>   AT_AUTORECONF = YES
>>   AT_DEPENDENCIES = $(if $(BR2_PACKAGE_FLEX),flex) host-bison host-flex
>> @@ -23,6 +24,7 @@ AT_CONF_OPTS = \
>>   
>>   define AT_INSTALL_INIT_SYSV
>>   	$(INSTALL) -m 0755 -D package/at/S99at $(TARGET_DIR)/etc/init.d/S99at
>> +	
> 
> Redundant newline.

Yep

Thank you!
Best regards
Giulio Benetti Sept. 20, 2018, 4:47 p.m. UTC | #5
Il 20/09/2018 14:43, Matthew Weber ha scritto:
> Giulio,
> 
> 
> On Tue, Sep 18, 2018 at 4:40 PM Giulio Benetti
> <giulio.benetti@micronovasrl.com> wrote:
>>
>> At is now available on a git repository at:
>> https://salsa.debian.org/debian/at
>> Main changes 3.1.16 -> 3.1.23:
>> - add support for SELinux, multiple files
>> - improve atd.service, see bug report 892819
>> - fix various bugs and warnings
>> - finalized script to release software
> 
> Please update the Config.in to list a valid url for this package.
> 
> Maybe https://salsa.debian.org/debian/at  or https://tracker.debian.org/pkg/at ?

I correct it.

Thank you.
Best regards
diff mbox series

Patch

diff --git a/package/at/S99at b/package/at/S99at
index 666d39b546..fb81736ae2 100755
--- a/package/at/S99at
+++ b/package/at/S99at
@@ -6,6 +6,15 @@ 
 umask 077
 
 start() {
+	# Since /va/spool can be linked to /tmp (tmpfs) 
+	# /var/spool/cron/atjobs/.SEQ created could be not available
+	# Check if not exists otherwise create it
+	if [ ! -f /var/spool/cron/atjobs/.SEQ ]; then
+	    mkdir -p /var/spool/cron/atjobs/
+	    touch /var/spool/cron/atjobs/.SEQ
+	    printf "atd: Created missing .SEQ file. Probably it's in tmpfs and on reboot atjobs will be lost!\n"
+	fi
+
 	printf "Starting atd: "
 	start-stop-daemon --start --quiet --make-pidfile --pidfile /var/run/atd.pid --background --exec /usr/sbin/atd -- -f
 	echo "OK"
diff --git a/package/at/at.hash b/package/at/at.hash
index 22c732cc7e..e6eb26d818 100644
--- a/package/at/at.hash
+++ b/package/at/at.hash
@@ -1,2 +1,2 @@ 
-# From: http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at/at_3.1.16-1.dsc
-sha256 cb9af59c6a54edce9536ba629841055409d1f89d8ae26494727a97141fb4d5c1  at_3.1.16.orig.tar.gz
+# Locally calculated
+sha256 f5c7c8226fab0bc4e2d16a55e04d4026f3452db51fc5cbcc4bb5a3c79a79f7ef  at-release_3.1.23.tar.gz
diff --git a/package/at/at.mk b/package/at/at.mk
index 058ebac5c8..083fbbc74b 100644
--- a/package/at/at.mk
+++ b/package/at/at.mk
@@ -4,10 +4,11 @@ 
 #
 ################################################################################
 
-AT_VERSION = 3.1.16
-AT_SOURCE = at_$(AT_VERSION).orig.tar.gz
-AT_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/a/at
-# missing deps for parsetime.l
+AT_VERSION = release/3.1.23
+AT_SITE = https://salsa.debian.org/debian/at.git
+AT_SITE_METHOD = git
+# Tried to add missing deps for parsetime.l but still parallel build fails
+# in some case, so at the moment let's keep MAKE1
 AT_MAKE = $(MAKE1)
 AT_AUTORECONF = YES
 AT_DEPENDENCIES = $(if $(BR2_PACKAGE_FLEX),flex) host-bison host-flex
@@ -23,6 +24,7 @@  AT_CONF_OPTS = \
 
 define AT_INSTALL_INIT_SYSV
 	$(INSTALL) -m 0755 -D package/at/S99at $(TARGET_DIR)/etc/init.d/S99at
+	
 endef
 
 $(eval $(autotools-package))