diff mbox series

[v1,3/4] qt5virtualkeyboard: fix legal-info with 5.6

Message ID 20180903123747.5234-4-gael.portay@savoirfairelinux.com
State Accepted
Headers show
Series qt5virtualkeyboard: fix build issues with 5.6 | expand

Commit Message

Gaël PORTAY Sept. 3, 2018, 12:37 p.m. UTC
qt5virtualkeyboard 2.0 (shipped with Qt 5.6) doesn't contain any license
files.

Conditionally remove LICENSE.GPL3 from QT5VIRTUALKEYBOARD_LICENSE_FILES
when Qt major version is set to 5.6.

Fixes:

	>>> qt5virtualkeyboard 2.0 Collecting legal info
	sha256sum: /home/gportay/src/buildroot/output/build/qt5virtualkeyboard-2.0/LICENSE.GPL3: No such file or directory
	ERROR: LICENSE.GPL3 has wrong sha256 hash:
	ERROR: expected: 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903
	ERROR: got     :
	ERROR: Incomplete download, or man-in-the-middle (MITM) attack

Also, the lipi-toolkit has a different filename between both supported
Qt major version (5.6 and latest).

Conditionally set the license in QT5VIRTUALKEYBOARD_LICENSE_FILES for
lipi-toolkit according to the Qt major version used.

Fixes:
	>>> qt5virtualkeyboard 2.0 Collecting legal info
	ERROR: No hash found for src/virtualkeyboard/3rdparty/openwnn/NOTICE
	ERROR: No hash found for src/virtualkeyboard/3rdparty/pinyin/NOTICE
	ERROR: No hash found for src/virtualkeyboard/3rdparty/tcime/COPYING
	sha256sum: /home/gportay/src/buildroot/output/build/qt5virtualkeyboard-2.0/src/virtualkeyboard/3rdparty/lipi-toolkit/MIT_LICENSE.txt: No such file or directory
	ERROR: src/virtualkeyboard/3rdparty/lipi-toolkit/MIT_LICENSE.txt has wrong sha256 hash:
	ERROR: expected: 7a45a9769d19545480a241230e6ea520b5156fac00930dcd69b6886749743d10
	ERROR: got     :
	ERROR: Incomplete download, or man-in-the-middle (MITM) attack

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
---
 package/qt5/qt5virtualkeyboard/qt5virtualkeyboard.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni Sept. 5, 2018, 9:11 p.m. UTC | #1
Hello Gaël,

On Mon,  3 Sep 2018 08:37:46 -0400, Gaël PORTAY wrote:
> qt5virtualkeyboard 2.0 (shipped with Qt 5.6) doesn't contain any license
> files.

"any license files" is not true, because there's the lipi-toolkit
license file. However, there is no "main" license file with the GPLv3
text. I've fixed that up.

> Conditionally remove LICENSE.GPL3 from QT5VIRTUALKEYBOARD_LICENSE_FILES
> when Qt major version is set to 5.6.

Do we have any indication that the license is GPLv3 for the 2.0 version
of qt5virtualkeyboard ?

> Also, the lipi-toolkit has a different filename between both supported
> Qt major version (5.6 and latest).
> 
> Conditionally set the license in QT5VIRTUALKEYBOARD_LICENSE_FILES for
> lipi-toolkit according to the Qt major version used.

You forgot to add the hash for this license file.

I've fixed the commit log and added the hash for the 2.0 version of the
lipi-toolkit license file, and applied to master.

It would be nice to get some confirmation that the license is really
GPLv3.

Thanks!

Thomas
Gaël PORTAY Sept. 6, 2018, 7:32 a.m. UTC | #2
Thomas,

On Wed, Sep 05, 2018 at 11:11:34PM +0200, Thomas Petazzoni wrote:
> (...)
> 
> > Conditionally remove LICENSE.GPL3 from QT5VIRTUALKEYBOARD_LICENSE_FILES
> > when Qt major version is set to 5.6.
> 
> Do we have any indication that the license is GPLv3 for the 2.0 version
> of qt5virtualkeyboard ?
> 

I found this [1]. I also asked to Qt and I am waiting for their
response.

I guess this Qt5 module is available in Open license since 5.7; thus 2.0
(5.6) is available only under their Commercial license.

> (...)
> 
> Thanks!
> 
> Thomas
> -- 
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com

[1]: http://blog.qt.io/blog/2016/03/02/qt-virtual-keyboard-updated-with-handwriting-recognition/

Regards,
Gaël
Thomas Petazzoni Sept. 6, 2018, 7:36 a.m. UTC | #3
Hello,

On Thu, 6 Sep 2018 03:32:21 -0400, Gaël PORTAY wrote:

> I found this [1]. I also asked to Qt and I am waiting for their
> response.
> 
> I guess this Qt5 module is available in Open license since 5.7;

What do you call the "Open license" ?

> thus 2.0 (5.6) is available only under their Commercial license.

So the source code would be freely available, but can't be used without
having their Commercial license ?

Thomas
Gaël PORTAY Sept. 6, 2018, 7:43 a.m. UTC | #4
Thomas,

On Thu, Sep 06, 2018 at 09:36:31AM +0200, Thomas Petazzoni wrote:
> Hello,
> 
> On Thu, 6 Sep 2018 03:32:21 -0400, Gaël PORTAY wrote:
> 
> > I found this [1]. I also asked to Qt and I am waiting for their
> > response.
> > 
> > I guess this Qt5 module is available in Open license since 5.7;
> 
> What do you call the "Open license" ?
> 

I wanted to say that Qt VirtualKeyboard is available under GPLv3 since
5.7.

So I guess the version 2.0 is available only under the Qt Commercial
license.

> > thus 2.0 (5.6) is available only under their Commercial license.
> 
> So the source code would be freely available, but can't be used without
> having their Commercial license ?
> 

I do not know yet. I asked and I will tell you once I get a response
from them.

Gaël
diff mbox series

Patch

diff --git a/package/qt5/qt5virtualkeyboard/qt5virtualkeyboard.mk b/package/qt5/qt5virtualkeyboard/qt5virtualkeyboard.mk
index a4c9492a91..ce2dea7a3b 100644
--- a/package/qt5/qt5virtualkeyboard/qt5virtualkeyboard.mk
+++ b/package/qt5/qt5virtualkeyboard/qt5virtualkeyboard.mk
@@ -16,7 +16,9 @@  QT5VIRTUALKEYBOARD_DEPENDENCIES = qt5base qt5declarative qt5svg
 QT5VIRTUALKEYBOARD_INSTALL_STAGING = YES
 
 QT5VIRTUALKEYBOARD_LICENSE = GPL-3.0
+ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
 QT5VIRTUALKEYBOARD_LICENSE_FILES = LICENSE.GPL3
+endif
 
 QT5VIRTUALKEYBOARD_LANGUAGE_LAYOUTS = $(call qstrip,$(BR2_PACKAGE_QT5VIRTUALKEYBOARD_LANGUAGE_LAYOUTS))
 ifneq ($(strip $(QT5VIRTUALKEYBOARD_LANGUAGE_LAYOUTS)),)
@@ -44,8 +46,12 @@  ifeq ($(BR2_PACKAGE_QT5VIRTUALKEYBOARD_HANDWRITING),y)
 QT5VIRTUALKEYBOARD_3RDPARTY_PARTS = YES
 QT5VIRTUALKEYBOARD_QMAKEFLAGS += CONFIG+=handwriting
 QT5VIRTUALKEYBOARD_LICENSE := $(QT5VIRTUALKEYBOARD_LICENSE), MIT (lipi-toolkit)
+ifeq ($(BR2_PACKAGE_QT5_VERSION_5_6),y)
+QT5VIRTUALKEYBOARD_LICENSE_FILES += src/virtualkeyboard/3rdparty/lipi-toolkit/license.txt
+else
 QT5VIRTUALKEYBOARD_LICENSE_FILES += src/virtualkeyboard/3rdparty/lipi-toolkit/MIT_LICENSE.txt
 endif
+endif
 
 ifdef QT5VIRTUALKEYBOARD_3RDPARTY_PARTS
 define QT5VIRTUALKEYBOARD_INSTALL_TARGET_3RDPARTY_PARTS