diff mbox series

[7/9] qt5serialbus: install examples to target

Message ID 20180612123206.31523-8-gael.portay@savoirfairelinux.com
State Accepted
Headers show
Series qt5: install missing examples | expand

Commit Message

Gaël PORTAY June 12, 2018, 12:32 p.m. UTC
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `serialbus' from the staging directory
to the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
---
 package/qt5/qt5serialbus/qt5serialbus.mk | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/package/qt5/qt5serialbus/qt5serialbus.mk b/package/qt5/qt5serialbus/qt5serialbus.mk
index c9a2139556..6de9f9b7d3 100644
--- a/package/qt5/qt5serialbus/qt5serialbus.mk
+++ b/package/qt5/qt5serialbus/qt5serialbus.mk
@@ -36,8 +36,15 @@  define QT5SERIALBUS_INSTALL_TARGET_LIBS
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5SERIALBUS_INSTALL_TARGET_EXAMPLES
+	cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/serialbus $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
 define QT5SERIALBUS_INSTALL_TARGET_CMDS
 	$(QT5SERIALBUS_INSTALL_TARGET_LIBS)
+	$(QT5SERIALBUS_INSTALL_TARGET_EXAMPLES)
 	$(INSTALL) -m 0755 -D $(@D)/bin/canbusutil \
 		$(TARGET_DIR)/usr/bin/canbusutil
 endef