diff mbox series

[4/9] qt5script: install examples to target

Message ID 20180612123206.31523-5-gael.portay@savoirfairelinux.com
State Accepted
Headers show
Series qt5: install missing examples | expand

Commit Message

Gaël PORTAY June 12, 2018, 12:32 p.m. UTC
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `script' from the staging directory to
the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
---
 package/qt5/qt5script/qt5script.mk | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/qt5/qt5script/qt5script.mk b/package/qt5/qt5script/qt5script.mk
index fe0ad9e888..4a292c95a5 100644
--- a/package/qt5/qt5script/qt5script.mk
+++ b/package/qt5/qt5script/qt5script.mk
@@ -41,9 +41,20 @@  define QT5SCRIPT_INSTALL_STAGING_CMDS
 endef
 
 ifeq ($(BR2_STATIC_LIBS),)
-define QT5SCRIPT_INSTALL_TARGET_CMDS
+define QT5SCRIPT_INSTALL_TARGET_LIBS
 	cp -dpf $(STAGING_DIR)/usr/lib/libQt5Script*.so.* $(TARGET_DIR)/usr/lib
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5SCRIPT_INSTALL_TARGET_EXAMPLES
+	cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/script $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
+define QT5SCRIPT_INSTALL_TARGET_CMDS
+	$(QT5SCRIPT_INSTALL_TARGET_LIBS)
+	$(QT5SCRIPT_INSTALL_TARGET_EXAMPLES)
+endef
+
 $(eval $(generic-package))