diff mbox series

[v2] libusb: add an option to compile examples

Message ID 20180610220849.15558-1-gael.portay@savoirfairelinux.com
State Superseded
Headers show
Series [v2] libusb: add an option to compile examples | expand

Commit Message

Gaël PORTAY June 10, 2018, 10:08 p.m. UTC
Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
---
 package/libusb/Config.in |  7 +++++++
 package/libusb/libusb.mk | 10 ++++++++++
 2 files changed, 17 insertions(+)

Comments

Gaël PORTAY June 11, 2018, 2:48 a.m. UTC | #1
With the missing changelog...

On Sun, Jun 10, 2018 at 06:08:49PM -0400, Gaël PORTAY wrote:
> Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
> ---
>  package/libusb/Config.in |  7 +++++++
>  package/libusb/libusb.mk | 10 ++++++++++
>  2 files changed, 17 insertions(+)
> 
> diff --git a/package/libusb/Config.in b/package/libusb/Config.in
> index 5238588aa8..d31a717fdf 100644
> --- a/package/libusb/Config.in
> +++ b/package/libusb/Config.in
> @@ -6,5 +6,12 @@ config BR2_PACKAGE_LIBUSB
>  
>  	  http://libusb.info/
>  
> +if BR2_PACKAGE_LIBUSB
> +
> +config BR2_PACKAGE_LIBUSB_EXAMPLES
> +	bool "build libusb examples"
> +
> +endif
> +
>  comment "libusb needs a toolchain w/ threads"
>  	depends on !BR2_TOOLCHAIN_HAS_THREADS
> diff --git a/package/libusb/libusb.mk b/package/libusb/libusb.mk
> index aee3622f8d..2cad3dec7f 100644
> --- a/package/libusb/libusb.mk
> +++ b/package/libusb/libusb.mk
> @@ -25,5 +25,15 @@ else
>  LIBUSB_CONF_OPTS += --disable-udev
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBUSB_EXAMPLES),y)
> +LIBUSB_CONF_OPTS += --enable-examples-build
> +define LIBUSB_INSTALL_TARGET_EXAMPLES
> +	for example in listdevs xusb fxload hotplugtest testlibusb dpfp dpfp_threaded sam3u_benchmark oopps ; do \
> +		cp -dpfr $(@D)/examples/$${example} $(TARGET_DIR)/usr/bin; \
> +	done
> +endef
> +LIBUSB_POST_INSTALL_TARGET_HOOKS += LIBUSB_INSTALL_TARGET_EXAMPLES
> +endif
> +
>  $(eval $(autotools-package))
>  $(eval $(host-autotools-package))
> -- 
> 2.11.0
> 

Changes since v1:
 - remove presence check.

Regards,
Gael
Gaël PORTAY June 11, 2018, 3:48 a.m. UTC | #2
Oops, there is a typo in example list...

On Sun, Jun 10, 2018 at 06:08:49PM -0400, Gaël PORTAY wrote:
> +	for example in listdevs xusb fxload hotplugtest testlibusb dpfp dpfp_threaded sam3u_benchmark oopps ; do \
                                                                                                      ^---

I will send a v3.
diff mbox series

Patch

diff --git a/package/libusb/Config.in b/package/libusb/Config.in
index 5238588aa8..d31a717fdf 100644
--- a/package/libusb/Config.in
+++ b/package/libusb/Config.in
@@ -6,5 +6,12 @@  config BR2_PACKAGE_LIBUSB
 
 	  http://libusb.info/
 
+if BR2_PACKAGE_LIBUSB
+
+config BR2_PACKAGE_LIBUSB_EXAMPLES
+	bool "build libusb examples"
+
+endif
+
 comment "libusb needs a toolchain w/ threads"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libusb/libusb.mk b/package/libusb/libusb.mk
index aee3622f8d..2cad3dec7f 100644
--- a/package/libusb/libusb.mk
+++ b/package/libusb/libusb.mk
@@ -25,5 +25,15 @@  else
 LIBUSB_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUSB_EXAMPLES),y)
+LIBUSB_CONF_OPTS += --enable-examples-build
+define LIBUSB_INSTALL_TARGET_EXAMPLES
+	for example in listdevs xusb fxload hotplugtest testlibusb dpfp dpfp_threaded sam3u_benchmark oopps ; do \
+		cp -dpfr $(@D)/examples/$${example} $(TARGET_DIR)/usr/bin; \
+	done
+endef
+LIBUSB_POST_INSTALL_TARGET_HOOKS += LIBUSB_INSTALL_TARGET_EXAMPLES
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))