diff mbox series

[v2] python-remi: new package

Message ID 20180202214205.14781-1-gwenj@trabucayre.com
State Accepted
Commit 31f1e97eae6b9f7f6c22447768113318aa7b85fc
Headers show
Series [v2] python-remi: new package | expand

Commit Message

Gwenhael Goavec-Merou Feb. 2, 2018, 9:42 p.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

Remi is a GUI library for Python applications which transpiles an
application's interface into HTML to be rendered in a web browser.
This removes platform-specific dependencies and lets you easily
develop cross-platform applications in Python!

https://github.com/dddomodossola/remi/tree/master

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
---
Changes v1 -> v2
 * add licence file checksum (Yegor Yefremov)
---
 DEVELOPERS                           |  1 +
 package/Config.in                    |  1 +
 package/python-remi/Config.in        |  9 +++++++++
 package/python-remi/python-remi.hash |  3 +++
 package/python-remi/python-remi.mk   | 14 ++++++++++++++
 5 files changed, 28 insertions(+)
 create mode 100644 package/python-remi/Config.in
 create mode 100644 package/python-remi/python-remi.hash
 create mode 100644 package/python-remi/python-remi.mk

Comments

Peter Korsgaard Feb. 4, 2018, 9:50 a.m. UTC | #1
>>>>> "Gwenhael" == Gwenhael Goavec-Merou <gwenj@trabucayre.com> writes:

 > From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
 > Remi is a GUI library for Python applications which transpiles an
 > application's interface into HTML to be rendered in a web browser.
 > This removes platform-specific dependencies and lets you easily
 > develop cross-platform applications in Python!

 > https://github.com/dddomodossola/remi/tree/master

 > Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
 > Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
 > ---
 > Changes v1 -> v2
 >  * add licence file checksum (Yegor Yefremov)

Committed, thanks.
Gwenhael Goavec-Merou Feb. 4, 2018, 9:57 a.m. UTC | #2
thank you.
Gwen

On Sun, 04 Feb 2018 10:50:21 +0100
Peter Korsgaard <peter@korsgaard.com> wrote:

> >>>>> "Gwenhael" == Gwenhael Goavec-Merou <gwenj@trabucayre.com>
> >>>>> writes:  
> 
>  > From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
>  > Remi is a GUI library for Python applications which transpiles an
>  > application's interface into HTML to be rendered in a web browser.
>  > This removes platform-specific dependencies and lets you easily
>  > develop cross-platform applications in Python!  
> 
>  > https://github.com/dddomodossola/remi/tree/master  
> 
>  > Signed-off-by: Gwenhael Goavec-Merou
>  > <gwenhael.goavec-merou@trabucayre.com> Reviewed-by: Yegor Yefremov
>  > <yegorslists@googlemail.com> ---
>  > Changes v1 -> v2
>  >  * add licence file checksum (Yegor Yefremov)  
> 
> Committed, thanks.
> 
> -- 
> Bye, Peter Korsgaard
Yann E. MORIN Feb. 4, 2018, 4:17 p.m. UTC | #3
Gwenhael, All,

On 2018-02-02 22:42 +0100, Gwenhael Goavec-Merou spake thusly:
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> Remi is a GUI library for Python applications which transpiles an
> application's interface into HTML to be rendered in a web browser.
> This removes platform-specific dependencies and lets you easily
> develop cross-platform applications in Python!
[--SNIP--]
> diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
> new file mode 100644
> index 0000000000..6514118192
> --- /dev/null
> +++ b/package/python-remi/python-remi.mk
> @@ -0,0 +1,14 @@
> +################################################################################
> +# 

Trailing whitespace...

> +# python-remi
> +#
> +################################################################################
> +
> +PYTHON_REMI_VERSION = v1.0
> +PYTHON_REMI_SITE = $(call github,dddomodossola,remi,$(PYTHON_REMI_VERSION))
> +PYTHON_REMI_LICENSE = Apache-2.0
> +PYTHON_REMI_LICENSE_FILES = LICENSE
> +PYTHON_REMI_SETUP_TYPE = setuptools
> +
> +$(eval $(python-package))
> +

Trailng empty line.

Those two are causing check-package failures;
    https://gitlab.com/buildroot.org/buildroot/-/jobs/50971692

You can check locally with:
    ./utils/check-package package/python-remi/*

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 9048d45b16..1083782422 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -753,6 +753,7 @@  F:	package/libusbgx/
 F:	package/python-cheetah/
 F:	package/python-markdown/
 F:	package/python-pyqt/
+F:	package/python-remi/
 F:	package/python-sip/
 
 N:	Henrique Camargo <henrique@henriquecamargo.com>
diff --git a/package/Config.in b/package/Config.in
index 9a6b199f40..3ce86fcadf 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -888,6 +888,7 @@  menu "External python modules"
 	source "package/python-pyyaml/Config.in"
 	source "package/python-pyzmq/Config.in"
 	source "package/python-raven/Config.in"
+	source "package/python-remi/Config.in"
 	source "package/python-requests/Config.in"
 	source "package/python-requests-oauthlib/Config.in"
 	source "package/python-requests-toolbelt/Config.in"
diff --git a/package/python-remi/Config.in b/package/python-remi/Config.in
new file mode 100644
index 0000000000..68d0a92b11
--- /dev/null
+++ b/package/python-remi/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_PYTHON_REMI
+	bool "python-remi"
+	help
+	  Remi is a GUI library for Python applications which transpiles an
+	  application's interface into HTML to be rendered in a web browser.
+	  This removes platform-specific dependencies and lets you easily
+	  develop cross-platform applications in Python!
+
+	  https://github.com/dddomodossola/remi/tree/master
diff --git a/package/python-remi/python-remi.hash b/package/python-remi/python-remi.hash
new file mode 100644
index 0000000000..e3df6cbb03
--- /dev/null
+++ b/package/python-remi/python-remi.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256 69ab3f7438de76708bfc40396f791b76452f84bb8bca6dafbdaca510c17e9526  python-remi-v1.0.tar.gz
+sha256 bc198f9846c1da3a1c1b1fa2b12909b021365d1e7fe9b4039245edfcec3b7f7f  LICENSE
diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
new file mode 100644
index 0000000000..6514118192
--- /dev/null
+++ b/package/python-remi/python-remi.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+# 
+# python-remi
+#
+################################################################################
+
+PYTHON_REMI_VERSION = v1.0
+PYTHON_REMI_SITE = $(call github,dddomodossola,remi,$(PYTHON_REMI_VERSION))
+PYTHON_REMI_LICENSE = Apache-2.0
+PYTHON_REMI_LICENSE_FILES = LICENSE
+PYTHON_REMI_SETUP_TYPE = setuptools
+
+$(eval $(python-package))
+