diff mbox series

[07/12] go: bump version to 1.9

Message ID 20171019002257.27646-7-christian@paral.in
State Accepted
Headers show
Series [01/12] dumb-init: new package | expand

Commit Message

Christian Stewart Oct. 19, 2017, 12:22 a.m. UTC
Bumping Go to 1.9 from 1.7.

Go 1.8 comes with significant performance improvements, particularly
around ARM: "CPU time required by our benchmark programs was reduced by
20-30% on 32-bit ARM systems."

Go 1.9 is required for docker-engine and other Go packages in Buildroot.

Signed-off-by: Christian Stewart <christian@paral.in>
---
 package/go/go.hash | 4 ++--
 package/go/go.mk   | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Baruch Siach Oct. 19, 2017, 3:50 a.m. UTC | #1
Hi Christian,

On Wed, Oct 18, 2017 at 08:22:52PM -0400, Christian Stewart wrote:
> Bumping Go to 1.9 from 1.7.

This patch bumps from 1.8.3. Mention of the old version is not necessary, but 
it should be correct.

baruch

> Go 1.8 comes with significant performance improvements, particularly
> around ARM: "CPU time required by our benchmark programs was reduced by
> 20-30% on 32-bit ARM systems."
> 
> Go 1.9 is required for docker-engine and other Go packages in Buildroot.
> 
> Signed-off-by: Christian Stewart <christian@paral.in>
> ---
>  package/go/go.hash | 4 ++--
>  package/go/go.mk   | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/go/go.hash b/package/go/go.hash
> index 1836af2482..445a0b7c20 100644
> --- a/package/go/go.hash
> +++ b/package/go/go.hash
> @@ -1,2 +1,2 @@
> -# Locally computed:
> -sha256	5f5dea2447e7dcfdc50fa6b94c512e58bfba5673c039259fd843f68829d99fa6	go1.8.3.src.tar.gz
> +# From https://golang.org/dl/
> +sha256	a4ab229028ed167ba1986825751463605264e44868362ca8e7accc8be057e993	go1.9.src.tar.gz
> diff --git a/package/go/go.mk b/package/go/go.mk
> index 0781dff035..93e1189c23 100644
> --- a/package/go/go.mk
> +++ b/package/go/go.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -GO_VERSION = 1.8.3
> +GO_VERSION = 1.9
>  GO_SITE = https://storage.googleapis.com/golang
>  GO_SOURCE = go$(GO_VERSION).src.tar.gz
Thomas Petazzoni Oct. 19, 2017, 8:19 a.m. UTC | #2
Hello,

On Wed, 18 Oct 2017 20:22:52 -0400, Christian Stewart wrote:
> Bumping Go to 1.9 from 1.7.
> 
> Go 1.8 comes with significant performance improvements, particularly
> around ARM: "CPU time required by our benchmark programs was reduced by
> 20-30% on 32-bit ARM systems."
> 
> Go 1.9 is required for docker-engine and other Go packages in Buildroot.
> 
> Signed-off-by: Christian Stewart <christian@paral.in>

Since you're bumping go, it would be nice if you could review/test:

  https://patchwork.ozlabs.org/patch/826431/
  https://patchwork.ozlabs.org/patch/826433/
  https://patchwork.ozlabs.org/patch/826432/
  https://patchwork.ozlabs.org/patch/826434/

And specifically the first one.

Thanks!

Thomas
Christian Stewart Oct. 19, 2017, 4:15 p.m. UTC | #3
Hi Thomas,

On Thu, Oct 19, 2017 at 4:19 AM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
>   https://patchwork.ozlabs.org/patch/826431/

> And specifically the first one.

Tested, works fine. Sending my signed-off in a separate email. I would
recommend applying the first patch but not the rest of the series at
this point.

Not a dependency for my series to work properly, though.

Best,
Christian
Thomas Petazzoni Oct. 22, 2017, 10:18 a.m. UTC | #4
Hello,

On Wed, 18 Oct 2017 20:22:52 -0400, Christian Stewart wrote:
> Bumping Go to 1.9 from 1.7.
> 
> Go 1.8 comes with significant performance improvements, particularly
> around ARM: "CPU time required by our benchmark programs was reduced by
> 20-30% on 32-bit ARM systems."
> 
> Go 1.9 is required for docker-engine and other Go packages in Buildroot.
> 
> Signed-off-by: Christian Stewart <christian@paral.in>
> ---
>  package/go/go.hash | 4 ++--
>  package/go/go.mk   | 2 +-
>  2 files changed, 3 insertions(+), 3 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/go/go.hash b/package/go/go.hash
index 1836af2482..445a0b7c20 100644
--- a/package/go/go.hash
+++ b/package/go/go.hash
@@ -1,2 +1,2 @@ 
-# Locally computed:
-sha256	5f5dea2447e7dcfdc50fa6b94c512e58bfba5673c039259fd843f68829d99fa6	go1.8.3.src.tar.gz
+# From https://golang.org/dl/
+sha256	a4ab229028ed167ba1986825751463605264e44868362ca8e7accc8be057e993	go1.9.src.tar.gz
diff --git a/package/go/go.mk b/package/go/go.mk
index 0781dff035..93e1189c23 100644
--- a/package/go/go.mk
+++ b/package/go/go.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-GO_VERSION = 1.8.3
+GO_VERSION = 1.9
 GO_SITE = https://storage.googleapis.com/golang
 GO_SOURCE = go$(GO_VERSION).src.tar.gz