diff mbox series

axel: bump to version 2.15

Message ID 20171011014129.32230-1-ismael@iodev.co.uk
State Changes Requested
Headers show
Series axel: bump to version 2.15 | expand

Commit Message

Ismael Luceno Oct. 11, 2017, 1:41 a.m. UTC
- Change upstream URL.
- Add optional dependency on libressl/openssl.
- Switch to autotools-package.

Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
---
 package/axel/Config.in |  2 +-
 package/axel/axel.hash |  3 +--
 package/axel/axel.mk   | 35 ++++++++++++-----------------------
 3 files changed, 14 insertions(+), 26 deletions(-)

Comments

Thomas Petazzoni Oct. 11, 2017, 9:48 p.m. UTC | #1
Hello,

Thanks for this update!

On Tue, 10 Oct 2017 22:41:29 -0300, Ismael Luceno wrote:

> -ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
> -AXEL_DISABLE_I18N = --i18n=0
> +ifeq ($(BR2_PACKAGE_LIBRESSL),y)
> +AXEL_CONF_OPTS += --with-ssl
> +AXEL_DEPENDENCIES += libressl
> +else ifeq ($(BR2_PACKAGE_LIBRESSL),y)

This should be BR2_PACKAGE_OPENSSL

> +AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)

Such a variable has no effect with the autotools-package
infrastructure, to it is useless.

So you probably want to check instead if it's still needed:

 - To check if -lpthread is needed, build with a glibc toolchain
   toolchain, for example
   support/config-fragments/autobuild/br-arm-cortex-a9-glibc.config

 - To check if $(TARGET_NLS_LIBS) is needed, build with a uClibc
   toolchain, for example
   support/config-fragments/autobuild/br-arm-full.config, and enable
   BR2_SYSTEM_ENABLE_NLS.

Ideally, none of these should be needed, and the configure script of
axel should automatically figure out if it needs to link against
-lpthread and/or -lintl.

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/axel/Config.in b/package/axel/Config.in
index 6e709cfb1351..4507855ff8e7 100644
--- a/package/axel/Config.in
+++ b/package/axel/Config.in
@@ -4,7 +4,7 @@  config BR2_PACKAGE_AXEL
 	help
 	  HTTP/FTP download accelerator.
 
-	  http://axel.alioth.debian.org/
+	  https://github.com/axel-download-accelerator/axel/
 
 comment "axel needs a toolchain w/ threads"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/axel/axel.hash b/package/axel/axel.hash
index 895767011892..a49de66b9497 100644
--- a/package/axel/axel.hash
+++ b/package/axel/axel.hash
@@ -1,2 +1 @@ 
-# Locally calculated
-sha256	359a57ab4e354bcb6075430d977c59d33eb3e2f1415a811948fa8ae657ca8036  axel-2.4.tar.gz
+sha256 70daa27abca5a3f1abe4be833d8f64205ac422416f5bcf396856eb6dd0fe9194  axel-2.15.tar.xz
diff --git a/package/axel/axel.mk b/package/axel/axel.mk
index 60bf5e4a61df..0563d9b6ed95 100644
--- a/package/axel/axel.mk
+++ b/package/axel/axel.mk
@@ -4,33 +4,22 @@ 
 #
 ################################################################################
 
-AXEL_VERSION = 2.4
-AXEL_SITE = http://sources.buildroot.net
+AXEL_VERSION = 2.15
+AXEL_SITE = https://github.com/axel-download-accelerator/axel/releases/download/v$(AXEL_VERSION)
 AXEL_LICENSE = GPL-2.0+
 AXEL_LICENSE_FILES = COPYING
 AXEL_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
-AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)
 
-ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
-AXEL_DISABLE_I18N = --i18n=0
+ifeq ($(BR2_PACKAGE_LIBRESSL),y)
+AXEL_CONF_OPTS += --with-ssl
+AXEL_DEPENDENCIES += libressl
+else ifeq ($(BR2_PACKAGE_LIBRESSL),y)
+AXEL_CONF_OPTS += --with-ssl
+AXEL_DEPENDENCIES += openssl
+else
+AXEL_CONF_OPTS += --without-ssl
 endif
 
-define AXEL_CONFIGURE_CMDS
-	(cd $(@D); \
-		./configure \
-			--prefix=/usr \
-			--debug=1 \
-			$(AXEL_DISABLE_I18N) \
-	)
-endef
-
-define AXEL_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
-	LFLAGS="$(TARGET_LDFLAGS) $(AXEL_LDFLAGS)" -C $(@D)
-endef
-
-define AXEL_INSTALL_TARGET_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
-endef
+AXEL_LDFLAGS = -lpthread $(TARGET_NLS_LIBS)
 
-$(eval $(generic-package))
+$(eval $(autotools-package))