diff mbox

[1/1] webkitgtk: Allow building with BR2_PACKAGE_WEBKITGTK_MULTIMEDIA disabled

Message ID 20170729131844.3502-1-aperez@igalia.com
State Accepted
Headers show

Commit Message

Adrian Perez de Castro July 29, 2017, 1:18 p.m. UTC
Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a
missing feature dependency in the WebKitGTK+ build files.

Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
 package/webkitgtk/webkitgtk.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni July 29, 2017, 1:37 p.m. UTC | #1
Hello,

On Sat, 29 Jul 2017 16:18:44 +0300, Adrian Perez de Castro wrote:
> Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a
> missing feature dependency in the WebKitGTK+ build files.
> 
> Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940
> 
> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
> ---
>  package/webkitgtk/webkitgtk.mk | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Adrian Perez de Castro July 29, 2017, 2 p.m. UTC | #2
On Sat, 29 Jul 2017 15:37:38 +0200, Thomas Petazzoni <thomas.petazzoni@free-electrons.com> wrote:
> Hello,
> 
> On Sat, 29 Jul 2017 16:18:44 +0300, Adrian Perez de Castro wrote:
> > Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a
> > missing feature dependency in the WebKitGTK+ build files.
> > 
> > Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940
> > 
> > Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
> > ---
> >  package/webkitgtk/webkitgtk.mk | 6 +++++-
> >  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> Applied to master, thanks.

Ouch, I've just sent a v2 with an added patch. I'll send the patch addition as
a separate patch so please ignore the v2 then.

Cheers,


--
 Adrián 🎩
Peter Korsgaard Sept. 4, 2017, 7:08 a.m. UTC | #3
>>>>> "Adrian" == Adrian Perez de Castro <aperez@igalia.com> writes:

 > Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a
 > missing feature dependency in the WebKitGTK+ build files.

 > Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940

 > Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>

Committed to 2017.02.x, thanks.
diff mbox

Patch

diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
index b200d23262..e30d07fc1d 100644
--- a/package/webkitgtk/webkitgtk.mk
+++ b/package/webkitgtk/webkitgtk.mk
@@ -40,9 +40,13 @@  WEBKITGTK_CONF_OPTS += \
 	-DENABLE_WEB_AUDIO=ON
 WEBKITGTK_DEPENDENCIES += gstreamer1 gst1-libav gst1-plugins-base gst1-plugins-good
 else
+# ENABLE_MEDIA_STREAM has to be explicitly disabled because there is a missing
+# feature dependency in the WebKitGTK+ CMake files. This can be removed once
+# https://bugs.webkit.org/show_bug.cgi?id=174940 makes it into a release.
 WEBKITGTK_CONF_OPTS += \
 	-DENABLE_VIDEO=OFF \
-	-DENABLE_WEB_AUDIO=OFF
+	-DENABLE_WEB_AUDIO=OFF \
+	-DENABLE_MEDIA_STREAM=OFF
 endif
 
 # Only one target platform can be built, assume X11 > Wayland