diff mbox

toolchain/helpers.mk: fix creation of DESTDIR in copy_toolchain_lib_root

Message ID 20170705145418.25101-1-arnout@mind.be
State Accepted
Headers show

Commit Message

Arnout Vandecappelle July 5, 2017, 2:54 p.m. UTC
In commit b3cc7e65ee, the definition of the DESTDIR variable was moved
down into the loop that follows symlinks in the libraries that are
copied to target. However, the corresponding mkdir was not moved down,
so that no directories are ever created.

In practice, this mkdir is normally redundant since the directories
should already have been created as part of creating STAGING_DIR.
Still, the current situation is clearly wrong, so fix it by moving the
mkdir down to after the assignment to DESTDIR.

While we're at it, also remove a redundant empty line. It's a leftover
from when a lot of variables were declared above.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 toolchain/helpers.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Thomas Petazzoni July 5, 2017, 4:11 p.m. UTC | #1
Hello,

On Wed, 5 Jul 2017 16:54:18 +0200, Arnout Vandecappelle
(Essensium/Mind) wrote:
> In commit b3cc7e65ee, the definition of the DESTDIR variable was moved
> down into the loop that follows symlinks in the libraries that are
> copied to target. However, the corresponding mkdir was not moved down,
> so that no directories are ever created.
> 
> In practice, this mkdir is normally redundant since the directories
> should already have been created as part of creating STAGING_DIR.
> Still, the current situation is clearly wrong, so fix it by moving the
> mkdir down to after the assignment to DESTDIR.
> 
> While we're at it, also remove a redundant empty line. It's a leftover
> from when a lot of variables were declared above.
> 
> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
> ---
>  toolchain/helpers.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)

Applied to master, thanks.

Thomas
diff mbox

Patch

diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 6136aef6b9..9942ce404f 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -10,13 +10,12 @@ 
 #
 copy_toolchain_lib_root = \
 	LIBPATTERN="$(strip $1)"; \
-\
 	LIBPATHS=`find $(STAGING_DIR)/ -name "$${LIBPATTERN}" 2>/dev/null` ; \
 	for LIBPATH in $${LIBPATHS} ; do \
-		mkdir -p $(TARGET_DIR)/$${DESTDIR}; \
 		while true ; do \
 			LIBNAME=`basename $${LIBPATH}`; \
 			DESTDIR=`echo $${LIBPATH} | sed "s,^$(STAGING_DIR)/,," | xargs dirname` ; \
+			mkdir -p $(TARGET_DIR)/$${DESTDIR}; \
 			rm -fr $(TARGET_DIR)/$${DESTDIR}/$${LIBNAME}; \
 			if test -h $${LIBPATH} ; then \
 				cp -d $${LIBPATH} $(TARGET_DIR)/$${DESTDIR}/$${LIBNAME}; \