diff mbox

pngquant: doesn't support building with ccache

Message ID 20170703214355.30076-1-arnout@mind.be
State Accepted
Commit 4a6168db97db6501af42e96091da3218ae64d5c1
Headers show

Commit Message

Arnout Vandecappelle July 3, 2017, 9:43 p.m. UTC
pngquant's homegrown configure script doesn't understand CC with a
space, so we can't use ccache with it. Only the host variant is
affected: for the target, we call ccache from the toolchain-wrapper so
it's transparent to the configure script.

This wasn't seen in the autobuilders since they never enable
BR2_CCACHE.

To test, use any configuration and do
make BR2_CCACHE=y host-pngquant

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/pngquant/pngquant.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard July 3, 2017, 10:32 p.m. UTC | #1
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 > pngquant's homegrown configure script doesn't understand CC with a
 > space, so we can't use ccache with it. Only the host variant is
 > affected: for the target, we call ccache from the toolchain-wrapper so
 > it's transparent to the configure script.

 > This wasn't seen in the autobuilders since they never enable
 > BR2_CCACHE.

 > To test, use any configuration and do
 > make BR2_CCACHE=y host-pngquant

 > Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed, thanks.
Peter Korsgaard July 4, 2017, 3:43 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> writes:

 > pngquant's homegrown configure script doesn't understand CC with a
 > space, so we can't use ccache with it. Only the host variant is
 > affected: for the target, we call ccache from the toolchain-wrapper so
 > it's transparent to the configure script.

 > This wasn't seen in the autobuilders since they never enable
 > BR2_CCACHE.

 > To test, use any configuration and do
 > make BR2_CCACHE=y host-pngquant

 > Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

Committed to 2017.05.x (not in 2017.02), thanks.
diff mbox

Patch

diff --git a/package/pngquant/pngquant.mk b/package/pngquant/pngquant.mk
index 4a6f32fdca..938603a21d 100644
--- a/package/pngquant/pngquant.mk
+++ b/package/pngquant/pngquant.mk
@@ -36,6 +36,7 @@  endef
 define HOST_PNGQUANT_CONFIGURE_CMDS
 	(cd $(@D) && \
 		$(HOST_CONFIGURE_OPTS) \
+		CC=$(HOSTCC_NOCCACHE) \
 		./configure --prefix=$(HOST_DIR)/usr \
 		--without-lcms2 \
 	)