diff mbox

[next,1/3] ed: add host package

Message ID 20170512142848.13956-1-Vincent.Riera@imgtec.com
State Changes Requested
Headers show

Commit Message

Vicente Olivert Riera May 12, 2017, 2:28 p.m. UTC
This will be necessary for updating bc's version in a subsequent patch.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/ed/ed.mk | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Thomas Petazzoni July 16, 2017, 2:05 p.m. UTC | #1
Hello,

On Fri, 12 May 2017 15:28:46 +0100, Vicente Olivert Riera wrote:
> This will be necessary for updating bc's version in a subsequent patch.
> 
> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
> ---
>  package/ed/ed.mk | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)

I had a look at all of this, and my feeling is the same as the
OpenEmbedded folks: this really sucks. Why on earth do they need "ed"?
Why don't they fix their build system to build fbc for the host?

See https://patchwork.openembedded.org/patch/140001/ for the feedback
from OpenEmbedded people. I really don't think there's a compelling
reason to upgrade to 1.07.1 for now, so let's keep 1.06 and avoid this
mess.

I've mailed the submitter of the OE patch, who said he would contact
the upstream GNU bc maintainer, in order to see if he got some
feedback. You are in Cc of this e-mail.

In addition, there was an issue in your patch: GNU bc has moved to GNU
GPLv3+ since this 1.07.1 release, so the licensing details should be
fixed as well.

Best regards,

Thomas
diff mbox

Patch

diff --git a/package/ed/ed.mk b/package/ed/ed.mk
index ada0316..7f69480 100644
--- a/package/ed/ed.mk
+++ b/package/ed/ed.mk
@@ -21,12 +21,29 @@  define ED_CONFIGURE_CMDS
 	)
 endef
 
+define HOST_ED_CONFIGURE_CMDS
+	(cd $(@D); \
+		$(HOST_MAKE_ENV) ./configure \
+		--prefix=/usr \
+		$(HOST_CONFIGURE_OPTS) \
+	)
+endef
+
 define ED_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
+define HOST_ED_BUILD_CMDS
+	$(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
 define ED_INSTALL_TARGET_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" install
 endef
 
+define HOST_ED_INSTALL_CMDS
+	$(HOST_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(HOST_DIR)" install
+endef
+
 $(eval $(generic-package))
+$(eval $(host-generic-package))