diff mbox

[v2] htop: enable unicode if possible

Message ID 20161114110448.9162-1-jezz@sysmic.org
State Accepted
Headers show

Commit Message

Jérôme Pouiller Nov. 14, 2016, 11:04 a.m. UTC
Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
---
 package/htop/htop.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

v2:
  - explicitily enable unicode

Comments

Thomas Petazzoni Nov. 15, 2016, 12:03 p.m. UTC | #1
Hello,

On Mon, 14 Nov 2016 12:04:48 +0100, Jérôme Pouiller wrote:

> +ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),)

You should have used positive logic instead:

ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
enable feature
else
disable feature
endif

> +HTOP_CONF_OPTS = --disable-unicode

You should use += here instead of =, since we are in a condition. This
helps avoiding stupid bugs in the future, if additional CONF_OPTS
assignments are added earlier in the file.

Applied to next with those two issues fixed.

Thanks,

Thomas
diff mbox

Patch

diff --git a/package/htop/htop.mk b/package/htop/htop.mk
index 7409a78..af0f66b 100644
--- a/package/htop/htop.mk
+++ b/package/htop/htop.mk
@@ -7,10 +7,15 @@ 
 HTOP_VERSION = 2.0.2
 HTOP_SITE = http://hisham.hm/htop/releases/$(HTOP_VERSION)
 HTOP_DEPENDENCIES = ncurses
-HTOP_CONF_OPTS = --disable-unicode
 # Prevent htop build system from searching the host paths
 HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/ncurses5-config
 HTOP_LICENSE = GPLv2
 HTOP_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),)
+HTOP_CONF_OPTS = --disable-unicode
+else
+HTOP_CONF_OPTS = --enable-unicode
+endif
+
 $(eval $(autotools-package))