diff mbox

package/nginx-naxsi: add pcre dependency to .mk

Message ID 20160913180102.4825-1-s.martin49@gmail.com
State Superseded
Headers show

Commit Message

Samuel Martin Sept. 13, 2016, 6:01 p.m. UTC
This change completes the commit 218dfdd9038af882a02fe64f13a533c8ce75ddc1.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
---
 package/nginx-naxsi/nginx-naxsi.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Sept. 13, 2016, 7:22 p.m. UTC | #1
Hello,

On Tue, 13 Sep 2016 20:01:02 +0200, Samuel Martin wrote:
> This change completes the commit 218dfdd9038af882a02fe64f13a533c8ce75ddc1.
> 
> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
> ---
>  package/nginx-naxsi/nginx-naxsi.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/nginx-naxsi/nginx-naxsi.mk b/package/nginx-naxsi/nginx-naxsi.mk
> index 0e1f714..ad7749e 100644
> --- a/package/nginx-naxsi/nginx-naxsi.mk
> +++ b/package/nginx-naxsi/nginx-naxsi.mk
> @@ -8,5 +8,6 @@ NGINX_NAXSI_VERSION = 0.54
>  NGINX_NAXSI_SITE = $(call github,nbs-system,naxsi,$(NGINX_NAXSI_VERSION))
>  NGINX_NAXSI_LICENSE = GPLv2+ with OpenSSL exception
>  NGINX_NAXSI_LICENSE_FILES = naxsi_src/naxsi_json.c
> +NGINX_NAXSI_DEPENDENCIES = pcre
>  
>  $(eval $(generic-package))

Is this really necessary? nginx-naxsi is not a real package, it just
allows to download the source code of nginx-naxsi before nginx gets
built.

And nginx.mk already has pcre in NGINX_DEPENDENCIES when pcre is
enabled, so I believe the select added in
218dfdd9038af882a02fe64f13a533c8ce75ddc1 is sufficient.

If not, could you explain why?

Thanks,

Thomas
Samuel Martin Sept. 13, 2016, 7:33 p.m. UTC | #2
Thomas,

On Tue, Sep 13, 2016 at 9:22 PM, Thomas Petazzoni
<thomas.petazzoni@free-electrons.com> wrote:
> Hello,
>
> On Tue, 13 Sep 2016 20:01:02 +0200, Samuel Martin wrote:
>> This change completes the commit 218dfdd9038af882a02fe64f13a533c8ce75ddc1.
>>
>> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
>> ---
>>  package/nginx-naxsi/nginx-naxsi.mk | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/package/nginx-naxsi/nginx-naxsi.mk b/package/nginx-naxsi/nginx-naxsi.mk
>> index 0e1f714..ad7749e 100644
>> --- a/package/nginx-naxsi/nginx-naxsi.mk
>> +++ b/package/nginx-naxsi/nginx-naxsi.mk
>> @@ -8,5 +8,6 @@ NGINX_NAXSI_VERSION = 0.54
>>  NGINX_NAXSI_SITE = $(call github,nbs-system,naxsi,$(NGINX_NAXSI_VERSION))
>>  NGINX_NAXSI_LICENSE = GPLv2+ with OpenSSL exception
>>  NGINX_NAXSI_LICENSE_FILES = naxsi_src/naxsi_json.c
>> +NGINX_NAXSI_DEPENDENCIES = pcre
>>
>>  $(eval $(generic-package))
>
> Is this really necessary? nginx-naxsi is not a real package, it just
> allows to download the source code of nginx-naxsi before nginx gets
> built.
>
> And nginx.mk already has pcre in NGINX_DEPENDENCIES when pcre is
> enabled, so I believe the select added in
> 218dfdd9038af882a02fe64f13a533c8ce75ddc1 is sufficient.

I agree, hence the first patch...

>
> If not, could you explain why?

... but Arnout does not seem to share this opinion [1].

So, I'm tempted to said "maintainer call" on this.


[1] http://lists.busybox.net/pipermail/buildroot/2016-September/172113.html

Regards,
Peter Korsgaard Sept. 17, 2016, 10:11 a.m. UTC | #3
>>>>> "Samuel" == Samuel Martin <s.martin49@gmail.com> writes:

Hi,

 >> Is this really necessary? nginx-naxsi is not a real package, it just
 >> allows to download the source code of nginx-naxsi before nginx gets
 >> built.
 >> 
 >> And nginx.mk already has pcre in NGINX_DEPENDENCIES when pcre is
 >> enabled, so I believe the select added in
 >> 218dfdd9038af882a02fe64f13a533c8ce75ddc1 is sufficient.

 > I agree, hence the first patch...

 >> 
 >> If not, could you explain why?

 > ... but Arnout does not seem to share this opinion [1].

 > So, I'm tempted to said "maintainer call" on this.

 > [1] http://lists.busybox.net/pipermail/buildroot/2016-September/172113.html

I instead added a comment above the select to clarify and marked this
patch as superseeded in patchwork.
diff mbox

Patch

diff --git a/package/nginx-naxsi/nginx-naxsi.mk b/package/nginx-naxsi/nginx-naxsi.mk
index 0e1f714..ad7749e 100644
--- a/package/nginx-naxsi/nginx-naxsi.mk
+++ b/package/nginx-naxsi/nginx-naxsi.mk
@@ -8,5 +8,6 @@  NGINX_NAXSI_VERSION = 0.54
 NGINX_NAXSI_SITE = $(call github,nbs-system,naxsi,$(NGINX_NAXSI_VERSION))
 NGINX_NAXSI_LICENSE = GPLv2+ with OpenSSL exception
 NGINX_NAXSI_LICENSE_FILES = naxsi_src/naxsi_json.c
+NGINX_NAXSI_DEPENDENCIES = pcre
 
 $(eval $(generic-package))