diff mbox

[Bug,7646] strftime on datetime not works on python3.

Message ID 20141113203146.034C3B1290@busybox.osuosl.org
State Not Applicable
Headers show

Commit Message

bugzilla@busybox.net Nov. 13, 2014, 8:31 p.m. UTC
https://bugs.busybox.net/show_bug.cgi?id=7646

--- Comment #11 from Thomas Petazzoni <thomas.petazzoni@free-electrons.com> 2014-11-13 20:31:45 UTC ---
Here is a quick patch that tells Python3 to not use wcsftime() on uClibc, and
it fixes the problem for me:
diff mbox

Patch

diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index 2c1ef2a..e242835 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -107,6 +107,10 @@  PYTHON3_CONF_ENV += \
        ac_cv_file__dev_ptc=yes \
        ac_cv_working_tzset=yes

+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+PYTHON3_CONF_ENV += ac_cv_func_wcsftime=no
+endif
+
 PYTHON3_CONF_OPTS += \
        --without-ensurepip     \
        --without-cxx-main      \