diff mbox

openvpn: Fix paths to external utilities

Message ID 20120930181104.GA2046@gmail.com
State Superseded
Headers show

Commit Message

Valentine Barshak Sept. 30, 2012, 6:11 p.m. UTC
This sets paths to ifconfig, route, netstat and ip
in the target root filesystem.

Otherwise the paths leak from the host and may not
match those on the target.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
---
 package/openvpn/openvpn.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Gustavo Zacarias Sept. 30, 2012, 8:03 p.m. UTC | #1
On 09/30/12 15:11, Valentine Barshak wrote:

> This sets paths to ifconfig, route, netstat and ip
> in the target root filesystem.
> 
> Otherwise the paths leak from the host and may not
> match those on the target.
> 
> Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
> ---
>  package/openvpn/openvpn.mk | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
> index 03eabcf..b7e13f5 100644
> --- a/package/openvpn/openvpn.mk
> +++ b/package/openvpn/openvpn.mk
> @@ -6,7 +6,11 @@
>  
>  OPENVPN_VERSION = 2.2.2
>  OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
> -OPENVPN_CONF_OPT = --enable-small --disable-plugins
> +OPENVPN_CONF_OPT = --enable-small --disable-plugins \
> +			--with-ifconfig-path=/sbin/ifconfig \
> +			--with-route-path=/sbin/route \
> +			--with-netstat-path=/bin/netstat \
> +			--with-iproute-path=/bin/ip

And what happens if i install let's say iproute2 which provides a
nicer/bigger /sbin/ip instead of using the busybox one?
Regards.
Valentine Barshak Sept. 30, 2012, 8:40 p.m. UTC | #2
On 10/01/2012 12:03 AM, Gustavo Zacarias wrote:
> On 09/30/12 15:11, Valentine Barshak wrote:
>
>> This sets paths to ifconfig, route, netstat and ip
>> in the target root filesystem.
>>
>> Otherwise the paths leak from the host and may not
>> match those on the target.
>>
>> Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
>> ---
>>   package/openvpn/openvpn.mk | 6 +++++-
>>   1 file changed, 5 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
>> index 03eabcf..b7e13f5 100644
>> --- a/package/openvpn/openvpn.mk
>> +++ b/package/openvpn/openvpn.mk
>> @@ -6,7 +6,11 @@
>>
>>   OPENVPN_VERSION = 2.2.2
>>   OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
>> -OPENVPN_CONF_OPT = --enable-small --disable-plugins
>> +OPENVPN_CONF_OPT = --enable-small --disable-plugins \
>> +			--with-ifconfig-path=/sbin/ifconfig \
>> +			--with-route-path=/sbin/route \
>> +			--with-netstat-path=/bin/netstat \
>> +			--with-iproute-path=/bin/ip
>
> And what happens if i install let's say iproute2 which provides a
> nicer/bigger /sbin/ip instead of using the busybox one?
> Regards.
>

You'll be surprised to see openvpn fail to find it :)

Unless you build on the latest fedora, which has this stuff in 
/usr/sbin. So you won't see any difference, because it has failed to 
find it before.

I'll submit new version with BR2_PACKAGE_IPROUTE2 check.

Thanks,
Val.
diff mbox

Patch

diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 03eabcf..b7e13f5 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -6,7 +6,11 @@ 
 
 OPENVPN_VERSION = 2.2.2
 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
-OPENVPN_CONF_OPT = --enable-small --disable-plugins
+OPENVPN_CONF_OPT = --enable-small --disable-plugins \
+			--with-ifconfig-path=/sbin/ifconfig \
+			--with-route-path=/sbin/route \
+			--with-netstat-path=/bin/netstat \
+			--with-iproute-path=/bin/ip
 
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
 	OPENVPN_DEPENDENCIES += lzo