diff mbox series

package/volk: bump version to 2.5.2

Message ID 1664265949-22692-1-git-send-email-gwenj@trabucayre.com
State Accepted
Headers show
Series package/volk: bump version to 2.5.2 | expand

Commit Message

Gwenhael Goavec-Merou Sept. 27, 2022, 8:05 a.m. UTC
From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>

- with this release boost has been dropped: all select BR2_PACKAGE_BOOST_XXX
  are removed
- volk now uses functions only available with c++17: adds a depends on for
  gcc > 7.0
- COPYING-GPL is added to volk.hash
- VOLK_LICENSE is updated with LGPL-3.0+

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
 package/volk/Config.in | 9 ++-------
 package/volk/volk.hash | 3 ++-
 package/volk/volk.mk   | 8 ++++----
 3 files changed, 8 insertions(+), 12 deletions(-)

Comments

Yann E. MORIN Oct. 1, 2022, 9:41 p.m. UTC | #1
Gwenhael, All,

On 2022-09-27 10:05 +0200, Gwenhael Goavec-Merou spake thusly:
> From: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> 
> - with this release boost has been dropped: all select BR2_PACKAGE_BOOST_XXX
>   are removed
> - volk now uses functions only available with c++17: adds a depends on for
>   gcc > 7.0
> - COPYING-GPL is added to volk.hash
> - VOLK_LICENSE is updated with LGPL-3.0+

In fact, the licensing and boost and C++17 changes were already present
in the 2.5.2 version, so I've split this patch in three:
  - drop Boost, require C++17
  - fix licensing
  - bump to 2.5.2

Pleas review the licensing changes, I did quite some substantial
rewrites of the corresponding commit log.

The three resulting patches: applied to master, thanks.

Regards,
Yann E. MORIN.

> Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
> ---
>  package/volk/Config.in | 9 ++-------
>  package/volk/volk.hash | 3 ++-
>  package/volk/volk.mk   | 8 ++++----
>  3 files changed, 8 insertions(+), 12 deletions(-)
> 
> diff --git a/package/volk/Config.in b/package/volk/Config.in
> index 95b4a8bdb5..83d58d64ab 100644
> --- a/package/volk/Config.in
> +++ b/package/volk/Config.in
> @@ -1,20 +1,15 @@
>  comment "volk needs a toolchain w/ C++, NPTL, wchar, dynamic library"
>  	depends on BR2_USE_MMU
> -	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
> -	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
> +	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_7 \
>  		!BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
>  
>  config BR2_PACKAGE_VOLK
>  	bool "volk"
>  	depends on BR2_INSTALL_LIBSTDCPP
>  	depends on !BR2_STATIC_LIBS
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # C++17
>  	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
>  	depends on BR2_USE_MMU # use fork()
> -	depends on BR2_USE_WCHAR # boost
> -	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS # boost-filesystem
> -	select BR2_PACKAGE_BOOST
> -	select BR2_PACKAGE_BOOST_FILESYSTEM
> -	select BR2_PACKAGE_BOOST_SYSTEM
>  	help
>  	  VOLK is the Vector-Optimized Library of Kernels. It is a
>  	  library that contains kernels of hand-written SIMD code
> diff --git a/package/volk/volk.hash b/package/volk/volk.hash
> index 0ec96d22ff..b334a7613b 100644
> --- a/package/volk/volk.hash
> +++ b/package/volk/volk.hash
> @@ -1,4 +1,5 @@
>  # Locally computed
> -sha256  3f092737006ad2b7d24852833cf040e725c6f47d68ec2f4197895f84c6400bd8  volk-2.5.1.tar.xz
> +sha256  eff53206cd1ec3314755e0b2bde3c7aaea21dd0f0ad8d753bff07d98e93ddee2  volk-2.5.2.tar.xz
>  sha256  6dcdafa9e750545f5f65c2e6f53820184822db728ac2b8bfe1d4a47da09ec0d6  COPYING
> +sha256  6dcdafa9e750545f5f65c2e6f53820184822db728ac2b8bfe1d4a47da09ec0d6  COPYING-GPL
>  sha256  258f450f060a161fb9f9e2e7c07c6b1ee73e5142297e6792dc1ee76b028cf0ca  COPYING-LGPL
> diff --git a/package/volk/volk.mk b/package/volk/volk.mk
> index e7b004b87f..571a5477b1 100644
> --- a/package/volk/volk.mk
> +++ b/package/volk/volk.mk
> @@ -4,18 +4,18 @@
>  #
>  ################################################################################
>  
> -VOLK_VERSION = 2.5.1
> +VOLK_VERSION = 2.5.2
>  VOLK_SITE = https://github.com/gnuradio/volk/releases/download/v$(VOLK_VERSION)
>  VOLK_SOURCE = volk-$(VOLK_VERSION).tar.xz
>  # See https://github.com/gnuradio/volk/tree/v2.5.1#license for some
>  # details on the licensing.
> -VOLK_LICENSE = GPL-3.0+
> -VOLK_LICENSE_FILES = COPYING COPYING-LGPL
> +VOLK_LICENSE = GPL-3.0+ LGPL-3.0+
> +VOLK_LICENSE_FILES = COPYING COPYING-GPL COPYING-LGPL
>  
>  VOLK_SUPPORTS_IN_SOURCE_BUILD = NO
>  
>  # host-python-mako are needed for volk to compile
> -VOLK_DEPENDENCIES = host-python3 host-python-mako boost
> +VOLK_DEPENDENCIES = host-python3 host-python-mako
>  
>  VOLK_CONF_OPTS = \
>  	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/volk/Config.in b/package/volk/Config.in
index 95b4a8bdb5..83d58d64ab 100644
--- a/package/volk/Config.in
+++ b/package/volk/Config.in
@@ -1,20 +1,15 @@ 
 comment "volk needs a toolchain w/ C++, NPTL, wchar, dynamic library"
 	depends on BR2_USE_MMU
-	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
-	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_7 \
 		!BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
 
 config BR2_PACKAGE_VOLK
 	bool "volk"
 	depends on BR2_INSTALL_LIBSTDCPP
 	depends on !BR2_STATIC_LIBS
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # C++17
 	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
 	depends on BR2_USE_MMU # use fork()
-	depends on BR2_USE_WCHAR # boost
-	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS # boost-filesystem
-	select BR2_PACKAGE_BOOST
-	select BR2_PACKAGE_BOOST_FILESYSTEM
-	select BR2_PACKAGE_BOOST_SYSTEM
 	help
 	  VOLK is the Vector-Optimized Library of Kernels. It is a
 	  library that contains kernels of hand-written SIMD code
diff --git a/package/volk/volk.hash b/package/volk/volk.hash
index 0ec96d22ff..b334a7613b 100644
--- a/package/volk/volk.hash
+++ b/package/volk/volk.hash
@@ -1,4 +1,5 @@ 
 # Locally computed
-sha256  3f092737006ad2b7d24852833cf040e725c6f47d68ec2f4197895f84c6400bd8  volk-2.5.1.tar.xz
+sha256  eff53206cd1ec3314755e0b2bde3c7aaea21dd0f0ad8d753bff07d98e93ddee2  volk-2.5.2.tar.xz
 sha256  6dcdafa9e750545f5f65c2e6f53820184822db728ac2b8bfe1d4a47da09ec0d6  COPYING
+sha256  6dcdafa9e750545f5f65c2e6f53820184822db728ac2b8bfe1d4a47da09ec0d6  COPYING-GPL
 sha256  258f450f060a161fb9f9e2e7c07c6b1ee73e5142297e6792dc1ee76b028cf0ca  COPYING-LGPL
diff --git a/package/volk/volk.mk b/package/volk/volk.mk
index e7b004b87f..571a5477b1 100644
--- a/package/volk/volk.mk
+++ b/package/volk/volk.mk
@@ -4,18 +4,18 @@ 
 #
 ################################################################################
 
-VOLK_VERSION = 2.5.1
+VOLK_VERSION = 2.5.2
 VOLK_SITE = https://github.com/gnuradio/volk/releases/download/v$(VOLK_VERSION)
 VOLK_SOURCE = volk-$(VOLK_VERSION).tar.xz
 # See https://github.com/gnuradio/volk/tree/v2.5.1#license for some
 # details on the licensing.
-VOLK_LICENSE = GPL-3.0+
-VOLK_LICENSE_FILES = COPYING COPYING-LGPL
+VOLK_LICENSE = GPL-3.0+ LGPL-3.0+
+VOLK_LICENSE_FILES = COPYING COPYING-GPL COPYING-LGPL
 
 VOLK_SUPPORTS_IN_SOURCE_BUILD = NO
 
 # host-python-mako are needed for volk to compile
-VOLK_DEPENDENCIES = host-python3 host-python-mako boost
+VOLK_DEPENDENCIES = host-python3 host-python-mako
 
 VOLK_CONF_OPTS = \
 	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3 \